summaryrefslogtreecommitdiff
path: root/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch')
-rw-r--r--app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
new file mode 100644
index 000000000000..5ccef2047bc7
--- /dev/null
+++ b/app-misc/hexcompare/files/hexcompare-1.0.4-Makefile.patch
@@ -0,0 +1,14 @@
+--- hexcompare-1.0.4/Makefile
++++ hexcompare-1.0.4/Makefile
+@@ -1,9 +1,9 @@
+-CFLAGS = -O3 -Wall -Wextra -pedantic -Wformat-security -std=gnu89
++CFLAGS += -Wall -Wextra -pedantic -Wformat-security -std=gnu89
+
+ all: hexcompare
+
+ hexcompare: main.c gui.c
+- $(CC) $(CFLAGS) -o hexcompare main.c gui.c -lncurses
++ $(CC) $(CFLAGS) `pkg-config --cflags ncurses` -o hexcompare main.c gui.c `pkg-config --libs ncurses`
+
+ clean:
+ rm -f *.o