summaryrefslogtreecommitdiff
path: root/app-laptop/rogauracore
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/rogauracore')
-rw-r--r--app-laptop/rogauracore/Manifest4
-rw-r--r--app-laptop/rogauracore/metadata.xml12
-rw-r--r--app-laptop/rogauracore/rogauracore-1.4.ebuild35
-rw-r--r--app-laptop/rogauracore/rogauracore-9999.ebuild35
4 files changed, 86 insertions, 0 deletions
diff --git a/app-laptop/rogauracore/Manifest b/app-laptop/rogauracore/Manifest
new file mode 100644
index 000000000000..2d7797b331dd
--- /dev/null
+++ b/app-laptop/rogauracore/Manifest
@@ -0,0 +1,4 @@
+DIST rogauracore-1.4.tar.gz 10305 BLAKE2B 27e94af50d318a3ce87f87236367aea72ee8daa2b0db896daeaa19bb75b6266faca2aca127d6444b759e6b7029c9f2eee1076ca4a197d70c4dfc2c611f5419ed SHA512 5179bfdfa8eeca5d7ac3ec87e4226429fa8d7987dc2d824a73a8a99142ceaf6fbda16f9844a62ecc8c629c44e334f940dff318bb3e2a3057c0bd1620d0f92c36
+EBUILD rogauracore-1.4.ebuild 630 BLAKE2B 3732d44657e7b1389d1ae00f8483453c04d0d3b0a7cd985b579744b74e479eff16da1bd056b5643b194d1556ebf2ee2309c54df5961aa350a9b98b597039c5b5 SHA512 6d1e374212d977115be88483858d13d64f0712f76197e5f9664ccbcd7dabb7c760c84b3b2e969dd8c8d0e27bff05b5e80681221988be8fc6cf7dc5b9ff47e5ef
+EBUILD rogauracore-9999.ebuild 630 BLAKE2B 3732d44657e7b1389d1ae00f8483453c04d0d3b0a7cd985b579744b74e479eff16da1bd056b5643b194d1556ebf2ee2309c54df5961aa350a9b98b597039c5b5 SHA512 6d1e374212d977115be88483858d13d64f0712f76197e5f9664ccbcd7dabb7c760c84b3b2e969dd8c8d0e27bff05b5e80681221988be8fc6cf7dc5b9ff47e5ef
+MISC metadata.xml 402 BLAKE2B f256ef70a8d2ddaa56f7db9f4abc0a695e70314ff4434322f7737bf19492a63ab53f2d9aef738a7877e9bf1f55a652d23b158c91fe936b3bb5a4d3a5f97e16fb SHA512 191437e9d9bb4b5472cab939b16d75ee41a8882ca4f0aa99aa5d0543ad3494bc101db16324fe521411b8478288f5fd75ac9caa0ea4e20f3007c1311743a240cc
diff --git a/app-laptop/rogauracore/metadata.xml b/app-laptop/rogauracore/metadata.xml
new file mode 100644
index 000000000000..e124668af5fe
--- /dev/null
+++ b/app-laptop/rogauracore/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fordfrog@gentoo.org</email>
+ <name>Miroslav Ć ulc</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">wroberts/rogauracore</remote-id>
+ <bugs-to>https://github.com/wroberts/rogauracore/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-laptop/rogauracore/rogauracore-1.4.ebuild b/app-laptop/rogauracore/rogauracore-1.4.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}
diff --git a/app-laptop/rogauracore/rogauracore-9999.ebuild b/app-laptop/rogauracore/rogauracore-9999.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}