summaryrefslogtreecommitdiff
path: root/app-laptop/rogauracore/rogauracore-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/rogauracore/rogauracore-9999.ebuild')
-rw-r--r--app-laptop/rogauracore/rogauracore-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-laptop/rogauracore/rogauracore-9999.ebuild b/app-laptop/rogauracore/rogauracore-9999.ebuild
new file mode 100644
index 000000000000..a6678b687a8b
--- /dev/null
+++ b/app-laptop/rogauracore/rogauracore-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} = "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="RGB keyboard control for Asus ROG laptops"
+HOMEPAGE="https://github.com/wroberts/rogauracore"
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}