summaryrefslogtreecommitdiff
path: root/app-emulation/conmon/conmon-2.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/conmon/conmon-2.0.9.ebuild')
-rw-r--r--app-emulation/conmon/conmon-2.0.9.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/conmon/conmon-2.0.9.ebuild b/app-emulation/conmon/conmon-2.0.9.ebuild
new file mode 100644
index 000000000000..94ebc62d9c17
--- /dev/null
+++ b/app-emulation/conmon/conmon-2.0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="60b42f20f222df9da07a01ee444327348b9f54ee"
+DESCRIPTION="An OCI container runtime monitor"
+HOMEPAGE="https://github.com/containers/conmon"
+SRC_URI="https://github.com/containers/conmon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="systemd"
+
+RDEPEND="dev-libs/glib:=
+ systemd? ( sys-apps/systemd:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if ! use systemd; then
+ sed -e 's| $(PKG_CONFIG) --exists libsystemd-journal | false |' \
+ -e 's| $(PKG_CONFIG) --exists libsystemd | false |' \
+ -i Makefile || die
+ fi
+}
+
+src_compile() {
+ emake GIT_COMMIT="${EGIT_COMMIT}" \
+ all
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ PREFIX="/usr" \
+ install
+ dodir /usr/libexec/podman
+ ln "${ED}/usr/"{bin,libexec/podman}/conmon || die
+ dodoc README.md
+}