summaryrefslogtreecommitdiff
path: root/app-admin/fifo-cronolog
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/fifo-cronolog')
-rw-r--r--app-admin/fifo-cronolog/Manifest2
-rw-r--r--app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/fifo-cronolog/Manifest b/app-admin/fifo-cronolog/Manifest
index 6d1e05d25906..8995d4879ea4 100644
--- a/app-admin/fifo-cronolog/Manifest
+++ b/app-admin/fifo-cronolog/Manifest
@@ -1,3 +1,5 @@
DIST fifo-cronolog-1.1.1.tar.bz2 3124 BLAKE2B 6e9cb35e0ed1b54c3baed4451742840dc1144294fc675822c1260d4d7d885a52f8835e60dcbed57c714e40e94e6d51b3ba78af9b9892883f5f520a7c57d30df8 SHA512 3ac809d5cfc951764aaf31d50ee394b0dde9ced16f53daa91c81bdb218af2bab410ff945ebfdeb8307a55bda3292c0a55eb500c3cb73595e17228ef739455d90
+DIST fifo-cronolog-1.2.3.tar.gz 4518 BLAKE2B c227304d98b2467a1ed7352399b1e53aba4dc005fa30a1be73b8cc96d61ee49d5f6a3703ccddd1ffef652c4090e9b5dfed9cce3f1254b959a1ccc07aac78b3f6 SHA512 557be1a663c5754a293092078b8a3710474bb1939c1ee65e4c560056238ca646e941e4ad82c0a90c02834fc90ddb2aae9047a4e73d42cf8c2c013f2a5d2c839c
EBUILD fifo-cronolog-1.1.1-r2.ebuild 795 BLAKE2B 7c1137f5d42e6b331d1452de028958f193b7973870bb94e86cb81ba11e672605efeb60ceb75ab8f8dc2595d0c6fbea7c8b1f3debcae4be3a592c32bfe43c18b8 SHA512 0075cbb50a9513ff4540a979b8eecd37d0d2570fb75a5f878011101f9bfb7a453a307745510efdef8847c580f60eb506a668ef8faf4ef82f8b83590735cb735a
+EBUILD fifo-cronolog-1.2.3.ebuild 995 BLAKE2B c871cf33eb7b5560b6839f6459c35e1cffda044ad1d9e54bc39a21bc7f069b581e337361d2e9d1175c46367860f9dde12818303f01571560912d17f460656dd6 SHA512 2945b03d73090597f0ffb3caf429818a3bd23f9088ff856aa750402fd51dc699e36abe75157753bdac785f9beec42eb5df7ab1c15066ee4f93136154266b5a91
MISC metadata.xml 498 BLAKE2B 57ae35e61276c4e4b3fe5c05fbd8bb3bb1c7107b34d1575e49862cb1dea43857c3a34e216c90d77b5ee56f80699757924af1e4d5f36b1d5de41bbe6d58147e2c SHA512 c5dd305bfcdaec5407f1a2d611988701310b232630da863dd062ec32c9a82f733959424a95697d04acbacf8faf147d4d6904b7bff9b3dce4a48356e7a296eb9e
diff --git a/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
new file mode 100644
index 000000000000..940b4376a493
--- /dev/null
+++ b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="cronolog wrapper for use with dumb daemons like squid, varnish and so on"
+HOMEPAGE="https://gitweb.gentoo.org/proj/fifo-cronolog.git"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/cronolog"
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dosbin fifo-cronolog
+ dosym fifo-cronolog /usr/sbin/squid-cronolog
+ dosbin fifo-cronolog-setup
+
+ newinitd openrc/fifo-cronolog.initd fifo-cronolog
+ newconfd openrc/fifo-cronolog.confd fifo-cronolog
+
+ systemd_douserunit systemd/fifo-cronolog@.service
+ dodoc README.md systemd/fifo-cronolog@example.service.env
+}
+
+pkg_postinst() {
+ elog "Warning: app-admin/squid-cronolog has been renamed to app-admin/fifo-cronolog."
+ elog "This also applies to the binary 'squid-cronolog' but there is a symlink for now"
+ elog "Please fix your scripts/configs."
+}