summaryrefslogtreecommitdiff
path: root/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild')
-rw-r--r--app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
new file mode 100644
index 000000000000..940b4376a493
--- /dev/null
+++ b/app-admin/fifo-cronolog/fifo-cronolog-1.2.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="cronolog wrapper for use with dumb daemons like squid, varnish and so on"
+HOMEPAGE="https://gitweb.gentoo.org/proj/fifo-cronolog.git"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-admin/cronolog"
+
+src_compile() {
+ emake all
+}
+
+src_install() {
+ dosbin fifo-cronolog
+ dosym fifo-cronolog /usr/sbin/squid-cronolog
+ dosbin fifo-cronolog-setup
+
+ newinitd openrc/fifo-cronolog.initd fifo-cronolog
+ newconfd openrc/fifo-cronolog.confd fifo-cronolog
+
+ systemd_douserunit systemd/fifo-cronolog@.service
+ dodoc README.md systemd/fifo-cronolog@example.service.env
+}
+
+pkg_postinst() {
+ elog "Warning: app-admin/squid-cronolog has been renamed to app-admin/fifo-cronolog."
+ elog "This also applies to the binary 'squid-cronolog' but there is a symlink for now"
+ elog "Please fix your scripts/configs."
+}