summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-43.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index ee3451e06d10..df6bb79c55ef 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-42.3.tar.xz 3707048 BLAKE2B b1a03cee97ba2ad17e32b863effba46974f86e5cbdcea72235085e369189e8e92cba8b83931fd83a7b859edfc8da9236f462e250c468ad1533768479eb25aad0 SHA512 59d9d61af2e385d8e356f825fc1733d73d136f89a3a06c352eaf1e7b05cd6ebf5bd13282afb478adb4ea7981398db0138324c3e275eb372b99ba648d9fafeab6
+DIST orca-43.0.tar.xz 3758480 BLAKE2B 05c31777c1c88452e165bd7fb6fe75fe727149f5337828b5f4e7679430ed5065a03de7074536c4433bedd81c3090c72e02a775db46f4673d6e3264a57732ad7a SHA512 20248e6065c1daa9c3d6ba37515bab60a3ceb14065b862d6d0610a7659bddc04f49a1cda7850646b45bb0afb5c2a89f1894de96f505831b11b77d332adb747d3
EBUILD orca-42.3.ebuild 1562 BLAKE2B 23c0907b11da9aca993aed45ea94f9bed04553d421fcf76bd241d582f3189943edb8d7e9dd7d09ce158573b06bd71a231126e854cab047a31a2323a52da7d484 SHA512 9ce417d9e0175bf2dd5790a85bfdc6feec6a00b919b18c6dc9ea28d4b899860cc41e8e949f1a2d441dd3d9cf0ff79442bf62b8afc6b12dbe933ff5b6ead149ce
+EBUILD orca-43.0.ebuild 1537 BLAKE2B 53a39f2996779cdbbcd28606174bce7ee08841a654991602cfe51aebed12e45a0ff01cbcc1fd1c5802dea28c276c154f9d32aa24f1ec7fa6dbfee133020b8072 SHA512 5840a3e903c1bc1bac79a2dcb8555a3940c36eba5713426e9a40f34986267f3945bfe29ec6faad9d71faa4eb6ba62a61f1dbb677a30eb11fdfdba6fb0c44edc5
MISC metadata.xml 641 BLAKE2B 2a9a0582cf597e46cf71f11034a17ed3146f5d2709855be3f64530c94be53bdbb7ac8e8be859969706c67e6b32e1f8a33fe97b3e54d41b27a4f6ee3807f19fd6 SHA512 4119f9cc00c1978ada19d63f559ba35bec6299732bf50e3fb724c531dae3c3052e26fb1e7ec7830c55c98ef800ff0a6ecbb01df98e3b64781ff42eb7ef9ce7fb
diff --git a/app-accessibility/orca/orca-43.0.ebuild b/app-accessibility/orca/orca-43.0.ebuild
new file mode 100644
index 000000000000..cedc398c4eb9
--- /dev/null
+++ b/app-accessibility/orca/orca-43.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}