summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4711 -> 4714 bytes
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-43.0.ebuild62
-rw-r--r--app-accessibility/speech-dispatcher/Manifest2
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.11.3.ebuild122
5 files changed, 188 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 6a6cf1027a02..0df12a5d6870 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index ee3451e06d10..df6bb79c55ef 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-42.3.tar.xz 3707048 BLAKE2B b1a03cee97ba2ad17e32b863effba46974f86e5cbdcea72235085e369189e8e92cba8b83931fd83a7b859edfc8da9236f462e250c468ad1533768479eb25aad0 SHA512 59d9d61af2e385d8e356f825fc1733d73d136f89a3a06c352eaf1e7b05cd6ebf5bd13282afb478adb4ea7981398db0138324c3e275eb372b99ba648d9fafeab6
+DIST orca-43.0.tar.xz 3758480 BLAKE2B 05c31777c1c88452e165bd7fb6fe75fe727149f5337828b5f4e7679430ed5065a03de7074536c4433bedd81c3090c72e02a775db46f4673d6e3264a57732ad7a SHA512 20248e6065c1daa9c3d6ba37515bab60a3ceb14065b862d6d0610a7659bddc04f49a1cda7850646b45bb0afb5c2a89f1894de96f505831b11b77d332adb747d3
EBUILD orca-42.3.ebuild 1562 BLAKE2B 23c0907b11da9aca993aed45ea94f9bed04553d421fcf76bd241d582f3189943edb8d7e9dd7d09ce158573b06bd71a231126e854cab047a31a2323a52da7d484 SHA512 9ce417d9e0175bf2dd5790a85bfdc6feec6a00b919b18c6dc9ea28d4b899860cc41e8e949f1a2d441dd3d9cf0ff79442bf62b8afc6b12dbe933ff5b6ead149ce
+EBUILD orca-43.0.ebuild 1537 BLAKE2B 53a39f2996779cdbbcd28606174bce7ee08841a654991602cfe51aebed12e45a0ff01cbcc1fd1c5802dea28c276c154f9d32aa24f1ec7fa6dbfee133020b8072 SHA512 5840a3e903c1bc1bac79a2dcb8555a3940c36eba5713426e9a40f34986267f3945bfe29ec6faad9d71faa4eb6ba62a61f1dbb677a30eb11fdfdba6fb0c44edc5
MISC metadata.xml 641 BLAKE2B 2a9a0582cf597e46cf71f11034a17ed3146f5d2709855be3f64530c94be53bdbb7ac8e8be859969706c67e6b32e1f8a33fe97b3e54d41b27a4f6ee3807f19fd6 SHA512 4119f9cc00c1978ada19d63f559ba35bec6299732bf50e3fb724c531dae3c3052e26fb1e7ec7830c55c98ef800ff0a6ecbb01df98e3b64781ff42eb7ef9ce7fb
diff --git a/app-accessibility/orca/orca-43.0.ebuild b/app-accessibility/orca/orca-43.0.ebuild
new file mode 100644
index 000000000000..cedc398c4eb9
--- /dev/null
+++ b/app-accessibility/orca/orca-43.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index 32801a0de20b..214a15054a00 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -3,8 +3,10 @@ AUX speech-dispatcher-0.11.1-remove-unused-variable-musl.patch 1106 BLAKE2B 0a21
AUX speech-dispatcher-0.9.1-fno-common.patch 13112 BLAKE2B 6a4125117852cfe250bed1a9936af67a2a83303ecced615febd89b9b14918dda94a78862cdcceb95fcea3ea7ed30a12d799afbc21264ff386c94f9f867eb8136 SHA512 b957ebbfd8a6a9cfe2b85cba85b77dc813e76212721d63d42b3881ed17993d7b4a8c720d4c431c8e2eb3ea60996e411402732c735948f37fa84a9fdcfa2683fc
DIST speech-dispatcher-0.11.1.tar.gz 6548489 BLAKE2B fd4e05c51b80991bdd5d27ecf967946cfde98f978462e909f193c14eab51f3cae047d281c3e2896b3ddeeb4e045ceb72f51e5dbfaf3f9ea8a818f8146cb5e625 SHA512 859911d7db5660423bc7911eacbe8e7a9c3104df97478cbbca48ca5fd6ec018113172d49bc66781680433c77b4d2af43578c9b0f11409e2ba7ac618deb31d7cf
DIST speech-dispatcher-0.11.2.tar.gz 7147526 BLAKE2B 6b11949736275d900e5e1d3909fab51fc04fbb45baf470a4c98aed19f61b7adb8cedf6b11f1a1aa69d9625383627beab4122c74ec78d9c07a5d0ddf4646669d6 SHA512 038ecaa5b9d56e3f915ec49fe7768cb4eebe1c8be79b95635f09fb3f6067e4c0ade13d2dd355e0b326579dcdf509dd180889b27282410b6bb252a2f642f028d4
+DIST speech-dispatcher-0.11.3.tar.gz 7150632 BLAKE2B 92bad589e453a243362a9e0142d2897b9651fa648012f2bd7ef00bc1ded389fd2c01b6f38f19002289357f7aa6361a6e7fa3ee35ec2ad7c044f34d87e7f2c409 SHA512 e9f5b862066c0292230fda32f16782f9a2d66e8d0c0e3aa0ccdb4628c1182661d2f40894f480ae5206af7fbbc49338189312afe02092f5d472095b053afd75c7
DIST speech-dispatcher-0.9.1.tar.gz 1662222 BLAKE2B 03c3d79a9cbbe7e549f638992fb276ab2270a45a057708721666257699479b3feb81daddf26d8032ba3f7b9ab6b836c7f582ee22a532ff018c99820af3864d87 SHA512 35adb353d22b8dff8884cb20f3836f96f4f74b272bbd442d522a10a3d3b91a0da6705e6c216764f295208b5446c2077da620de2a81cafe5a0c4dd826e33753c2
EBUILD speech-dispatcher-0.11.1.ebuild 2933 BLAKE2B d9235a55cbce83da1fc223646853d948c93de097ddfede44ffb62ffc4e43dc407459b4666c95b5937a920722e689fa61bb7902d6cc0ab46382d0e5a71be7953c SHA512 a245da1e1b7675926da1e26a43a9977e6bb76e58ae3f4a714621e04d02b8b419a8565b047557e9d18b49f7a5b2cdadde2583dd5006840645ec3ec02bc0b16059
EBUILD speech-dispatcher-0.11.2.ebuild 2875 BLAKE2B d35c1758c898ae5f372e5df5980274da3a60563f52fba4a4f66edb2a117540079d67c3fca908472fb2704bc060211fcdb7cbca983c2fd2213138d108e50af2fd SHA512 60c71675b0db44bd1fe2f8c78c3192e4b78ec520a50c82782f8bb3bad887fc562d2e56f788460e595f060f6649bc8194317ecd7ec877c654586a98727abe7a65
+EBUILD speech-dispatcher-0.11.3.ebuild 2875 BLAKE2B 7e43633fa593175d1bf889e1f11004c5d95973a0eaa25b9005dc7abc116e9cf393d2a708b92849a2d1581c3d5adf5da4cad711d2cefc7e53e91129a3095dab06 SHA512 e0180013b2599505b0bbcae9dc4dfaf1621af0b699bae5c88f81f7b550791371139113cef98ffcbc3de4a7bd689bf068c5e1e300ddc96cbd00b4dd28ca99a91c
EBUILD speech-dispatcher-0.9.1.ebuild 2835 BLAKE2B f840d158b1303532c3fd0f41f9e40bac941d06071a125bcbef0341e75cc0197fe29a47d495b8248bc714cf2f8da3981660b95aa91d8b178fb72a7c4a23303b51 SHA512 2e0e8b16492ee0922199389e05e7d24103d4090b218378ce3f50111705084515c112d9e363f6dabc6d10dee75e4bdbb5f7c794f4b7b6562baa11798f3dff0dc9
MISC metadata.xml 708 BLAKE2B fdccc4d8de7f22eb64469021786480527bd87f3718dd5746426874266b8a46dcb6cc2b7bb25a4561a523362b919e0ed77e3f829f3fe269d90060d17a69f1b2ed SHA512 770e54e5ddeacc46165b90d41dd3ea0d1060adfdfb95055a9dab778f757189b892250e66b515773ce7b4d8b1bbdd692386b4d8cb49d670af7af8dadfed5c8788
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.3.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.3.ebuild
new file mode 100644
index 000000000000..c55d7ced1ded
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.11.3.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-r1 systemd
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="https://freebsoft.org/speechd"
+SRC_URI="https://github.com/brailcom/speechd/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="alsa ao espeak +espeak-ng flite nas pulseaudio python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/dotconf-1.3
+ >=dev-libs/glib-2.36:2
+ >=media-libs/libsndfile-1.0.2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak )
+ espeak-ng? ( app-accessibility/espeak-ng )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${DEPEND}
+ python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
+BDEPEND="
+ sys-apps/help2man
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.11.1-include-pthread_h.patch
+)
+
+src_configure() {
+ # bug 573732
+ export GIT_CEILING_DIRECTORIES="${WORKDIR}"
+
+ local myeconfargs=(
+ --disable-ltdl
+ --disable-python
+ --disable-static
+ --with-baratinoo=no
+ --with-ibmtts=no
+ --with-kali=no
+ --with-pico=no
+ --with-voxin=no
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak)
+ $(use_with espeak-ng)
+ $(use_with flite)
+ $(use_with nas)
+ $(use_with pulseaudio pulse)
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ emake
+
+ if use python; then
+ building() {
+ cd src/api/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ default
+
+ if use python; then
+ installation() {
+ cd src/api/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ python_foreach_impl python_optimize
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak-ng; then
+ ewarn "You have disabled espeak-ng, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}/etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+}