summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
commitebd51986f51b430f84c569c6c0f2fe051158d444 (patch)
tree0f4e961f34bca6c29cb4defea06a6595fa460d58 /xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
parentd1f1f3bc630772e7197391e85311655e2b6e7fa2 (diff)
gentoo auto-resync : 21:04:2023 - 18:02:52
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
new file mode 100644
index 000000000000..0b3c640eff9c
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-indicator-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-indicator-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/ayatana-ido-0.4.0
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/libayatana-indicator-0.5.0:3
+ >=x11-libs/gtk+-3.18.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.13.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}