summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-indicator-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 18:02:52 +0100
commitebd51986f51b430f84c569c6c0f2fe051158d444 (patch)
tree0f4e961f34bca6c29cb4defea06a6595fa460d58 /xfce-extra/xfce4-indicator-plugin
parentd1f1f3bc630772e7197391e85311655e2b6e7fa2 (diff)
gentoo auto-resync : 21:04:2023 - 18:02:52
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest b/xfce-extra/xfce4-indicator-plugin/Manifest
index 19e87175a49b..73b79b2fc512 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-indicator-plugin-2.4.1.tar.bz2 406823 BLAKE2B e24107888c8af7206111b4d6b8058e871b97aa687116684a3251cf731f9925bed1cfec3c1fd8a66794c6fc31bd631a4cdc7924972956c12eac3b12f4d7f18831 SHA512 a5b9b25b405888a69708eb43656ac58a728d4a5a9736b5513d23b17409b5d8a0230cf89e6243afde5b1a3edad43b38915d007551347c85a7d17364760c2dabba
+DIST xfce4-indicator-plugin-2.4.2.tar.bz2 386998 BLAKE2B bca9874ac6bcdafcc92a9f3aea4cb58ad0435650359966d1967dd9502ab69a019040b3ed4eb35e21115bc6cc54980ae8f7b6d38bbfc0a3b24c539cc87f192a0a SHA512 ed778cfb2daa55edded450114b9ba83ca6050a549572d6f09294b9e89cc927f8abc79deb008f8ff6933dab35a16f5ba819b14d1d7f6b7464e1cd809aabaaad6b
EBUILD xfce4-indicator-plugin-2.4.1.ebuild 1115 BLAKE2B 810a1b9c627675ca87c47d9c4348eef8c95adafb5d6e5213312b1d2d066805a087e46d891091d41494cd4f5951baa52ad8bec21614f9df0f0d18f127182ffe80 SHA512 a832e5db845411109ada4c102071265da46dc4a3b0d164d17a183fa90b6a994d187f21f4016ce6f86a5df76f443b65d70c8def965ec66aef89b27fde14b27fc2
+EBUILD xfce4-indicator-plugin-2.4.2.ebuild 1170 BLAKE2B b94e1f770f3ec5998493eb628cf7e6ed339ce8caeb300d222c087c46ba4c68c8491bd26cf64cbc329c0cdd33bde3557c44c61ff1aa3cf0c2816a866abe07e721 SHA512 efd0bf9408c8562df0ed46ddf4f24cf982c4ef35f159dcf2c95244ccb5b47927ee5304a38a645cb4e595542f2d92f94c4faba11910c236d32d9f6f61cf02c369
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
new file mode 100644
index 000000000000..0b3c640eff9c
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-indicator-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-indicator-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/ayatana-ido-0.4.0
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/libayatana-indicator-0.5.0:3
+ >=x11-libs/gtk+-3.18.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.13.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-ido
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}