summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-calculator-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /xfce-extra/xfce4-calculator-plugin
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'xfce-extra/xfce4-calculator-plugin')
-rw-r--r--xfce-extra/xfce4-calculator-plugin/Manifest3
-rw-r--r--xfce-extra/xfce4-calculator-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild39
3 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-calculator-plugin/Manifest b/xfce-extra/xfce4-calculator-plugin/Manifest
new file mode 100644
index 000000000000..818028d47085
--- /dev/null
+++ b/xfce-extra/xfce4-calculator-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST xfce4-calculator-plugin-0.7.1.tar.bz2 402401 BLAKE2B feadd3401f5e7b3bd1bc9277e04d63329fa0d35583c6af959fa350c6622012b4089fd1143dd8f7e987cde8a6b313fba75cfba751e2afb6bcba43d9787d17784b SHA512 05544e5f0e293fe44ae35b3e11a2e6fac8df13743649d0702c01c6a4b2df0557f8f9712acef6bd51aaa65f5542234a6a649017bf2fe2a6d2860ae2e534e7cff2
+EBUILD xfce4-calculator-plugin-0.7.1.ebuild 778 BLAKE2B 5b0801a6f7bac24f1160eb0922a8ca8d37f8927456dbba368d1b6aeb1351d8abc10b94cf80ae80d3e28d024ca5711e2f7670d949c44d8141de93b5525c39f860 SHA512 37379347e33331322534f0f6f22825fa67d7b20d728f6c8cd1383f4067e1c4ddb962a69d1255b58ac82456878289a35ec6d2d1eaf04509c96df7dad4880840cd
+MISC metadata.xml 241 BLAKE2B 19a1f7371ba9451232b7795e806499d1de2aba44dc9864bf1c8c72f6074af18387f6091c891f84c402c70e52f8502bc7a9a937828d63991402d2f0d17b247782 SHA512 97a8057b496da7d18b75e0cec2f5de16f7f16187776c3d7134ade6b0be2539c5f0e8de7ce43c2a4fc342ca9c3dd83a74c194a506ad28221c260dfa8a4eadb1e8
diff --git a/xfce-extra/xfce4-calculator-plugin/metadata.xml b/xfce-extra/xfce4-calculator-plugin/metadata.xml
new file mode 100644
index 000000000000..dce6704738a4
--- /dev/null
+++ b/xfce-extra/xfce4-calculator-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild
new file mode 100644
index 000000000000..73c8878dc5b1
--- /dev/null
+++ b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A calculator plugin for the Xfce4 panel"
+HOMEPAGE="https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}