summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild')
-rw-r--r--xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild
new file mode 100644
index 000000000000..73c8878dc5b1
--- /dev/null
+++ b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A calculator plugin for the Xfce4 panel"
+HOMEPAGE="https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libX11
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}