summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild')
-rw-r--r--x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
new file mode 100644
index 000000000000..e758ba522eee
--- /dev/null
+++ b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="dockapp showing the load of every logical CPU on the system"
+HOMEPAGE="https://bitbucket.org/StarFire/wmcpuwatch"
+SRC_URI="https://bitbucket.org/StarFire/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( ChangeLog README.md )
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use doc || sed -e "s/add_subdirectory(doc)//" -i CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/html
+}