summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcpuwatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /x11-plugins/wmcpuwatch
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'x11-plugins/wmcpuwatch')
-rw-r--r--x11-plugins/wmcpuwatch/Manifest3
-rw-r--r--x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch33
-rw-r--r--x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild (renamed from x11-plugins/wmcpuwatch/wmcpuwatch-0.2.ebuild)20
3 files changed, 52 insertions, 4 deletions
diff --git a/x11-plugins/wmcpuwatch/Manifest b/x11-plugins/wmcpuwatch/Manifest
index 20c96e991f05..148051b967d9 100644
--- a/x11-plugins/wmcpuwatch/Manifest
+++ b/x11-plugins/wmcpuwatch/Manifest
@@ -1,3 +1,4 @@
+AUX wmcpuwatch-0.2-cmake.patch 1376 BLAKE2B 5bee8323ebed3418220688964e709f7f657b91ffea780dd073464dddf3a30cfbb06d741cf0a50ac8a727dacbe428cc7ea6f8e5e8d8a5102f197034b16d5b284d SHA512 9e2f55aac2fc2d12556b70c05cd30cacd2fc8acdc3b6f955473a02b18fc2e705adcd6954e23051dbfdc8a51734a69446a20f459df0295e3a0e74459ff8729a5c
DIST wmcpuwatch-0.2.tar.bz2 55621 BLAKE2B 5be49c22b7f063fe2cf4fb91358665903018500d51f56731b0f3584fec011031ec03fdb650722634aaf3b8b9a29e9f7d048b73fcc88b20e469607472cf827e69 SHA512 25aa3fb2d416035a7f3afbec58b2166338009e57310166e91719f6b5cfc4a1e05600ef0ec381c1ff56964848dac1e8ed272cbc4e352dbcc2751addd2cddd2e6e
-EBUILD wmcpuwatch-0.2.ebuild 450 BLAKE2B ea698bbf2a78f1011692074b211799da6a73762ef45d5b7e780784744de0dd4edfeec7d077e88c1db5aa7b3b067d825651279c67aabee6e65ea2087ef01a3d68 SHA512 ee48e13abf455514add333e39f19ade82e1b348a627d2a4baa8a5730fa74eb6d0c1b2c3405190576c5145c94f66be5239201b536a9295d03e5403ad55f3e56a5
+EBUILD wmcpuwatch-0.2-r1.ebuild 762 BLAKE2B 9af1e94b7599686d532c6e097129a622eb97bf5c62634fd18c294433e1baff805251c4ae09ef60728371cd29642add881c1ac3dc31121540ba08b8b21e34ed15 SHA512 3f6118e0c18b462d6e10f1ba6c67d239adfddde1a8800f13cf24eae77e85f23f28c00d790e0a165374c5131595618dace4901adb1b6ac13d6136e2b156a92127
MISC metadata.xml 779 BLAKE2B 55a1b5288840f3bcb34fc4e1fdf1790b9f3dfd8454816caaea58c19f1ef9156fd3deea1be0540d4c3fc10701aec04da0a51d4beb35b81e7c892a5a25e6d3ea08 SHA512 7cced753e2d94d9f1d4265269797c690ed732dcf3943ea8263d7408c9e295a0e2d26aecf9dd9e0b0805dfcb0ecc355f87764ec65292c78a822dcd00d85d3c011
diff --git a/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch b/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch
new file mode 100644
index 000000000000..bd3ddac62403
--- /dev/null
+++ b/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch
@@ -0,0 +1,33 @@
+diff -Naur wmcpuwatch-0.2.orig/CMakeLists.txt wmcpuwatch-0.2/CMakeLists.txt
+--- wmcpuwatch-0.2.orig/CMakeLists.txt 2017-09-03 13:58:43.000000000 +0200
++++ wmcpuwatch-0.2/CMakeLists.txt 2018-01-01 22:28:19.108393247 +0100
+@@ -26,6 +26,7 @@
+ #
+ # Define include directories
+ include_directories(
++ "${PROJECT_BINARY_DIR}"
+ ${DOCKAPP_INCLUDE_DIR}
+ ${X11_X11_INCLUDE_PATH})
+
+@@ -56,8 +57,6 @@
+ install(TARGETS wmcpuwatch RUNTIME DESTINATION bin)
+ install(FILES wmcpuwatch.1 DESTINATION share/man/man1)
+ install(FILES wmcpuwatch.desktop DESTINATION share/applications)
+-install(FILES README.md DESTINATION share/doc/${CMAKE_PROJECT_NAME})
+-install(FILES ChangeLog DESTINATION share/doc/${CMAKE_PROJECT_NAME} RENAME changelog)
+
+ #
+ # Create a source tarball using CPack
+diff -Naur wmcpuwatch-0.2.orig/doc/CMakeLists.txt wmcpuwatch-0.2/doc/CMakeLists.txt
+--- wmcpuwatch-0.2.orig/doc/CMakeLists.txt 2017-09-03 12:00:37.000000000 +0200
++++ wmcpuwatch-0.2/doc/CMakeLists.txt 2018-01-01 22:33:00.690614708 +0100
+@@ -20,9 +20,6 @@
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating code documentation"
+ VERBATIM)
+-
+- # Install the documentation
+- install(DIRECTORY html DESTINATION share/doc/${CMAKE_PROJECT_NAME})
+ else (DOXYGEN_FOUND)
+ message("doxygen not installed: Not creating code documentation")
+ endif (DOXYGEN_FOUND)
diff --git a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2.ebuild b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
index d475e3e240e7..e758ba522eee 100644
--- a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2.ebuild
+++ b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,7 +11,21 @@ SRC_URI="https://bitbucket.org/StarFire/${PN}/downloads/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="doc"
RDEPEND=">=x11-libs/libdockapp-0.7:="
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+DOCS=( ChangeLog README.md )
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use doc || sed -e "s/add_subdirectory(doc)//" -i CMakeLists.txt || die
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc -r "${BUILD_DIR}"/doc/html
+}