summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild')
-rw-r--r--x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
index e758ba522eee..0edf74c5ae37 100644
--- a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
+++ b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+inherit cmake
DESCRIPTION="dockapp showing the load of every logical CPU on the system"
-HOMEPAGE="https://bitbucket.org/StarFire/wmcpuwatch"
-SRC_URI="https://bitbucket.org/StarFire/${PN}/downloads/${P}.tar.bz2"
+HOMEPAGE="https://bitbucket-archive.softwareheritage.org/projects/st/StarFire/wmcpuwatch.html"
+SRC_URI="https://bitbucket-archive.softwareheritage.org/static/83/8395d160-de4b-42d6-a7d9-939eade4f58a/attachments/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
@@ -14,18 +14,18 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND=">=x11-libs/libdockapp-0.7:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
DOCS=( ChangeLog README.md )
PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use doc || sed -e "s/add_subdirectory(doc)//" -i CMakeLists.txt || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${BUILD_DIR}"/doc/html
}