summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /x11-plugins
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin28082 -> 28075 bytes
-rw-r--r--x11-plugins/pidgin-encryption/Manifest2
-rw-r--r--x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild (renamed from x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild)25
-rw-r--r--x11-plugins/pidgin-telegram/Manifest3
-rw-r--r--x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch101
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild5
-rw-r--r--x11-plugins/wmcpuwatch/Manifest4
-rw-r--r--x11-plugins/wmcpuwatch/metadata.xml3
-rw-r--r--x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild18
9 files changed, 132 insertions, 29 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 2fc2e381322b..923ca25f8b24 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/pidgin-encryption/Manifest b/x11-plugins/pidgin-encryption/Manifest
index 7fc45ad69def..d27eb7c1f4d5 100644
--- a/x11-plugins/pidgin-encryption/Manifest
+++ b/x11-plugins/pidgin-encryption/Manifest
@@ -1,4 +1,4 @@
AUX pidgin-encryption-3.1-glib2.32.patch 381 BLAKE2B 0f62640d14f2da191de008f7a5a984d2a1462400eccc9c83e890fbdb0e4be271cac9e692af2619307de95ddc198e2d0e19a36dde55d617ddcdd69d15f90455df SHA512 1c6b3c34d0e8acab7dd4465348d674b56d8939305e87dc9e59bd14e99e7123e865c4e6a91f641e3365c507b2d88e19541f05534b3255ab23754d95d49c997639
DIST pidgin-encryption-3.1.tar.gz 604129 BLAKE2B d42c6baf9e1b0adcb8e88a611279fa66f6c37ce3e89c742c6a8e2662662576cc9e08c8e3fa08c19e857b88165b840826f9118c5bcca0098b7eb02fac0a8ae159 SHA512 681e719dacc6812f6e965b5025631b02dc6abe4694c4dfc3034d5c07e97798707f28920c142b99f9d428470ef5c14bffe5d7c62d2d5fce01ad0e7567ab60b32d
-EBUILD pidgin-encryption-3.1.ebuild 727 BLAKE2B efcc7e2b3042ff5985d17abd8544222f3c8c0164e25ebd378d1a6db3ac068664757ef969416740e57ed4066324d3d62affdb985af55ea560764bedfecbea881b SHA512 b75cd4d2e112416c3c5220e2f878176ab7b00f593131004789f0459f96784eed7a8feb6aca9c0546e7341b715b211eae114527ba96ea1e287d2ea25a1a2ca76b
+EBUILD pidgin-encryption-3.1-r1.ebuild 736 BLAKE2B dbaf9a51fdd834c7d9535ecb420cb1fbaecc460519eec862796dea9147bd587b5e1a2cbee83f8622388007174f2d18d64dcaf694ac8c149d5be5b4cfaf575042 SHA512 52dab8918a7080257dd19d7bb18b89e0b6be277c218d7e0282b7e4a84183496f00643f99b341a7c9b91ef018620c4fa94018eb28788cf437c4b9be05c0c16cfe
MISC metadata.xml 251 BLAKE2B 5461a66aa7bd7a3a15d3683470b35e5599778fd3000f5087f77190ea0e75dfa69dc059757a326c4c323ce5f10518144ef30ecd61fcbc8a6abb1b3ae43dbb89c7 SHA512 a375797fe97db08ac4975c1fc0d8630f65597b2d764f93fc119eda3f7454c094968cb321497b45b63be43221517498b15862b20380600d058d4b9d1376380044
diff --git a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
index 561a3df71d68..28f7c2dbaecf 100644
--- a/x11-plugins/pidgin-encryption/pidgin-encryption-3.1.ebuild
+++ b/x11-plugins/pidgin-encryption/pidgin-encryption-3.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit flag-o-matic eutils
+inherit flag-o-matic
DESCRIPTION="Pidgin IM Encryption PlugIn"
HOMEPAGE="http://pidgin-encrypt.sourceforge.net/"
@@ -14,24 +14,25 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 sparc x86"
IUSE="nls"
-RDEPEND="net-im/pidgin[gtk]
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ >=dev-libs/nss-3.11
+ net-im/pidgin[gtk]
x11-libs/gtk+:2
- >=dev-libs/nss-3.11"
+"
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-glib2.32.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-glib2.32.patch"
+)
src_configure() {
strip-flags
replace-flags -O? -O2
- econf $(use_enable nls)
+ econf $(use_enable nls) --disable-static
}
src_install() {
- emake install DESTDIR="${D}"
+ emake install DESTDIR="${ED}"
dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
}
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index 21fbb5ae9626..407cd47337e5 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1,4 +1,5 @@
AUX pidgin-telegram-1.4.3-change-metadata-location.patch 1749 BLAKE2B ad5dd197f162223d31d802259c183e4285921ee3270010bc2d6070048d625a4ca5e0c0457c26a65396aba1fb9dbbea5bf87ef21513782a06ad3d69dd4018b47e SHA512 fc42f57d033a5f5192a104fb1c364b44a54a54059613989c147fdb741ebcb3eb1b4870a5325260e8b6f4b328ad0d74f1e236c5540f5ff837054ff99c6c9f4b14
+AUX pidgin-telegram-1.4.3-clang.patch 3674 BLAKE2B c1fb52b984168afcd576b429ab97f92b44a04bdbe39af9f98c71a76bb0a18c9b82a0b7e16a5dd0c70cbd0d743a3a597b2cae9eea9ee04cb98674699452b0fea2 SHA512 f855a52582dc05266e3ac1410af668f6ce6e7f9a074d514b07c5d7c39b317f338967c41732f56db427bd3ab33b91af67d0df354ae1d43663abc45fd4edacfd02
DIST telegram-purple_1.4.3.orig.tar.gz 491997 BLAKE2B 30d42b34525c6553498c67f8a28cfe789442555a3a135a116195edc982611b8ccae6d7c53006358ebdca679258ae6a40b29a1d2ebb764e082bc2ee77d39584db SHA512 697d070da5c6671dd54a1709b37153d4b569ae1cd19d574a2d92a777a89ebd7884596b35829564a7f6fd49104f5d26e35cbe9634f64c678b5f061af8197fba16
-EBUILD pidgin-telegram-1.4.3.ebuild 1250 BLAKE2B 9d53fd821a4f85ec5d21abf7617812c2659eec182ad32c7721aac3c5bece03cae7b82694b6f9e4a709fb83c76493268bedf199ec549a2792f12d15ec5e4b5214 SHA512 311265d1515aa5d83e3be71374573984ee99f5e0738794df1d7ac447f919223cef795f72e3a9a044b53e5c2abbb62e1ba43fa1d106c07cafdfa0a2eed440020b
+EBUILD pidgin-telegram-1.4.3.ebuild 1287 BLAKE2B 62c3af492fe528b4628836c27ef4fd98cccd4259713313bd71ede962aad93faab48eddc66ef579450c24cb573645805259a638e3939cb5f1925307fcb5f42427 SHA512 420a1b1e1476bdcaab4d74add52033dfa57c97b4f6e3d3dddff4957d736eda3931080d0ca205070f1d68049b9ac53fddf4f2ee0d59a73bff0c524f614d66dda5
MISC metadata.xml 722 BLAKE2B fb8498a592b6da08fda5cb1961fd84ea2a4e839233719330625166f487f2d01e8000860d2383488ea1c377105f8d74aae928871f349ed08efda1dd7c0420db10 SHA512 6b7e5121c5662de9943b7b7d30e6acf6c2df04b5c9d19b3ce942b6e403e62023f1a07076c4023d899ccb97f7fd2a29b331f9bf76391cb5db1c477d5bfce088c8
diff --git a/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch b/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch
new file mode 100644
index 000000000000..d7d00d6234e3
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-clang.patch
@@ -0,0 +1,101 @@
+From b196e11eabb14d11e5a6b4c3cd65bf115a71f0d9 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Wed, 16 Sep 2020 20:55:21 +0200
+Subject: [PATCH] configure: fix compilation with clang
+
+If -L/usr/lib is being included, this will break compiling on 64-bit with clang.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ configure | 11 ++++-------
+ 1 file changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/configure b/configure
+index 5142055..aed9234 100755
+--- a/configure
++++ b/configure
+@@ -2283,11 +2283,10 @@ ac_config_headers="$ac_config_headers config.h"
+ #
+ # If both header file and library are found, shell commands
+ # 'action-if-found' is run. If 'action-if-found' is not specified, the
+-# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, appends
+-# '-L$ZLIB_HOME}/lib' to LDFLAGS, prepends '-lz' to LIBS, and calls
+-# AC_DEFINE(HAVE_LIBZ). You should use autoheader to include a definition
+-# for this symbol in a config.h file. Sample usage in a C/C++ source is as
+-# follows:
++# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS,prepends '-lz'
++# to LIBS, and calls AC_DEFINE(HAVE_LIBZ). You should use autoheader to
++# include a definition for this symbol in a config.h file.
++# Sample usage in a C/C++ source is as follows:
+ #
+ # #ifdef HAVE_LIBZ
+ # #include <zlib.h>
+@@ -4079,7 +4078,6 @@ then
+ ZLIB_OLD_LDFLAGS=$LDFLAGS
+ ZLIB_OLD_CPPFLAGS=$CPPFLAGS
+ if test -n "${ZLIB_HOME}"; then
+- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
+ CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
+ fi
+
+@@ -4152,7 +4150,6 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+ #
+
+ CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
+- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
+ LIBS="-lz $LIBS"
+
+ $as_echo "#define HAVE_LIBZ 1" >>confdefs.h
+--
+2.28.0
+
+From b7d92ac6c01f006dde8d317a4311497c6eda0bd7 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Wed, 16 Sep 2020 21:02:07 +0200
+Subject: [PATCH] configure: fix compilation with clang
+
+If -L/usr/lib is being included, this will break compiling on 64-bit with clang.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ configure | 11 ++++-------
+ 1 file changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/tgl/configure b/tgl/configure
+index 701a5d6..7ff1dac 100755
+--- a/tgl/configure
++++ b/tgl/configure
+@@ -2245,11 +2245,10 @@
+ #
+ # If both header file and library are found, shell commands
+ # 'action-if-found' is run. If 'action-if-found' is not specified, the
+-# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, appends
+-# '-L$ZLIB_HOME}/lib' to LDFLAGS, prepends '-lz' to LIBS, and calls
+-# AC_DEFINE(HAVE_LIBZ). You should use autoheader to include a definition
+-# for this symbol in a config.h file. Sample usage in a C/C++ source is as
+-# follows:
++# default action appends '-I${ZLIB_HOME}/include' to CPFLAGS, prepends '-lz'
++# to LIBS, and calls AC_DEFINE(HAVE_LIBZ). You should use autoheader to
++# include a definition for this symbol in a config.h file. Sample usage
++# in a C/C++ source is as follows:
+ #
+ # #ifdef HAVE_LIBZ
+ # #include <zlib.h>
+@@ -4072,7 +4071,6 @@
+ ZLIB_OLD_LDFLAGS=$LDFLAGS
+ ZLIB_OLD_CPPFLAGS=$CPPFLAGS
+ if test -n "${ZLIB_HOME}"; then
+- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
+ CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
+ fi
+
+@@ -4145,7 +4143,6 @@
+ #
+
+ CPPFLAGS="$CPPFLAGS -I${ZLIB_HOME}/include"
+- LDFLAGS="$LDFLAGS -L${ZLIB_HOME}/lib"
+ LIBS="-lz $LIBS"
+
+ $as_echo "#define HAVE_LIBZ 1" >>confdefs.h
+--
+2.28.0
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
index 605769b62335..2683ce2015f4 100644
--- a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
@@ -35,7 +35,10 @@ S="${WORKDIR}/telegram-purple"
DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
-PATCHES="${FILESDIR}/${P}-change-metadata-location.patch"
+PATCHES=(
+ "${FILESDIR}/${P}-change-metadata-location.patch"
+ "${FILESDIR}/${P}-clang.patch"
+)
src_prepare() {
default
diff --git a/x11-plugins/wmcpuwatch/Manifest b/x11-plugins/wmcpuwatch/Manifest
index 148051b967d9..cd69742ad755 100644
--- a/x11-plugins/wmcpuwatch/Manifest
+++ b/x11-plugins/wmcpuwatch/Manifest
@@ -1,4 +1,4 @@
AUX wmcpuwatch-0.2-cmake.patch 1376 BLAKE2B 5bee8323ebed3418220688964e709f7f657b91ffea780dd073464dddf3a30cfbb06d741cf0a50ac8a727dacbe428cc7ea6f8e5e8d8a5102f197034b16d5b284d SHA512 9e2f55aac2fc2d12556b70c05cd30cacd2fc8acdc3b6f955473a02b18fc2e705adcd6954e23051dbfdc8a51734a69446a20f459df0295e3a0e74459ff8729a5c
DIST wmcpuwatch-0.2.tar.bz2 55621 BLAKE2B 5be49c22b7f063fe2cf4fb91358665903018500d51f56731b0f3584fec011031ec03fdb650722634aaf3b8b9a29e9f7d048b73fcc88b20e469607472cf827e69 SHA512 25aa3fb2d416035a7f3afbec58b2166338009e57310166e91719f6b5cfc4a1e05600ef0ec381c1ff56964848dac1e8ed272cbc4e352dbcc2751addd2cddd2e6e
-EBUILD wmcpuwatch-0.2-r1.ebuild 762 BLAKE2B 9af1e94b7599686d532c6e097129a622eb97bf5c62634fd18c294433e1baff805251c4ae09ef60728371cd29642add881c1ac3dc31121540ba08b8b21e34ed15 SHA512 3f6118e0c18b462d6e10f1ba6c67d239adfddde1a8800f13cf24eae77e85f23f28c00d790e0a165374c5131595618dace4901adb1b6ac13d6136e2b156a92127
-MISC metadata.xml 779 BLAKE2B 55a1b5288840f3bcb34fc4e1fdf1790b9f3dfd8454816caaea58c19f1ef9156fd3deea1be0540d4c3fc10701aec04da0a51d4beb35b81e7c892a5a25e6d3ea08 SHA512 7cced753e2d94d9f1d4265269797c690ed732dcf3943ea8263d7408c9e295a0e2d26aecf9dd9e0b0805dfcb0ecc355f87764ec65292c78a822dcd00d85d3c011
+EBUILD wmcpuwatch-0.2-r1.ebuild 851 BLAKE2B aed12cf6d481c95149741b88d441995aeaeeb64cd2483365a267bbd6fc9e7ae6f4112e00d29731bcc09cc120d483905088ca26030ff31fb6d9e235b8971a47c1 SHA512 6bfd49f05be5eeebf3513a0cd6e3d48e8aa6504df55e922050f80464a13dee96809c747f953b01c95f73de2beb63f632d331f1c90074aead1270aac790cc2253
+MISC metadata.xml 695 BLAKE2B b4a97da1af3e7099656caed628ba5fe3cd36289997c174fca4571cd26acad553c32e59b8689641aeb81ca0c5e70c46e9b47a8843ec949f2badbc40841c39d2bb SHA512 ccf8dca7ae9e2738b200f98bdef61cfb57d50de5be1ab93803f56209d9d9fc27cc06e1f34f2d9e917ac9db33d70fd3f51ae54d51c24d21a564d36a5c2d247a74
diff --git a/x11-plugins/wmcpuwatch/metadata.xml b/x11-plugins/wmcpuwatch/metadata.xml
index 00a3935917ee..d34af4773b12 100644
--- a/x11-plugins/wmcpuwatch/metadata.xml
+++ b/x11-plugins/wmcpuwatch/metadata.xml
@@ -12,7 +12,4 @@ It is a fork of wmmon. wmmon shows the load of up to 10 CPUs. With a little twea
wmcpuwatch now shows the load of all CPUs in the lower frame which allows 40 CPUs at max.
</longdescription>
-<upstream>
- <remote-id type="bitbucket">StarFire/wmcpuwatch</remote-id>
-</upstream>
</pkgmetadata>
diff --git a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
index e758ba522eee..0edf74c5ae37 100644
--- a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
+++ b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+inherit cmake
DESCRIPTION="dockapp showing the load of every logical CPU on the system"
-HOMEPAGE="https://bitbucket.org/StarFire/wmcpuwatch"
-SRC_URI="https://bitbucket.org/StarFire/${PN}/downloads/${P}.tar.bz2"
+HOMEPAGE="https://bitbucket-archive.softwareheritage.org/projects/st/StarFire/wmcpuwatch.html"
+SRC_URI="https://bitbucket-archive.softwareheritage.org/static/83/8395d160-de4b-42d6-a7d9-939eade4f58a/attachments/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
@@ -14,18 +14,18 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND=">=x11-libs/libdockapp-0.7:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
DOCS=( ChangeLog README.md )
PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use doc || sed -e "s/add_subdirectory(doc)//" -i CMakeLists.txt || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${BUILD_DIR}"/doc/html
}