summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellshoot/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /x11-plugins/gkrellshoot/files
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'x11-plugins/gkrellshoot/files')
-rw-r--r--x11-plugins/gkrellshoot/files/makefile-respect-flags.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
new file mode 100644
index 000000000000..8de89009dbbc
--- /dev/null
+++ b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
@@ -0,0 +1,26 @@
+--- a/Makefile 2006-12-09 04:24:36.000000000 +0100
++++ b/Makefile 2013-03-16 13:50:00.147834790 +0100
+@@ -1,16 +1,20 @@
+ GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
+
+ OBJS = gkrellshoot.o
+
++all: gkrellshoot.so
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c -o $@ $<
++
+ gkrellshoot.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~