summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /x11-plugins
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin27698 -> 27701 bytes
-rw-r--r--x11-plugins/gkrellshoot/Manifest3
-rw-r--r--x11-plugins/gkrellshoot/files/makefile-respect-flags.patch26
-rw-r--r--x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild (renamed from x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild)6
4 files changed, 33 insertions, 2 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index fef177cd08d1..65d1e365490c 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/gkrellshoot/Manifest b/x11-plugins/gkrellshoot/Manifest
index 9ff6b13f991d..bb641d69c02e 100644
--- a/x11-plugins/gkrellshoot/Manifest
+++ b/x11-plugins/gkrellshoot/Manifest
@@ -1,3 +1,4 @@
+AUX makefile-respect-flags.patch 663 BLAKE2B 1129e147524560fd8a5ff2979453ed9aa0a8abb03b940d989106f18f887b571cd09a72454da05325b94c369ee72c4bfca2981945910ddd6e7c3e9ab1fe35b0cc SHA512 a58b16f0b95533be587f2fe1a63ba7c19ade8dfd9b432d2423aee3ff7b99789d662cb7ed0e04854ed1b315c106586c4cd527427b5ce395b3bbeffedf2c5fff80
DIST gkrellshoot-0.4.4.tar.gz 16556 BLAKE2B 417217ffa500d8b0cc4ddd80849b2da83e3e55bc489db83fd7c8992f42af9ebb385c1ece17cae65cb7393bffadaaffd70e11a4dea16aa4d2b2f19e0b828a6833 SHA512 9363c045a99c23f8fedf95ac82c7bab4ce21acb675fdabdd831f174d9816a14a22ed6d7048d475b4c4199b9e6a88f3f663702ac2f9304f08860339beb323322a
-EBUILD gkrellshoot-0.4.4-r2.ebuild 483 BLAKE2B e5177d7a7c192045bd80dac2fb3c2831652f59ebc76a4ce64a18995ac6d3ad4a538df488a525a754ab1dfd36296d06745ab3c1d3a66201b722319b2a87727d90 SHA512 bcffcd2e5bc65acad19dc45aabb5583d0f5799aa0c15cbd769e011ec5a9646eb30ddcfcdadb4843b758629161e1b8c57f4a7a7643f6358b6e5781b0a661a7814
+EBUILD gkrellshoot-0.4.4-r3.ebuild 540 BLAKE2B 5c136c2e9ba6e613ec500ed0eae8aeba3dbf82ed437ba3135949fce57745028d7ea53db1bcb0efe97d2ef1b459440227809cc428bc249648eb2fc2713eaff08a SHA512 0cc0135779a37947c289bf9f2c8185ce86592a373bf879166978967b97ba31665089a448093fde8278808fea21b4272f9c4292aa49a5dcfa7add209a2591bd92
MISC metadata.xml 249 BLAKE2B 3035b160871880c8efce1239c00a3560c8c7b2b8eda5ebe8dab078c77496de9815444cdb9e7440687681828490e7684c2794406444eedf71fa380f5cd3c35b05 SHA512 01584093d9f32130ab091c0101ca41fba98d46fc3670c9598f052ef4393659bc8fc964d4b6232c7724eb7d0e03e32901b231799a595fa7f6626b3367dd116a68
diff --git a/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
new file mode 100644
index 000000000000..8de89009dbbc
--- /dev/null
+++ b/x11-plugins/gkrellshoot/files/makefile-respect-flags.patch
@@ -0,0 +1,26 @@
+--- a/Makefile 2006-12-09 04:24:36.000000000 +0100
++++ b/Makefile 2013-03-16 13:50:00.147834790 +0100
+@@ -1,16 +1,20 @@
+ GTK_INCLUDE = `pkg-config gtk+-2.0 --cflags`
+ GTK_LIB = `pkg-config gtk+-2.0 --libs`
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
+-CC = gcc $(CFLAGS) $(FLAGS)
+
+ OBJS = gkrellshoot.o
+
++all: gkrellshoot.so
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c -o $@ $<
++
+ gkrellshoot.so: $(OBJS)
+- $(CC) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) $(OBJS) -o gkrellshoot.so $(LFLAGS) $(LIBS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild
index ad424be2249b..028ef92f7eb6 100644
--- a/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r2.ebuild
+++ b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,3 +20,7 @@ RDEPEND="
virtual/imagemagick-tools"
S=${WORKDIR}/${P/s/S}
+
+PATCHES=(
+ "${FILESDIR}"/makefile-respect-flags.patch
+)