summaryrefslogtreecommitdiff
path: root/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild')
-rw-r--r--x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
new file mode 100644
index 000000000000..136f1965fa15
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.19.5:3[X]
+ sys-apps/dbus
+ x11-libs/libX11
+ !x11-misc/notify-osd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ insinto /usr/share/dbus-1/services
+ newins <<-EOF - org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+}