summaryrefslogtreecommitdiff
path: root/x11-misc/notification-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-misc/notification-daemon
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-misc/notification-daemon')
-rw-r--r--x11-misc/notification-daemon/Manifest1
-rw-r--r--x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/Manifest b/x11-misc/notification-daemon/Manifest
index b3a74f7d14e7..ee4d8db51231 100644
--- a/x11-misc/notification-daemon/Manifest
+++ b/x11-misc/notification-daemon/Manifest
@@ -1,5 +1,6 @@
AUX notification-daemon-0.5.0-libnotify-0.7.patch 948 BLAKE2B 9da54db70a628988b5f5b3e34dd71a7bbf8357a58be1e7c9de863d719619b6376ca311c4963e0974f77c08671f03efd28693d90f97a852ee68393e3b11b550fc SHA512 e828d89197c29c3b8e2b6b2e616d6fd63952f8b8ac23f4a0b7a8f6a75722e011d1684302b711ee530506e4e17aae6c7949f12f58a113ca6bb254a29d146d5870
AUX notification-daemon-0.5.0-underlinking.patch 277 BLAKE2B ef30fae7ca0d8a26c18acc5f98e5a2bd4db53293f302fdba3bf3fbc362c435931d81482e174fbff5396ecee04768068e51c48a8e19be3f881803ae4af77e3637 SHA512 e370ed9435b474fddf0b884d6781bdbfb1cb68dd7f851e72f525d6153235d39f77d28257c6d720f3de63df8ac29a7bf9100669813f4edda177a9dbf21afa3e5e
DIST notification-daemon-3.20.0.tar.xz 340752 BLAKE2B 9ded1efdb38de0097495ff570b9b91eb151e5eb030fcb9364a5ac04a4a5631c0a8483dc4068dd806d54ef0a096062ca92f9783f2030edb57f681b82015cf8584 SHA512 d9311c71a2915cb6e55bd1408e60b4d7b7fc24114410b8bd8cb358fe86c100198567099843b967f7e01ca03c91afe3f3980fb30b7f2c138bdab949e0e196a0f8
+EBUILD notification-daemon-3.20.0-r1.ebuild 860 BLAKE2B 25b340172da0360327ed04e014d22285075326745a92628ff0b9fefae555ddb5b4ea302e274b6c5d12effee0503d15a8a9b80ee67bf0558c340e4f24eac45c3b SHA512 0bec1c988b485c9a8f8e554512cb83000e7f903fa2cf7284d50c15f83d6e118fa28d28e76ab215c859ad8a6bb0522d02f2b6a47e03fa14c00896ab3f164a3444
EBUILD notification-daemon-3.20.0.ebuild 933 BLAKE2B 6b6723c0fb6eb6d0bb651cf89391044caec710a62c646ce14c449dfadba8bac667260ab134ac3441e908fe66061db130e3a7a35f76cbb48ed56ad35258d7d58e SHA512 5ede8f81fb46b783f0d2f323d95724db34405bc5b9339afd36faea803453bd3b76c47c09b8c8525dd821637d1069572f645593c50d18c4e4b266166a7eac373a
MISC metadata.xml 270 BLAKE2B 9c2dafa0390cfc7b94b5c44505d72021bf57cf8ffb35be7a3327f4316c3e4b2dbbfa0325d97243a8ea933440a5678cc5d35c639f5aa210b1d5ceb8ab65eb5d90 SHA512 92c366ec57074ced42e6f9960f97d1cd1a022dba7450b51f3617a6a5e00c755496dfa84aa4ac259f4b00c676366b1eaa3ec30eeb9bcb0bf41253d1910005db2f
diff --git a/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
new file mode 100644
index 000000000000..136f1965fa15
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-3.20.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.19.5:3[X]
+ sys-apps/dbus
+ x11-libs/libX11
+ !x11-misc/notify-osd
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_install() {
+ default
+
+ insinto /usr/share/dbus-1/services
+ newins <<-EOF - org.freedesktop.Notifications.service
+ [D-BUS Service]
+ Name=org.freedesktop.Notifications
+ Exec=/usr/libexec/notification-daemon
+ EOF
+}