summaryrefslogtreecommitdiff
path: root/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-misc/hsetroot/hsetroot-1.0.5.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-misc/hsetroot/hsetroot-1.0.5.ebuild')
-rw-r--r--x11-misc/hsetroot/hsetroot-1.0.5.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-misc/hsetroot/hsetroot-1.0.5.ebuild b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
new file mode 100644
index 000000000000..cde4912ca941
--- /dev/null
+++ b/x11-misc/hsetroot/hsetroot-1.0.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Tool which allows you to compose wallpapers ('root pixmaps') for X"
+HOMEPAGE="https://github.com/himdel/hsetroot/"
+SRC_URI="
+ https://github.com/himdel/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ >=media-libs/imlib2-1.0.6.2003[X]
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+DOCS="AUTHORS ChangeLog NEWS README"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.5-XOpenDisplay.patch
+)
+
+src_compile() {
+ # Avoid the Makefile that replaced autotools
+ tc-export CC PKG_CONFIG
+ local tgt hsr_comp_args
+ for tgt in ${PN} hsr-outputs; do
+ hsr_comp_args=(
+ ${CFLAGS}
+ $("${PKG_CONFIG}" --cflags x11 imlib2 xinerama)
+ ${LDFLAGS}
+ ${tgt}.c
+ $("${PKG_CONFIG}" --libs x11 imlib2 xinerama)
+ -o ${tgt}
+ )
+ echo ${hsr_comp_args[@]}
+ "${CC}" ${hsr_comp_args[@]} || die
+ done
+
+}
+
+src_install() {
+ dobin ${PN} hsr-outputs
+ dodoc README.md
+}