summaryrefslogtreecommitdiff
path: root/x11-apps/xauth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-apps/xauth
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-apps/xauth')
-rw-r--r--x11-apps/xauth/Manifest4
-rw-r--r--x11-apps/xauth/xauth-1.1.2.ebuild29
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild13
3 files changed, 38 insertions, 8 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index c54f5421cfa8..e23561973402 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1,4 +1,6 @@
DIST xauth-1.1.1.tar.bz2 167315 BLAKE2B fbe36f867031c734e3a8ae9719145caa16828d4df156503c299812fb63f86462561ffea945f12fabc5e036cc63664ee1d8b5b37630dee8d4af6f2473aa5fcd1a SHA512 998c3158378fff50d368959c29335173b8d98e02591cb3d7b2f9534b5a44b19deb4cb7da9bf291ca5a37f69f833d72839b2c6611723306d10c1b4968ae4d4120
+DIST xauth-1.1.2.tar.xz 156960 BLAKE2B 2ba168229bdf0c1d0fdd4c352e434abfc6f527cbafce35abac8d403a0dea91f00fd858f91f177128d13a0e618d1d95061c71ef32a3e12ac91b72a257dcfcd12b SHA512 ac23fcd166b45abf7b030994ff3332c9906023dc1ddfa9b9d3000e6a914dc5e0213c4a2aa409cb3ddb93e1f9f4f6374376109241a95ef8c36af842de1f6f76e8
EBUILD xauth-1.1.1.ebuild 627 BLAKE2B 5f961ef4642fe9a226211d3f7c6731b505a05912d23e2feef1edef821b398a9440b8a6944f1e50c45cfe81e419d4e1d47e655816574c4e03f4a8dfa9781c8f1b SHA512 dbabc69355b416ecf3791fac9c87f499588095432424e8d0bbfaca96211e8ed30cdb5c1edb22fd48db1d92fe6b53e201e0ec0643b4ff07dad6b8c3346c833256
-EBUILD xauth-9999.ebuild 628 BLAKE2B 077a7198ef7ee9d3a4e391a2eb88a53cc6a38c2ac9a978acdd30207bb55be0d07459133aaf35a5396c81e92e48ebca42f73382f6a34d487dbd2d66e0510ff2f2 SHA512 ccf6679fcfcaa00f2620890f6a297bb81ec099c1d2cc4bba6b6ee95c2885e088733dc8b17e6ad142e14cd4786ab7bda02d8f038b471d2f5a88bd9b20f4d6c347
+EBUILD xauth-1.1.2.ebuild 595 BLAKE2B b6c0b32c2fdbd61d400a93f03d5d97e7a3209045e87b74fbcf222ac07064937c1e8c895bceff8c48f91882a0b61e67d4c4cde1267ac3eddecbb21265eac93d09 SHA512 429f84dd76f335e08cb244f80998d3b34d15d38cb90965a798aeb5dabe22b510b08cee5b2767f08d6b8ad02a6f1fdd5a1b6efed5f2c0f15a43d21bc39ab5e00d
+EBUILD xauth-9999.ebuild 599 BLAKE2B 757c7dc62ca39a50b64b5f2ffbf3bf5dcc123524d284457f62259a21fbfbd2db7eb854682cafbbb7ddf260c4254ad5c1836b2c7d9cc6eb2cbb47e626696f3d0f SHA512 8ccbfd002dd63a8d769d9d4a99e6c077bd9253e6dc8e35db34daa0dbe01350e749f12c3e46660ab9ec3b4e9db8379b5ffd238d07e3139690bb4ec640e8f8ccd7
MISC metadata.xml 235 BLAKE2B 5ed3cd35ac32a5cdd6ac490bafdbc1cd03fc8c6bdbc8194ba7f4a34151a24c4ade7a80705d92348d6d13a9579d18b19ec40a353bf014dc02f98980bfa03d3574 SHA512 3fe78f6dd92b87b30ed02aef15ed72ec5cb62f4c6568dd9b98dcb2f11a4b9ce93955e34c62112a310b4c4a51f87e0e31e31ae5af140e1054c127d3cd344d7267
diff --git a/x11-apps/xauth/xauth-1.1.2.ebuild b/x11-apps/xauth/xauth-1.1.2.ebuild
new file mode 100644
index 000000000000..0c046c83629c
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ )
+ xorg-3_src_configure
+}
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index 50da5eb529dd..7fc5df1bdbf2 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
+XORG_TARBALL_SUFFIX=xz
inherit xorg-3
if [[ ${PV} == 9999* ]]; then
SRC_URI=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6"
-RESTRICT="test" # Depends on dead cmdtest package
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXau
x11-libs/libXext
x11-libs/libXmu"
@@ -24,7 +23,7 @@ DEPEND="${RDEPEND}
src_configure() {
local XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
+ --enable-ipv6
)
xorg-3_src_configure
}