summaryrefslogtreecommitdiff
path: root/x11-apps/xauth/xauth-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xauth/xauth-9999.ebuild')
-rw-r--r--x11-apps/xauth/xauth-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/x11-apps/xauth/xauth-9999.ebuild b/x11-apps/xauth/xauth-9999.ebuild
index 50da5eb529dd..7fc5df1bdbf2 100644
--- a/x11-apps/xauth/xauth-9999.ebuild
+++ b/x11-apps/xauth/xauth-9999.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
+XORG_TARBALL_SUFFIX=xz
inherit xorg-3
if [[ ${PV} == 9999* ]]; then
SRC_URI=""
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
fi
DESCRIPTION="X authority file utility"
-IUSE="ipv6"
-RESTRICT="test" # Depends on dead cmdtest package
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXau
x11-libs/libXext
x11-libs/libXmu"
@@ -24,7 +23,7 @@ DEPEND="${RDEPEND}
src_configure() {
local XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
+ --enable-ipv6
)
xorg-3_src_configure
}