summaryrefslogtreecommitdiff
path: root/x11-apps/xauth/xauth-1.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-apps/xauth/xauth-1.1.2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-apps/xauth/xauth-1.1.2.ebuild')
-rw-r--r--x11-apps/xauth/xauth-1.1.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-apps/xauth/xauth-1.1.2.ebuild b/x11-apps/xauth/xauth-1.1.2.ebuild
new file mode 100644
index 000000000000..0c046c83629c
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="X authority file utility"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-ipv6
+ )
+ xorg-3_src_configure
+}