summaryrefslogtreecommitdiff
path: root/www-servers/kore/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 04:17:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 04:17:09 +0100
commit388a0747e5972613060d5ca13955b5cd7132533d (patch)
tree428632822fc3fccc6f83e13091c09d6c19ad51bc /www-servers/kore/files
parent89da5c5ac79849bb6d8b087cb9c1e554187bd59c (diff)
gentoo auto-resync : 20:05:2023 - 04:17:09
Diffstat (limited to 'www-servers/kore/files')
-rw-r--r--www-servers/kore/files/kore-4.2.3-kodev-makefile.patch22
-rw-r--r--www-servers/kore/files/kore-4.2.3-makefile.patch34
2 files changed, 56 insertions, 0 deletions
diff --git a/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch b/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch
new file mode 100644
index 000000000000..e1e0fe1fd75e
--- /dev/null
+++ b/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch
@@ -0,0 +1,22 @@
+--- a/kodev/Makefile
++++ b/kodev/Makefile
+@@ -9,16 +9,16 @@ INSTALL_DIR=$(PREFIX)/bin
+
+ S_SRC= ../src/cli.c
+
+-CFLAGS+=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes
+ CFLAGS+=-Wmissing-declarations -Wshadow -Wpointer-arith -Wcast-qual
+ CFLAGS+=-Wsign-compare -Iincludes -std=c99 -pedantic
+ CFLAGS+=-DPREFIX='"$(PREFIX)"'
+-LDFLAGS=-lcrypto
++LDFLAGS+=-lcrypto
+
+ ifneq ("$(NOOPT)", "")
+ CFLAGS+=-O0
+ else
+- CFLAGS+=-O2
++ CFLAGS+=
+ endif
+
+ ifneq ("$(MINIMAL)", "")
diff --git a/www-servers/kore/files/kore-4.2.3-makefile.patch b/www-servers/kore/files/kore-4.2.3-makefile.patch
new file mode 100644
index 000000000000..e8a94f8aecab
--- /dev/null
+++ b/www-servers/kore/files/kore-4.2.3-makefile.patch
@@ -0,0 +1,34 @@
+--- a/Makefile
++++ b/Makefile
+@@ -31,11 +31,11 @@ S_SRC+= src/tls_$(TLS_BACKEND).c
+ FEATURES=
+ FEATURES_INC=
+
+-CFLAGS+=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes
+ CFLAGS+=-Wmissing-declarations -Wshadow -Wpointer-arith -Wcast-qual
+ CFLAGS+=-Wsign-compare -Iinclude/kore -I$(OBJDIR) -std=c99 -pedantic
+ CFLAGS+=-Wtype-limits -fno-common
+-CFLAGS+=-DPREFIX='"$(PREFIX)"' -fstack-protector-all
++CFLAGS+=-DPREFIX='"$(PREFIX)"'
+
+ LDFLAGS+=-rdynamic
+
+@@ -69,7 +69,7 @@ endif
+ ifneq ("$(NOOPT)", "")
+ CFLAGS+=-O0
+ else
+- CFLAGS+=-O2
++ CFLAGS+=
+ endif
+
+ ifneq ("$(NOSENDFILE)", "")
+@@ -155,7 +155,7 @@ ifeq ("$(OSNAME)", "darwin")
+ endif
+ S_SRC+=src/bsd.c
+ else ifeq ("$(OSNAME)", "linux")
+- CFLAGS+=-D_GNU_SOURCE=1 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
++ CFLAGS+=-D_GNU_SOURCE=1
+ LDFLAGS+=-ldl
+ S_SRC+=src/linux.c src/seccomp.c
+ else