summaryrefslogtreecommitdiff
path: root/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/kore/files/kore-4.2.3-kodev-makefile.patch')
-rw-r--r--www-servers/kore/files/kore-4.2.3-kodev-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch b/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch
new file mode 100644
index 000000000000..e1e0fe1fd75e
--- /dev/null
+++ b/www-servers/kore/files/kore-4.2.3-kodev-makefile.patch
@@ -0,0 +1,22 @@
+--- a/kodev/Makefile
++++ b/kodev/Makefile
+@@ -9,16 +9,16 @@ INSTALL_DIR=$(PREFIX)/bin
+
+ S_SRC= ../src/cli.c
+
+-CFLAGS+=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes
+ CFLAGS+=-Wmissing-declarations -Wshadow -Wpointer-arith -Wcast-qual
+ CFLAGS+=-Wsign-compare -Iincludes -std=c99 -pedantic
+ CFLAGS+=-DPREFIX='"$(PREFIX)"'
+-LDFLAGS=-lcrypto
++LDFLAGS+=-lcrypto
+
+ ifneq ("$(NOOPT)", "")
+ CFLAGS+=-O0
+ else
+- CFLAGS+=-O2
++ CFLAGS+=
+ endif
+
+ ifneq ("$(MINIMAL)", "")