summaryrefslogtreecommitdiff
path: root/www-plugins/passff/passff-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /www-plugins/passff/passff-1.1.ebuild
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'www-plugins/passff/passff-1.1.ebuild')
-rw-r--r--www-plugins/passff/passff-1.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-plugins/passff/passff-1.1.ebuild b/www-plugins/passff/passff-1.1.ebuild
new file mode 100644
index 000000000000..3c07171aa77c
--- /dev/null
+++ b/www-plugins/passff/passff-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit python-single-r1
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox (Host Binary)"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="
+ https://github.com/passff/passff/releases/download/${PV}/passff.json -> ${P}.json
+ https://github.com/passff/passff/releases/download/${PV}/passff.py -> ${P}.py
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+TARGET_DIR="/usr/lib/mozilla/native-messaging-hosts"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" passff.json || die
+ cp "${DISTDIR}/${P}.py" passff.py || die
+}
+
+src_compile() {
+ sed -i "s|PLACEHOLDER|${EPREFIX}${TARGET_DIR}/${PN}.py|" passff.json || die
+ python_fix_shebang passff.py
+}
+
+src_install() {
+ insinto "${TARGET_DIR}"
+ doins passff.json
+ exeinto "${TARGET_DIR}"
+ doexe passff.py
+}