summaryrefslogtreecommitdiff
path: root/www-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-24 10:19:03 +0000
commitb279bbe94522565b8feb19b8e5f377d3ea76f157 (patch)
treee4790abc54cd850232f7d7de49e371fdfe8976c7 /www-plugins
parentc5283d322accc6097afec74eab24550829788bab (diff)
gentoo resync : 24.03.2018
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/Manifest.gzbin1933 -> 2098 bytes
-rw-r--r--www-plugins/passff/Manifest4
-rw-r--r--www-plugins/passff/metadata.xml11
-rw-r--r--www-plugins/passff/passff-1.1.ebuild40
4 files changed, 55 insertions, 0 deletions
diff --git a/www-plugins/Manifest.gz b/www-plugins/Manifest.gz
index 7330f786888a..8fa64b4c5610 100644
--- a/www-plugins/Manifest.gz
+++ b/www-plugins/Manifest.gz
Binary files differ
diff --git a/www-plugins/passff/Manifest b/www-plugins/passff/Manifest
new file mode 100644
index 000000000000..cdc9ac78e6b8
--- /dev/null
+++ b/www-plugins/passff/Manifest
@@ -0,0 +1,4 @@
+DIST passff-1.1.json 176 BLAKE2B 8eddc19cd0c072d25afff5cfa86a95d960ae7b986727099a04a1d983b887922f9ad77e940a2c80e0838a169afe81fa3f6529a901998bb98a6750ac888a09c264 SHA512 e4a4b90fb5323c6dbec339b9e67a7d546c6d7a95754fe03b3a4d96396c28de1caba3068b4e936ee0ce0997f865c8b5e53a3da1fb34f0123a04c5889302c28911
+DIST passff-1.1.py 2256 BLAKE2B fcde1a8d1fe4e8793df46c182a8d717931e7b5ee98ae39a6a03bf32c51528dd7036beefc47dd5839bede47a78bcb7904a745fa38522183057dd7b29e20eae726 SHA512 b5d4aa3d3a9455adece3d291a6e1e05178296e72828ec708cd33541f30e4fbef2385978f24ba27eaefc739e4792f4cbac1830e8dcd15380c7243e11ddbcafe9d
+EBUILD passff-1.1.ebuild 914 BLAKE2B 6ed1b603a4a39926e81e0efc2243c5fdd6feacd35b3a5ae874bd6cc74787791c959e015837a9e2baccd438bfc89970926ab27851a8f5127825d758ccf4cc7b17 SHA512 9d926c76b7232322ead013112b78cab6bac3179c5036c61deaf2bcf6d65fa226b9841fe935b63c69e9ce5bc9fd351c0ded12c78117ad4a03a1d207b129c420ae
+MISC metadata.xml 330 BLAKE2B 87fadecd45f680ccf29dbc736eac6c8d5c5da5dc6f15749b42abf6d4d6a5b1d466818b32d996198a0a7534365bf31a5773b8ae358330ee36e365a26e90789ba1 SHA512 c33841e96737f16de6ee6a4f7e2dba04df4dddb26d502d55df8be637ed668a5c8593fef76a2b24a00da335a59cac5f534f89e8cf917d8b1d4ffa9d3d9c0c6d57
diff --git a/www-plugins/passff/metadata.xml b/www-plugins/passff/metadata.xml
new file mode 100644
index 000000000000..764e78624bc3
--- /dev/null
+++ b/www-plugins/passff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>contact@hacktivis.me</email>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+</pkgmetadata>
diff --git a/www-plugins/passff/passff-1.1.ebuild b/www-plugins/passff/passff-1.1.ebuild
new file mode 100644
index 000000000000..3c07171aa77c
--- /dev/null
+++ b/www-plugins/passff/passff-1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit python-single-r1
+
+DESCRIPTION="zx2c4 pass manager extension for Firefox (Host Binary)"
+HOMEPAGE="https://github.com/passff/passff"
+SRC_URI="
+ https://github.com/passff/passff/releases/download/${PV}/passff.json -> ${P}.json
+ https://github.com/passff/passff/releases/download/${PV}/passff.py -> ${P}.py
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+TARGET_DIR="/usr/lib/mozilla/native-messaging-hosts"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}/${P}.json" passff.json || die
+ cp "${DISTDIR}/${P}.py" passff.py || die
+}
+
+src_compile() {
+ sed -i "s|PLACEHOLDER|${EPREFIX}${TARGET_DIR}/${PN}.py|" passff.json || die
+ python_fix_shebang passff.py
+}
+
+src_install() {
+ insinto "${TARGET_DIR}"
+ doins passff.json
+ exeinto "${TARGET_DIR}"
+ doexe passff.py
+}