summaryrefslogtreecommitdiff
path: root/sys-process/iotop-c/iotop-c-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /sys-process/iotop-c/iotop-c-9999.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'sys-process/iotop-c/iotop-c-9999.ebuild')
-rw-r--r--sys-process/iotop-c/iotop-c-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-process/iotop-c/iotop-c-9999.ebuild b/sys-process/iotop-c/iotop-c-9999.ebuild
new file mode 100644
index 000000000000..b05952298d1d
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/Tomas-M/iotop"
+inherit fcaps git-r3 linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}