summaryrefslogtreecommitdiff
path: root/sys-process/iotop-c
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /sys-process/iotop-c
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'sys-process/iotop-c')
-rw-r--r--sys-process/iotop-c/Manifest4
-rw-r--r--sys-process/iotop-c/iotop-c-1.18.ebuild36
-rw-r--r--sys-process/iotop-c/iotop-c-9999.ebuild34
-rw-r--r--sys-process/iotop-c/metadata.xml18
4 files changed, 92 insertions, 0 deletions
diff --git a/sys-process/iotop-c/Manifest b/sys-process/iotop-c/Manifest
new file mode 100644
index 000000000000..2d203b7b40db
--- /dev/null
+++ b/sys-process/iotop-c/Manifest
@@ -0,0 +1,4 @@
+DIST iotop-c-1.18.tar.gz 114838 BLAKE2B 8b3e13d00de4a5cd385a2d441d84bb27cc1d03a27012163b9628285c31176698bf840951e39199abef11b2d3c0413d500d6e7699f32a3b542360a1333307d00e SHA512 f0affbfdb106eb36078e7994860155f52d47878017f47e64d69aa7c04cc29756ca516a6634fd19d6d39c931100b9a0e93e07ca2f4d14c18014dc1c4f477907ea
+EBUILD iotop-c-1.18.ebuild 775 BLAKE2B 3869a20c8ce7d1144a33a58db4596b95798f338d2d739bc28c2494185bca002fd736a0bbd9521bc2907aa8b1a078268f53f8aefa6c13f6696471103d5f6faddc SHA512 061611b94fc7c2c29e08ceffa09d58de640f255c1eccc57442804be051beda551584ca682409cb17ff9a7d48fc0e7a50f3bc6ee738d03d936a4144ead2fcdc9c
+EBUILD iotop-c-9999.ebuild 701 BLAKE2B d87011d19c473ce2c4cba8d2f954d1c4e5e7d3cb43f04cef30f62bc238ad995db40c090107c1633acf37e983520474148f4975305c54cd40d01f428068bf85f4 SHA512 99bdda36efce6b2174a17746c21fe7398bcdf515943139776ac8123189d681bd630c063e9efcbb3cb91827fac75f518f3501fb11b09086cbc49442848308c055
+MISC metadata.xml 1376 BLAKE2B 4c377f582205438d0c85bc74ec56f55746a9ed8d5f82d13adf8c0beb81f5800d7e003e4ac9027edc2cd5a72a85a56eb829c82cac5c80aad31303aa3e50656077 SHA512 41827d5cb9e10c470ab065231727c5433947f78efc360f1474a05e6c6473c2a86f0dfd98389603203c6d5c35d3be8fa839d225e92b164e13ded4798cf5c8db0d
diff --git a/sys-process/iotop-c/iotop-c-1.18.ebuild b/sys-process/iotop-c/iotop-c-1.18.ebuild
new file mode 100644
index 000000000000..b6d52c5d05fa
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-1.18.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+SRC_URI="https://github.com/Tomas-M/iotop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/iotop-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}
diff --git a/sys-process/iotop-c/iotop-c-9999.ebuild b/sys-process/iotop-c/iotop-c-9999.ebuild
new file mode 100644
index 000000000000..b05952298d1d
--- /dev/null
+++ b/sys-process/iotop-c/iotop-c-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/Tomas-M/iotop"
+inherit fcaps git-r3 linux-info toolchain-funcs
+
+DESCRIPTION="top utility for IO (C port)"
+HOMEPAGE="https://github.com/Tomas-M/iotop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses:=
+ !sys-process/iotop"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+
+FILECAPS=(
+ cap_net_admin=eip usr/bin/iotop
+)
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)" NO_FLTO=1
+}
+
+src_install() {
+ dobin iotop
+ dodoc README.md
+ doman iotop.8
+}
diff --git a/sys-process/iotop-c/metadata.xml b/sys-process/iotop-c/metadata.xml
new file mode 100644
index 000000000000..e99460ff502b
--- /dev/null
+++ b/sys-process/iotop-c/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <longdescription lang="en">
+Your Linux server is too slow or load is too high? One of the possible causes of such symptoms may be high IO (input/output) waiting time, which basically means that some of your processes need to read or write to a hard drive while it is too slow and not ready yet, serving data for some other processes.
+
+Common practice is to use iostat -x in order to find out which block device (hard drive) is slow, but such information is not always much helpful. It could help you much more if you knew which process reads or writes the most data from your slow disk, so you could possibly renice it using ionice or even kill it.
+
+IOTop will identify processes, which use high amount of input/output requests on your machine. It is similar to the well known top utility, but instead of showing you what consumes CPU the most, it lists processes by their IO consumption. Inspired by iotop python script from Guillaume Chazarain, but rewritten to C by Vyacheslav Trushkin so it now runs without python at all.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Tomas-M/iotop</remote-id>
+ </upstream>
+</pkgmetadata>