summaryrefslogtreecommitdiff
path: root/sys-process/btop/btop-1.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-15 17:13:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-15 17:13:11 +0100
commit0c80ffd3caee224555f8b394b6b2c05b2752f440 (patch)
tree926db40c52646ba8a4f07fecfd4e64971ac28f4e /sys-process/btop/btop-1.2.9.ebuild
parentd9339ace1b5d6cf11ad869751abc1a474f46931d (diff)
gentoo auto-resync : 15:09:2022 - 17:13:11
Diffstat (limited to 'sys-process/btop/btop-1.2.9.ebuild')
-rw-r--r--sys-process/btop/btop-1.2.9.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-process/btop/btop-1.2.9.ebuild b/sys-process/btop/btop-1.2.9.ebuild
index 53e5416f327e..6bf13cbd7d95 100644
--- a/sys-process/btop/btop-1.2.9.ebuild
+++ b/sys-process/btop/btop-1.2.9.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default