summaryrefslogtreecommitdiff
path: root/sys-process
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-15 17:13:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-15 17:13:11 +0100
commit0c80ffd3caee224555f8b394b6b2c05b2752f440 (patch)
tree926db40c52646ba8a4f07fecfd4e64971ac28f4e /sys-process
parentd9339ace1b5d6cf11ad869751abc1a474f46931d (diff)
gentoo auto-resync : 15:09:2022 - 17:13:11
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/Manifest.gzbin9988 -> 9987 bytes
-rw-r--r--sys-process/btop/Manifest4
-rw-r--r--sys-process/btop/btop-1.2.8.ebuild13
-rw-r--r--sys-process/btop/btop-1.2.9.ebuild13
4 files changed, 28 insertions, 2 deletions
diff --git a/sys-process/Manifest.gz b/sys-process/Manifest.gz
index 3bf85bca422f..a0923ad039df 100644
--- a/sys-process/Manifest.gz
+++ b/sys-process/Manifest.gz
Binary files differ
diff --git a/sys-process/btop/Manifest b/sys-process/btop/Manifest
index 8f1b65f250d0..25be75ea3917 100644
--- a/sys-process/btop/Manifest
+++ b/sys-process/btop/Manifest
@@ -1,5 +1,5 @@
DIST btop-1.2.8.tar.gz 976370 BLAKE2B ab71ac322afd84b5b73c5deb9003f319078809d81e2725a7447d2a8fe7539af21c669e7199a3422b2a1cc2ecbd79a46179343e00311f2d56bfa30f51d6340bd3 SHA512 4b5a3685ca5cf301cd7d6556bd365892587e6811f8323ca66728022aba7cc3ff95cf591b452151c9431824dc458bc3d09e10474c7c02a944e8931c4585914f5a
DIST btop-1.2.9.tar.gz 978265 BLAKE2B ff80079a393342a2cf3aefad6ead8be8b786fbc2b9445e8e2a8b37386f65f4060c801a6f59d216cd611783f4135a60d64b95ff2b5e1a3d62bb2d40030bde8974 SHA512 424573c8f82d0daf748cba7c82e72232773f145af9792ac78a5f5f18d98a8695f11452de106c72cf685ecb8cc89729471a494f9ea6b4300bdb2fa6acdbf4ac60
-EBUILD btop-1.2.8.ebuild 921 BLAKE2B bf11e4951dbabc9100b885f1a82847fc13484208e009c159f6e18db2bd4a2d26f09ce7af596e7b5ebb9ef10b629a81b1718434c8a2d414f0253d907253a8b8dc SHA512 bdaa27a8f0f8ef6a6c5689937bf9eac9ba6193134a151e7e62dbb4f11d9f8fcdef8d81b06db4f880372e519813aa6a358bf3f2dbce42d894f0fe8f71b4a47e80
-EBUILD btop-1.2.9.ebuild 925 BLAKE2B ae07070b8cf8e78ce5ffb5dc3ecb7f3370dd7b54e6cecafc6507ee2d873cae70e07e2bdb911f794a26492c5e300fdd57091ab1f491788a9006de50799c670a2e SHA512 33e1e5b1d985b91bc1f98d161c39b0d9bf95ed187e9e37b95a62d94d6941d9a37883184225c7604e066aa880e39b769303fef3444e12be0cad1461b5a20b98e4
+EBUILD btop-1.2.8.ebuild 1168 BLAKE2B 94d4fa9e2bf45294168e815e2255f2b3d1c7c6dec0b45da99b8fa89296544470e8c9f014c6f316beae03045c1d832fa1025962812f47ffb15a1b274f0f5167af SHA512 1bd52b416712b4b1d1280e0cccddd3c2a26a14ae5ac46ea995b6678d8234c2ecf33d13a9b2d836786af1a7bbae78c828c612b261b7640d8526052c1bd3553c31
+EBUILD btop-1.2.9.ebuild 1172 BLAKE2B 2e934a30e9d173620b7b55c30865c06df45549dbfe69a1c7626df665f0587449adf7cfa883942abcd8c96d51beb6a5477246bdddacbfb82227e859b23d3075c5 SHA512 8f07db128338d196ec3a3ab6fda8f01ed3a75e15500ec6a7b8b3f498f35986205a9a370b66424055f3bd6ac3b4fbd3c2076956e1907c1a6f999df9a44b144b1b
MISC metadata.xml 548 BLAKE2B 74762cdc63011b363a4c06de8190541f862d70f0006461c7a1cf2d734caf20601ba0769dc067e261957fe42a64bdaf26297bf3d080c3c08203eabd73165f2f8c SHA512 bb16944df9321001ca5c9e9fff49ea39069386117f0cfde67e8f19e3f44c13d360effb578d2c44c67f792d1ff574830f13cb9ef183f594e39ad3669083f2cf41
diff --git a/sys-process/btop/btop-1.2.8.ebuild b/sys-process/btop/btop-1.2.8.ebuild
index b4ac52c9fecc..ee0bbdefbd6d 100644
--- a/sys-process/btop/btop-1.2.8.ebuild
+++ b/sys-process/btop/btop-1.2.8.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 ppc64 ~riscv x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default
diff --git a/sys-process/btop/btop-1.2.9.ebuild b/sys-process/btop/btop-1.2.9.ebuild
index 53e5416f327e..6bf13cbd7d95 100644
--- a/sys-process/btop/btop-1.2.9.ebuild
+++ b/sys-process/btop/btop-1.2.9.ebuild
@@ -13,6 +13,19 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+BDEPEND="
+ >=sys-devel/gcc-8
+"
+
+pkg_setup() {
+ if [[ "${MERGE_TYPE}" != "binary" ]]; then
+ if ! tc-is-gcc ; then
+ # https://bugs.gentoo.org/839318
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc instead."
+ fi
+ fi
+}
+
src_prepare() {
default
# btop installs README.md to /usr/share/btop by default