summaryrefslogtreecommitdiff
path: root/sys-process/bpytop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-01 21:06:00 +0000
commit129160ec854dca4c3fedb5bcfbcb56930371da0f (patch)
tree53bf797418ac5e9b99c41ca0382c87b82421e5de /sys-process/bpytop
parent441d1370330332b7d78f238d2f5e13f7aed5e4e0 (diff)
gentoo new year resync : 01.01.2021
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest2
-rw-r--r--sys-process/bpytop/bpytop-1.0.54.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
index 3dc95ea25b11..872b13797710 100644
--- a/sys-process/bpytop/Manifest
+++ b/sys-process/bpytop/Manifest
@@ -1,4 +1,6 @@
AUX bpytop-1.0.51-tests.patch 1376 BLAKE2B a66b87bd725b699bbf603215abda7e4fe30d043784666206c7e73b4304d2cc73bbacae4194ec1a09f7393ee1a02291db39d72e87384dab25a5270545dfb5132d SHA512 d045a28c577a06b851dd3fdb8619bb831ebe9a9b9c70ed1398879873516254817f29db385fb112fbd2626b23d48ad860996fe1845ef991b8f993e8c017748a78
DIST bpytop-1.0.52.tar.gz 616111 BLAKE2B f586189f1ae2067b1873a41235ac05f116aae5a6a965372d0ee778d714f80e6a41c163288ad1829313c0bef68f0f07235989d11351c48f4c78b953ceb4a4cb81 SHA512 68189c87890b637b9b3ff40ec4b0518a45023d3af0966cf0556c9dcc884d28660c42af37c69c06bbd03b514e198e5313fce143974ef11b67b95132070a77bfd4
+DIST bpytop-1.0.54.tar.gz 616658 BLAKE2B 0c639012ff69bb01f60943d63b179ea53a74affdfc0158ec0ce3e18a7c0ff855246450661fdef36f10fcb2f0de9e623d014cc41f19da375dddaac57f4b755e32 SHA512 4d47c00e6c642eaa48e7aa2d1df74050578f30cf5e40cda016b196e288f64819649e65090c3150a31889fea24e1859215d7fc06f419abad2d11f52efbb0ac7eb
EBUILD bpytop-1.0.52.ebuild 596 BLAKE2B c2ee81820f150f7c9ab9011cb7cb7f1a2f9feae156a44d1b5a96b395786ead328003b7f8931b4cd3a3a3de439e2aa345bf33551c0047fd75021398b618637c39 SHA512 e36c4f4c35ca76f94eb3491c09c3e880e29f40dce5b6ab3ab256a67a2dc5fe327f7a59c71ae1afc6cb0b6ddf7ad060f1baca8e5d441b835c90c4bb75a75267ff
+EBUILD bpytop-1.0.54.ebuild 711 BLAKE2B 599eff98cf7adf189f05e6e551cf8a8f4651e93f6efbf7d35e4f15dce488f18206417a851eea12bec620d33c4329ccea4efd2897af5b91cfa13564a6009df7a2 SHA512 5c5bf8589dfaa637bf62459c7a3c184162e0fd0b72b378633b02898ccab5381899079a9e490d9d8e7e84b616eae400ce434a391cb6a5131f234db62632bb86e6
MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/sys-process/bpytop/bpytop-1.0.54.ebuild b/sys-process/bpytop/bpytop-1.0.54.ebuild
new file mode 100644
index 000000000000..46708db1ebab
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.54.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.51-tests.patch"
+)
+
+src_install() {
+ insinto "/usr/share/${PN}/themes"
+ doins bpytop-themes/*.theme
+ distutils-r1_src_install
+}