summaryrefslogtreecommitdiff
path: root/sys-process/bpytop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /sys-process/bpytop
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'sys-process/bpytop')
-rw-r--r--sys-process/bpytop/Manifest4
-rw-r--r--sys-process/bpytop/bpytop-1.0.52.ebuild27
-rw-r--r--sys-process/bpytop/files/bpytop-1.0.51-tests.patch45
-rw-r--r--sys-process/bpytop/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/sys-process/bpytop/Manifest b/sys-process/bpytop/Manifest
new file mode 100644
index 000000000000..3dc95ea25b11
--- /dev/null
+++ b/sys-process/bpytop/Manifest
@@ -0,0 +1,4 @@
+AUX bpytop-1.0.51-tests.patch 1376 BLAKE2B a66b87bd725b699bbf603215abda7e4fe30d043784666206c7e73b4304d2cc73bbacae4194ec1a09f7393ee1a02291db39d72e87384dab25a5270545dfb5132d SHA512 d045a28c577a06b851dd3fdb8619bb831ebe9a9b9c70ed1398879873516254817f29db385fb112fbd2626b23d48ad860996fe1845ef991b8f993e8c017748a78
+DIST bpytop-1.0.52.tar.gz 616111 BLAKE2B f586189f1ae2067b1873a41235ac05f116aae5a6a965372d0ee778d714f80e6a41c163288ad1829313c0bef68f0f07235989d11351c48f4c78b953ceb4a4cb81 SHA512 68189c87890b637b9b3ff40ec4b0518a45023d3af0966cf0556c9dcc884d28660c42af37c69c06bbd03b514e198e5313fce143974ef11b67b95132070a77bfd4
+EBUILD bpytop-1.0.52.ebuild 596 BLAKE2B c2ee81820f150f7c9ab9011cb7cb7f1a2f9feae156a44d1b5a96b395786ead328003b7f8931b4cd3a3a3de439e2aa345bf33551c0047fd75021398b618637c39 SHA512 e36c4f4c35ca76f94eb3491c09c3e880e29f40dce5b6ab3ab256a67a2dc5fe327f7a59c71ae1afc6cb0b6ddf7ad060f1baca8e5d441b835c90c4bb75a75267ff
+MISC metadata.xml 249 BLAKE2B 9e4529cdac0a55f14c36fde3fa54e30645a61a73d58e83ce460edf84d729bb3cd4cdc3e52d588690945508bc7d253b1edfb7734ebee94a88b75fee249a043c84 SHA512 ecad16da7f98e9b1cb1882147e6d8b7d541e4839d92fc26f3db1bea69ed633637da9259947b2b78d204a11d0edd3daa84f173613b6dc19110b5406c6fddfa7f0
diff --git a/sys-process/bpytop/bpytop-1.0.52.ebuild b/sys-process/bpytop/bpytop-1.0.52.ebuild
new file mode 100644
index 000000000000..0621a07dc62f
--- /dev/null
+++ b/sys-process/bpytop/bpytop-1.0.52.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Linux/OSX/FreeBSD resource monitor"
+HOMEPAGE="https://github.com/aristocratos/bpytop"
+SRC_URI="https://github.com/aristocratos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/psutil-5.7.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/bpytop-1.0.51-tests.patch"
+)
diff --git a/sys-process/bpytop/files/bpytop-1.0.51-tests.patch b/sys-process/bpytop/files/bpytop-1.0.51-tests.patch
new file mode 100644
index 000000000000..3e5de4751fd9
--- /dev/null
+++ b/sys-process/bpytop/files/bpytop-1.0.51-tests.patch
@@ -0,0 +1,45 @@
+diff --git a/bpytop.py b/bpytop.py
+index a1c2b3a..b1cc28e 100755
+--- a/bpytop.py
++++ b/bpytop.py
+@@ -64,23 +64,27 @@ args.add_argument("-p" , "--proc" ,action="store_true" ,help ="Start in minimal
+ args.add_argument("-s" , "--stat" ,action="store_true" ,help ="Start in minimal mode without process box")
+ args.add_argument("-v" , "--version" ,action="store_true" ,help ="Show version info and exit")
+ args.add_argument("--debug" ,action="store_true" ,help ="Start with loglevel set to DEBUG overriding value set in config")
+-stdargs = args.parse_args()
+-
+-if stdargs.version:
+- print(f'bpytop version: {VERSION}\n'
+- f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
+- raise SystemExit(0)
+
+ ARG_MODE: str = ""
+
+-if stdargs.full:
+- ARG_MODE = "full"
+-elif stdargs.proc:
+- ARG_MODE = "proc"
+-elif stdargs.stat:
+- ARG_MODE = "stat"
++if __name__ == "__main__":
++ stdargs = args.parse_args()
++
++ if stdargs.version:
++ print(f'bpytop version: {VERSION}\n'
++ f'psutil version: {".".join(str(x) for x in psutil.version_info)}')
++ raise SystemExit(0)
+
+-DEBUG = stdargs.debug
++ if stdargs.full:
++ ARG_MODE = "full"
++ elif stdargs.proc:
++ ARG_MODE = "proc"
++ elif stdargs.stat:
++ ARG_MODE = "stat"
++
++ DEBUG = stdargs.debug
++else:
++ DEBUG = False
+
+ #? Variables ------------------------------------------------------------------------------------->
+
diff --git a/sys-process/bpytop/metadata.xml b/sys-process/bpytop/metadata.xml
new file mode 100644
index 000000000000..cee379b15409
--- /dev/null
+++ b/sys-process/bpytop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>