summaryrefslogtreecommitdiff
path: root/sys-power/apcupsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /sys-power/apcupsd
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'sys-power/apcupsd')
-rw-r--r--sys-power/apcupsd/Manifest1
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-power/apcupsd/Manifest b/sys-power/apcupsd/Manifest
index 33dd3c435d9f..db954e3adc31 100644
--- a/sys-power/apcupsd/Manifest
+++ b/sys-power/apcupsd/Manifest
@@ -9,4 +9,5 @@ DIST apcupsd-3.14.13.tar.gz 1935043 BLAKE2B 56d8fb9c6a055b20c2d99867e43b6a2d6ebe
DIST apcupsd-3.14.14.tar.gz 1843409 BLAKE2B 48a3b249780064d699d86b658584aa222ce9f3b46a81209110b4684bf737cca7492b87b063154864ce76478f29f73cda83ab96b47f4a7aa7aa91e29a8abbf4a8 SHA512 c953bbf3e08f809748a7978a3952604176390d1cd276f187fe096d9bc3c8993b52127e8350c0363387da41318e24b4d1e00ea58df71f3bb8f50c9a5a64cd2d7f
EBUILD apcupsd-3.14.13.ebuild 3958 BLAKE2B e87053e35983347d5dad1c61ff484e65322678a90e59b23cdd8d97bd745b1590c01958ee8cf04e08b62d037d0bfb10a43f2707b37518877ba3371f49a6a9bb82 SHA512 6563b422815aa8904af1b50983fcf68d951c37be64caea016d5299fa87101d3e7323126f36973a4f43a409d4dd4116cee6876987986ce9def5cecfc67701ae38
EBUILD apcupsd-3.14.14-r1.ebuild 4085 BLAKE2B c8f0842bc550d8a40d5ebf1809a0a27db293a5425895df35502d77b700a5a235aa9fdb6a66c4c786670816bb14cfbaf0a4d6f968e58733f2171cd60b2cb6bee5 SHA512 b0fb1ddaa60c864cc301a9b35e8ccb455df27a3f9fd0c8f2b768b55d8a79a6329ac8d11f1d2d6e68e16502f3ca0e7db0a3b692d2fa805288e21773fe808c2609
+EBUILD apcupsd-3.14.14-r2.ebuild 4089 BLAKE2B 2e9da901aaeb715fc79b763ab20b2c19369eb27c089ead0339a1248e11c5e92cead419abbcd2b2e621c8c0a408245c771630b92901fae509fc54cc2946325202 SHA512 1fc24c9a15098f00ad003cda26a22e1043822fa6f680797e94b200a5983ca71ffe5e8753bba56e55b9c939a589cc94418f0acccfc146b3e312bcf593cc6a1ae0
MISC metadata.xml 1259 BLAKE2B ca28cef92e8edcea0aaeece78cadb43ad8ad836297d8e857540558877a7781922f50c05b018d1a9f7d0753ddfb0a99aff84d16051fdfe5f0d407b79509058a35 SHA512 ba5660026926c0334a47aa3f84bfc0a4ef745db2170a1d773547cf495101cf1274cc24d71d3afa46fa62ebcb49e0913e92e9a0efe4cb70a349f77538b7f60eff
diff --git a/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
new file mode 100644
index 000000000000..9212cf4864ce
--- /dev/null
+++ b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info flag-o-matic systemd udev
+
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+HOMEPAGE="http://www.apcupsd.org/"
+SRC_URI="mirror://sourceforge/apcupsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="snmp +usb +modbus cgi nls gnome kernel_linux"
+
+DEPEND="
+ || ( >=sys-apps/util-linux-2.23[tty-helpers(-)]
+ sys-freebsd/freebsd-ubin
+ )
+ modbus? ( usb? ( virtual/libusb:0 ) )
+ cgi? ( >=media-libs/gd-1.8.4 )
+ nls? ( sys-devel/gettext )
+ snmp? ( >=net-analyzer/net-snmp-5.7.2 )
+ gnome? ( >=x11-libs/gtk+-2.4.0:2
+ dev-libs/glib:2
+ >=gnome-base/gconf-2.0 )"
+RDEPEND="${DEPEND}
+ virtual/mailx"
+
+CONFIG_CHECK="~USB_HIDDEV ~HIDRAW"
+ERROR_USB_HIDDEV="CONFIG_USB_HIDDEV: needed to access USB-attached UPSes"
+ERROR_HIDRAW="CONFIG_HIDRAW: needed to access USB-attached UPSes"
+
+DOCS=( ChangeLog ReleaseNotes )
+HTML_DOCS=( doc/manual )
+PATCHES=( "${FILESDIR}/${PN}-3.14.9-aliasing.patch" )
+
+pkg_setup() {
+ if use kernel_linux && use usb && linux_config_exists; then
+ check_extra_config
+ fi
+}
+
+src_configure() {
+ local myconf
+ use cgi && myconf="${myconf} --enable-cgi --with-cgi-bin=/usr/libexec/${PN}/cgi-bin"
+ if use usb; then
+ myconf="${myconf} --with-upstype=usb --with-upscable=usb --enable-usb --with-dev= "
+ use modbus && myconf="${myconf} --enable-modbus-usb"
+ else
+ myconf="${myconf} --with-upstype=apcsmart --with-upscable=smart --disable-usb"
+ use modbus || myconf="${myconf} --disable-modbus"
+ fi
+
+ # We force the DISTNAME to gentoo so it will use gentoo's layout also
+ # when installed on non-linux systems.
+ econf \
+ --sbindir=/sbin \
+ --sysconfdir=/etc/apcupsd \
+ --with-pwrfail-dir=/etc/apcupsd \
+ --with-lock-dir=/run/apcupsd \
+ --with-pid-dir=/run/apcupsd \
+ --with-log-dir=/var/log \
+ --with-nis-port=3551 \
+ --enable-net --enable-pcnet \
+ --with-distname=gentoo \
+ $(use_enable snmp) \
+ $(use_enable gnome gapcmon) \
+ ${myconf} \
+ APCUPSD_MAIL=$(type -p mail)
+}
+
+src_compile() {
+ # Workaround for bug #280674; upstream should really just provide
+ # the text files in the distribution, but I wouldn't count on them
+ # doing that anytime soon.
+ MANPAGER=$(type -p cat) \
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/etc/init.d/halt || die
+
+ insinto /etc/apcupsd
+ newins examples/safe.apccontrol safe.apccontrol
+ doins "${FILESDIR}"/apcupsd.conf
+
+ doman doc/*.8 doc/*.5
+
+ einstalldocs
+
+ rm "${D}"/etc/init.d/apcupsd || die
+ newinitd "${FILESDIR}/${PN}.init.4" "${PN}"
+ newinitd "${FILESDIR}/${PN}.powerfail.init" "${PN}".powerfail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}-tmpfiles.conf
+
+ # remove hal settings, we don't really want to have it around still.
+ rm -r "${D}"/usr/share/hal || die
+
+ # replace it with our udev rules if we're in Linux
+ if use kernel_linux; then
+ udev_newrules "${FILESDIR}"/apcupsd-udev.rules 60-${PN}.rules
+ fi
+
+}
+
+pkg_postinst() {
+ if use cgi; then
+ elog "The cgi-bin directory for ${PN} is /usr/libexec/${PN}/cgi-bin."
+ elog "Set up your ScriptAlias or symbolic links accordingly."
+ fi
+
+ elog ""
+ elog "Since version 3.14.0 you can use multiple apcupsd instances to"
+ elog "control more than one UPS in a single box with openRC."
+ elog "To do this, create a link between /etc/init.d/apcupsd to a new"
+ elog "/etc/init.d/apcupsd.something, and it will then load the"
+ elog "configuration file at /etc/apcupsd/something.conf."
+ elog ""
+
+ elog 'If you want apcupsd to power off your UPS when it'
+ elog 'shuts down your system in a power failure, you must'
+ elog 'add apcupsd.powerfail to your shutdown runlevel:'
+ elog ''
+ elog ' \e[01m rc-update add apcupsd.powerfail shutdown \e[0m'
+ elog ''
+
+ if use kernel_linux; then
+ elog "Starting from version 3.14.9-r1, ${PN} installs udev rules"
+ elog "for persistent device naming. If you have multiple UPS"
+ elog "connected to the machine, you can point them to the devices"
+ elog "in /dev/apcups/by-id directory."
+ fi
+}