summaryrefslogtreecommitdiff
path: root/sys-power
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /sys-power
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/Manifest.gzbin5220 -> 5222 bytes
-rw-r--r--sys-power/apcupsd/Manifest1
-rw-r--r--sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild138
-rw-r--r--sys-power/hibernate-script/Manifest2
-rw-r--r--sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild7
-rw-r--r--sys-power/iasl/Manifest10
-rw-r--r--sys-power/iasl/files/iasl-20120816-locale.patch15
-rw-r--r--sys-power/iasl/iasl-20121018.ebuild123
-rw-r--r--sys-power/iasl/iasl-20180810.ebuild (renamed from sys-power/iasl/iasl-20140828.ebuild)34
-rw-r--r--sys-power/upower/Manifest2
-rw-r--r--sys-power/upower/upower-0.99.8.ebuild91
11 files changed, 258 insertions, 165 deletions
diff --git a/sys-power/Manifest.gz b/sys-power/Manifest.gz
index a23d5c30eb6a..921475e1f1e1 100644
--- a/sys-power/Manifest.gz
+++ b/sys-power/Manifest.gz
Binary files differ
diff --git a/sys-power/apcupsd/Manifest b/sys-power/apcupsd/Manifest
index 33dd3c435d9f..db954e3adc31 100644
--- a/sys-power/apcupsd/Manifest
+++ b/sys-power/apcupsd/Manifest
@@ -9,4 +9,5 @@ DIST apcupsd-3.14.13.tar.gz 1935043 BLAKE2B 56d8fb9c6a055b20c2d99867e43b6a2d6ebe
DIST apcupsd-3.14.14.tar.gz 1843409 BLAKE2B 48a3b249780064d699d86b658584aa222ce9f3b46a81209110b4684bf737cca7492b87b063154864ce76478f29f73cda83ab96b47f4a7aa7aa91e29a8abbf4a8 SHA512 c953bbf3e08f809748a7978a3952604176390d1cd276f187fe096d9bc3c8993b52127e8350c0363387da41318e24b4d1e00ea58df71f3bb8f50c9a5a64cd2d7f
EBUILD apcupsd-3.14.13.ebuild 3958 BLAKE2B e87053e35983347d5dad1c61ff484e65322678a90e59b23cdd8d97bd745b1590c01958ee8cf04e08b62d037d0bfb10a43f2707b37518877ba3371f49a6a9bb82 SHA512 6563b422815aa8904af1b50983fcf68d951c37be64caea016d5299fa87101d3e7323126f36973a4f43a409d4dd4116cee6876987986ce9def5cecfc67701ae38
EBUILD apcupsd-3.14.14-r1.ebuild 4085 BLAKE2B c8f0842bc550d8a40d5ebf1809a0a27db293a5425895df35502d77b700a5a235aa9fdb6a66c4c786670816bb14cfbaf0a4d6f968e58733f2171cd60b2cb6bee5 SHA512 b0fb1ddaa60c864cc301a9b35e8ccb455df27a3f9fd0c8f2b768b55d8a79a6329ac8d11f1d2d6e68e16502f3ca0e7db0a3b692d2fa805288e21773fe808c2609
+EBUILD apcupsd-3.14.14-r2.ebuild 4089 BLAKE2B 2e9da901aaeb715fc79b763ab20b2c19369eb27c089ead0339a1248e11c5e92cead419abbcd2b2e621c8c0a408245c771630b92901fae509fc54cc2946325202 SHA512 1fc24c9a15098f00ad003cda26a22e1043822fa6f680797e94b200a5983ca71ffe5e8753bba56e55b9c939a589cc94418f0acccfc146b3e312bcf593cc6a1ae0
MISC metadata.xml 1259 BLAKE2B ca28cef92e8edcea0aaeece78cadb43ad8ad836297d8e857540558877a7781922f50c05b018d1a9f7d0753ddfb0a99aff84d16051fdfe5f0d407b79509058a35 SHA512 ba5660026926c0334a47aa3f84bfc0a4ef745db2170a1d773547cf495101cf1274cc24d71d3afa46fa62ebcb49e0913e92e9a0efe4cb70a349f77538b7f60eff
diff --git a/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
new file mode 100644
index 000000000000..9212cf4864ce
--- /dev/null
+++ b/sys-power/apcupsd/apcupsd-3.14.14-r2.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info flag-o-matic systemd udev
+
+DESCRIPTION="APC UPS daemon with integrated tcp/ip remote shutdown"
+HOMEPAGE="http://www.apcupsd.org/"
+SRC_URI="mirror://sourceforge/apcupsd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="snmp +usb +modbus cgi nls gnome kernel_linux"
+
+DEPEND="
+ || ( >=sys-apps/util-linux-2.23[tty-helpers(-)]
+ sys-freebsd/freebsd-ubin
+ )
+ modbus? ( usb? ( virtual/libusb:0 ) )
+ cgi? ( >=media-libs/gd-1.8.4 )
+ nls? ( sys-devel/gettext )
+ snmp? ( >=net-analyzer/net-snmp-5.7.2 )
+ gnome? ( >=x11-libs/gtk+-2.4.0:2
+ dev-libs/glib:2
+ >=gnome-base/gconf-2.0 )"
+RDEPEND="${DEPEND}
+ virtual/mailx"
+
+CONFIG_CHECK="~USB_HIDDEV ~HIDRAW"
+ERROR_USB_HIDDEV="CONFIG_USB_HIDDEV: needed to access USB-attached UPSes"
+ERROR_HIDRAW="CONFIG_HIDRAW: needed to access USB-attached UPSes"
+
+DOCS=( ChangeLog ReleaseNotes )
+HTML_DOCS=( doc/manual )
+PATCHES=( "${FILESDIR}/${PN}-3.14.9-aliasing.patch" )
+
+pkg_setup() {
+ if use kernel_linux && use usb && linux_config_exists; then
+ check_extra_config
+ fi
+}
+
+src_configure() {
+ local myconf
+ use cgi && myconf="${myconf} --enable-cgi --with-cgi-bin=/usr/libexec/${PN}/cgi-bin"
+ if use usb; then
+ myconf="${myconf} --with-upstype=usb --with-upscable=usb --enable-usb --with-dev= "
+ use modbus && myconf="${myconf} --enable-modbus-usb"
+ else
+ myconf="${myconf} --with-upstype=apcsmart --with-upscable=smart --disable-usb"
+ use modbus || myconf="${myconf} --disable-modbus"
+ fi
+
+ # We force the DISTNAME to gentoo so it will use gentoo's layout also
+ # when installed on non-linux systems.
+ econf \
+ --sbindir=/sbin \
+ --sysconfdir=/etc/apcupsd \
+ --with-pwrfail-dir=/etc/apcupsd \
+ --with-lock-dir=/run/apcupsd \
+ --with-pid-dir=/run/apcupsd \
+ --with-log-dir=/var/log \
+ --with-nis-port=3551 \
+ --enable-net --enable-pcnet \
+ --with-distname=gentoo \
+ $(use_enable snmp) \
+ $(use_enable gnome gapcmon) \
+ ${myconf} \
+ APCUPSD_MAIL=$(type -p mail)
+}
+
+src_compile() {
+ # Workaround for bug #280674; upstream should really just provide
+ # the text files in the distribution, but I wouldn't count on them
+ # doing that anytime soon.
+ MANPAGER=$(type -p cat) \
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/etc/init.d/halt || die
+
+ insinto /etc/apcupsd
+ newins examples/safe.apccontrol safe.apccontrol
+ doins "${FILESDIR}"/apcupsd.conf
+
+ doman doc/*.8 doc/*.5
+
+ einstalldocs
+
+ rm "${D}"/etc/init.d/apcupsd || die
+ newinitd "${FILESDIR}/${PN}.init.4" "${PN}"
+ newinitd "${FILESDIR}/${PN}.powerfail.init" "${PN}".powerfail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}-tmpfiles.conf
+
+ # remove hal settings, we don't really want to have it around still.
+ rm -r "${D}"/usr/share/hal || die
+
+ # replace it with our udev rules if we're in Linux
+ if use kernel_linux; then
+ udev_newrules "${FILESDIR}"/apcupsd-udev.rules 60-${PN}.rules
+ fi
+
+}
+
+pkg_postinst() {
+ if use cgi; then
+ elog "The cgi-bin directory for ${PN} is /usr/libexec/${PN}/cgi-bin."
+ elog "Set up your ScriptAlias or symbolic links accordingly."
+ fi
+
+ elog ""
+ elog "Since version 3.14.0 you can use multiple apcupsd instances to"
+ elog "control more than one UPS in a single box with openRC."
+ elog "To do this, create a link between /etc/init.d/apcupsd to a new"
+ elog "/etc/init.d/apcupsd.something, and it will then load the"
+ elog "configuration file at /etc/apcupsd/something.conf."
+ elog ""
+
+ elog 'If you want apcupsd to power off your UPS when it'
+ elog 'shuts down your system in a power failure, you must'
+ elog 'add apcupsd.powerfail to your shutdown runlevel:'
+ elog ''
+ elog ' \e[01m rc-update add apcupsd.powerfail shutdown \e[0m'
+ elog ''
+
+ if use kernel_linux; then
+ elog "Starting from version 3.14.9-r1, ${PN} installs udev rules"
+ elog "for persistent device naming. If you have multiple UPS"
+ elog "connected to the machine, you can point them to the devices"
+ elog "in /dev/apcups/by-id directory."
+ fi
+}
diff --git a/sys-power/hibernate-script/Manifest b/sys-power/hibernate-script/Manifest
index 6d64642213ff..b9c3d80b21b9 100644
--- a/sys-power/hibernate-script/Manifest
+++ b/sys-power/hibernate-script/Manifest
@@ -1,4 +1,4 @@
DIST hibernate-script-2.0-patches-5.tar.bz2 4203 BLAKE2B 4635f1e39c92b7d63de7fe0cf75903d0fd12763c63ac303f06015893268dda81727725cdb4ef055e1a266d9298598776b498f00f9f683a295abb4e9c97c29dbb SHA512 9e9c45c8f9bfde9bfb7d2ab229e355e635ae2f98cfdefa964c07401cdef5e57d0c58976bd491f82a3b9204af213c82f840e0a9b794b2869f2dfe7783dbdb4970
DIST hibernate-script-2.0.tar.gz 84453 BLAKE2B 14b0b2fef2d3e84503a12feed935d44cb65be9e67a14686b5dad18cfa69177bd27dd9e287ffddb13533a005c6106fd81f85f78082a27f0170d26019421090ef9 SHA512 625efdf8bd8561dd9ab93c09436f2fb93edef2fbb0fb2d259727bacffab0b7bd4a6c99d445131390883be75658f6dd28f329fdaf4f03a7d218c0021223ac1a1e
-EBUILD hibernate-script-2.0-r6.ebuild 1840 BLAKE2B 8840c0489bf1bc832ebef13cc03c289191950bec5cd9021666294aa9d6dd455b5e43d3e16c83d91bdf985179ef5eb87d8569752e5999982e1430b23b5ce5fe7c SHA512 3f49f998e364374b9a9b250c82c06c8852c679eb51ac407755567f292cd3247d1628e8428223d98a314ff37c266328ad2cffb1cbab2ce39e0a0f5dff676d639f
+EBUILD hibernate-script-2.0-r6.ebuild 1820 BLAKE2B ca8794a6fca001e254befc76dda1a3191f97dbe71cfad69f8ebba667120ea765fccb841657dbfdca702527c6d9072ddb799e0b2c2e8ad8eb7cbfbf70de60bdaa SHA512 a59f90a76e4b2baca4ad58a19c49d587d3a83d53fa79748d3a687b327ae4143ef6433f0eec1c9f7f58cab69f7db3081d197ff412dfe69a2a0a88cbdefe9e9a8a
MISC metadata.xml 217 BLAKE2B 6e1cd12af01db3565487a9412bae9a06912408439877e1a81fc466c0dc0612175846256a14be3b1102bbd43ac663311d34bc441b5d64caf9462c25ada2cfa3a3 SHA512 1cb210be8d67d18e50ea53bedbfe8b2807e4b2e5c9bf82cc037ce5d60f98d60b5a967e8863a2964769eb6a15626db1e001cc1a38a18b2d1809cc73a3578df4e4
diff --git a/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
index 52906f7d98f0..d53f1555016d 100644
--- a/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
+++ b/sys-power/hibernate-script/hibernate-script-2.0-r6.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PATCH_VERSION="5"
@@ -16,7 +16,6 @@ KEYWORDS="amd64 ppc x86"
IUSE="vim-syntax"
-DEPEND=""
RDEPEND="!<media-gfx/splashutils-1.5.2"
DOCS=(
@@ -37,7 +36,7 @@ src_install() {
"${S}/install.sh" || die "Install failed"
# hibernate-ram will default to using ram.conf
- dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+ dosym hibernate /usr/sbin/hibernate-ram
newinitd init.d/hibernate-cleanup.sh hibernate-cleanup
diff --git a/sys-power/iasl/Manifest b/sys-power/iasl/Manifest
index 8eb2c4121655..ec5c66e37dc8 100644
--- a/sys-power/iasl/Manifest
+++ b/sys-power/iasl/Manifest
@@ -1,19 +1,15 @@
-AUX iasl-20120816-locale.patch 503 BLAKE2B 1fa9d0cb764087d97ecbc6c8c88d93c6b97dc90e0075d8b5742e5724403aba29f1a5bf43bec1268642dfd563c310c736f56e9c020c184691f59010fd66e0c560 SHA512 88012cf788d3ceb319f75834c96a0dbad7cf3db20229616ed7cd19f04903561085086a81adc02eab99aba5d22e215373b5302edc77313e8684a3ec8d4f9ea3a7
AUX iasl-20140214-nostrip.patch 253 BLAKE2B 744ae94cdf798b4d0b593de3e69d408c61b720aebfd385aa2e22929530a8ef84aba92b4484fd2c35cb5c51e15e75e4d8bafcf3c9339b63ca54746db1c30835ad SHA512 1379fa71c03d880b53ed1ed34ec925d5e94fe6f636f86cfdbb5a1e65a1c6a82fb99a42b991be154c018da9eaaa70c7443fa4b5ca38eb03fe5cec4f0de1dd6364
AUX iasl-20140828-locale.patch 349 BLAKE2B b435e40f257103acfaa8f74c8dd5ed66850ce53e3c7577ce59e1773b738dfaff89c58dbdb4517a0213b9b8c1ab4cbdcdf78e2dbe3c0a4857cf4f91b437b23cb9 SHA512 311c20b7d5cdc7e3ce5e2a84e508eb898cd506efa720d1e4bb017ff0b34d786ffed30168b7dcf16b4bee988702d00258289e5e320e0a3bb3cf630a1a71145640
-DIST acpica-unix-20121018.tar.gz 1272523 BLAKE2B 882d540bbfabc790dbdf13af819d8389a6b19de9d88686afb9093723c6cc99ed138e1379531df1a6cca1f7a11746bb8a4da7e3a4bf4dce1d6474c85ea59ba761 SHA512 32824579dccb9d5ba39a895a7905d746d61e2b0d19dcb215aba28e7d976e090d798af2361d474ee0b103a47776d00a6f44128a75a13b1bafb02e86364255523a
-DIST acpica-unix-20140828.tar.gz 1423788 BLAKE2B b694daafe34832ca8d14710b8c92066b9e29006d71b2789854714d9bfe60850349156c711746583cfedb8408b67e42accc6330d0896f66eab636244351eebbf1 SHA512 ab4cb8ba74c5abf05913b6ef39955698f2bb5c243f723d660bd8f9c397fcf2a959d5ec10326a699c53e05319a428e721f1d65a07249574200af3227676725398
DIST acpica-unix-20160729.tar.gz 1556095 BLAKE2B 2785d343d7aa0e3cce83d762bb70f8a7e76221da5d0e803eac3253b4a26dcaf852e114eadf811f387c7c040aeeb794de8cae37c47d8c29968f8cd0a0d76ed4b6 SHA512 37b0439b03e8d811c8b14d0c7c89471989227fb78b462f585c6290431afecc5b258073e568dde8dc982fa959ebce4b4d51589ea997f0066e66d4785ce185ccf2
DIST acpica-unix-20161222.tar.gz 1580428 BLAKE2B dcf44d1a19b51e43ad1a74b2ba5b4bfadeb83eca584ff5a5062aff9cc4b0a65153b1590d993b7bca602e35da747683d230ea56c380afbec3308fb83fdb03908a SHA512 ff733d210b3b013970d3f3a0bea45f346ca5cf78dd61b583d30114a69c80e8272af304d14248aa34e775e19bca1c2ddbbed1b4ba5e8ba660b28621a8ca45ae31
DIST acpica-unix-20171215.tar.gz 1769116 BLAKE2B f15c1202244ce5f489d80240e6c89f7fda38a3c74cf0773c4530e265876f931502571e3086aabae0082654a2085f3d6e5eeed324fd892c199a91a8837fdb19e2 SHA512 4cd3755fe28344de3259dad5209a58c9548216ecaf50a830165a0ee8993af57d4b63836904faafd5f97b1651051ee2f17a908395e0a048bab20b13395fe0d3ff
-DIST acpitests-unix-20121018.tar.gz 1978548 BLAKE2B 9a2d0c8cacffb509400bf272608c2f4adc9dd7f884f59d6b43927cc3f67d996a789eae2a34215c4b9608498b193b82422ed144723fde2a9c101f73a6e3c68e9c SHA512 4c565b9c3af3122f5acfd802e6467124071f45987db0e5d5b9bf87a2d82e433cd6bd1b6faed71dbe6b01694c0f79b390f220515cf287519588ccae71ebafe798
-DIST acpitests-unix-20140828.tar.gz 2008060 BLAKE2B 9bde05aeec61db9d89ac29cb361e5cbf0f6b71501e6f3fd2a7f138be1f8936858d86cdfd9df4d8c3f08efe2e593791f58f1a8a79538f66c23ec599199bb204d9 SHA512 7c3d36c9c1054a56f9b473cd0204062d7ac93b66e1f4d448575182ac3fb0a819506701306be406dd7b8385d37c6f77d7bc4dadc57f6743203ac1bee36a975be5
+DIST acpica-unix-20180810.tar.gz 1797634 BLAKE2B 66b1c53874a7fa898fb042d0aac6001e623bb056ef17de46fc5a8e3ee5667178c47b5d8ecec194ebd8d2b0bdf947b5c85a1874c5d11a9ba3307a85418856ebdb SHA512 f37d8e0f1393b87cbfd9c6607104b05f85386583e4e5a5bcdbd2f049c122592a53e7cd56fe7da75e93bf3a424921fbc9291e7a39e06de80e6403abe042f869cd
DIST acpitests-unix-20160729.tar.gz 1829061 BLAKE2B 8dacb39c477ff8ba8b68a3f061b74e90a128a90eb287b9febd57d6871ff0878dfe2eaf616d9881af2b0bca6c8db57d48711ad9009c6ceb1ceba321bed182a51c SHA512 bf6073092a0dfb208f1d4b13ff3a3c5335be8e1326b1e58acd41def1a402ab0d843600f616019d1dde6593db8c53c6876bd9d489360fe98c6a7bee95d9215600
DIST acpitests-unix-20161222.tar.gz 1759278 BLAKE2B cb1b3ea882135e9ee87c4337df4710ac2e613b89f2606306c3ce68af049735f999ae6a37b1f75c112f0fb5f8bc5af6897bf18715f657c8dcac82a37637da2a57 SHA512 ff0435f40564a94ceb3bc6cfc11ac859a5467b650004238092d7f3e2f7d596e7eb2fb9d3c56f0860c8324d38fcbedf3c6f4bc3f0569f1148462b824c7c025408
DIST acpitests-unix-20171215.tar.gz 2034932 BLAKE2B c36aaf6a8a7aadf54651f95486af918926b664069ed961993c3ee8a062a646a7bd4e40adeebe82a101a5997080b90762fa016724ed4be31af56086eb3c3b3ab9 SHA512 b405e87f18b15bd01540d32c021a7b900139abd7e698b55786ccbaf8536c5068087a8ba1e7adbb69e0954cdc6b347e9a88428f1e8f889e0e9eb3a472c11235f9
-EBUILD iasl-20121018.ebuild 3546 BLAKE2B 916c263b5e3e1f931658b22340662b05fe667dbd543f47e7474b73f4b3888724744ea2023cc84fa1314041fad8ca0b2c23fd48a794e87c458e17206c42d67521 SHA512 2063c817ffd03a7e884738fb93e0860a83a43b1ceedc321bf2257f02d5638e444e49f8b77f2a64c545ff01972daeea9195d33f02e2b409dfae511dbacc8ae057
-EBUILD iasl-20140828.ebuild 3361 BLAKE2B c444493ee3a168fb1f182183f7d81fbe9a430020048052aa5fbb98d25410e5a487dcc06012730e6a93276835b2e42bac4e8ee8b113af4a7470fd542ea89a2f99 SHA512 2e81b1cec125ca70777b514702f2f3ca4a6246b758404dccc3b999e91c4f7054b5a25be76280245320c662213a58387a09ce2c6ea06d8db00ed3f44a768f1dd5
+DIST acpitests-unix-20180810.tar.gz 2093850 BLAKE2B 519ce7807026dc11617ed9c34f294600ddae77a57a1fb76220da50da1bee56975373d583d51dfcdd81c8ccba3d5e735167b831bdb4669ab9cb2a1d9753d9261d SHA512 36c2527e8d670ccfb9a537b4944cfb8432c9638c1427e3c59f614c2ca43a66089228ecb74392301a07f266870e2d79bf0e2c671c6c7af06a4683bf97ac01ba54
EBUILD iasl-20160729.ebuild 3387 BLAKE2B 3caecded7550e0240e4a1ba5936f41475aad9221579bf2abb4e5a12088b3452aea512a718048015b820b5e4d4ac05bf4fab5b1ce0b81db34472e906364cda9a8 SHA512 5ec2719cf0f45344613cb0b5d5fee9e551ada4d44c8e65ef5bc7b241fa49bf910fe711abbf5e1f6a8d136f3aeb182430e8362e519091eac2acc520fc1c93c0ba
EBUILD iasl-20161222.ebuild 3397 BLAKE2B 26d33dc795ac4c8c72b2bfcb4156ed42ae558f0599993de169a6a814a509e5c59fb7ff10cb95e5874f70e057b35588e639dd46bac6eb25a2097d426cced797e1 SHA512 a4c870fe8f286888c18642889d02873c90b966519902a29036fec7b1b772c0ca5e947317eae9a659d0fcfd50c457ae87bb32d04c8c35077efc573a7c58634430
EBUILD iasl-20171215.ebuild 3397 BLAKE2B 26d33dc795ac4c8c72b2bfcb4156ed42ae558f0599993de169a6a814a509e5c59fb7ff10cb95e5874f70e057b35588e639dd46bac6eb25a2097d426cced797e1 SHA512 a4c870fe8f286888c18642889d02873c90b966519902a29036fec7b1b772c0ca5e947317eae9a659d0fcfd50c457ae87bb32d04c8c35077efc573a7c58634430
+EBUILD iasl-20180810.ebuild 3381 BLAKE2B ec55712dba0ce5e8d7b16a8bf23fe74e7f5fbcd155beae88464fddd8f7101651bf054c871640d817bd7b91dcfd8584f47dae4d2ba8b0f78ed2133716147ef732 SHA512 81fab08f17bf94e647f4f0758991ba17327910590dac721bb0d6f25926c346f6650e22b0946ad99523df16955e0b22fcbd0e0510e96ce90142ad6be8c2a63beb
MISC metadata.xml 330 BLAKE2B 4c0218788685cc36fddf5d759c091898a71c01bf22e9e7995d1f5da37cd0508c961895b4265bda462062676f3e722205f0a6b10f64db718110f7afe8f088d136 SHA512 4d7760ec82f64ce49478c359b32aa100ca9778471033741b7fd89905d075b3a067fda413c6dcc5115d7755d0ab6cd9d30a848ff674f1c83ef6205c51ec501a65
diff --git a/sys-power/iasl/files/iasl-20120816-locale.patch b/sys-power/iasl/files/iasl-20120816-locale.patch
deleted file mode 100644
index 425513342105..000000000000
--- a/sys-power/iasl/files/iasl-20120816-locale.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Nuar acpica-unix-20120816.orig/generate/unix/Makefile.config acpica-unix-20120816/generate/unix/Makefile.config
---- acpica-unix-20120816.orig/generate/unix/Makefile.config 2012-08-16 15:51:15.000000000 +0000
-+++ acpica-unix-20120816/generate/unix/Makefile.config 2012-09-07 18:31:41.887229126 +0000
-@@ -161,9 +161,9 @@
- #YACC= byacc
- #YFLAGS += -v -d
- #
--YACC= bison
-+YACC= LC_ALL=C bison
- YFLAGS += -v -d -y
-
--LEX= flex
-+LEX= LC_ALL=C flex
- LFLAGS += -i -s
-
diff --git a/sys-power/iasl/iasl-20121018.ebuild b/sys-power/iasl/iasl-20121018.ebuild
deleted file mode 100644
index 0f20cc66bf6c..000000000000
--- a/sys-power/iasl/iasl-20121018.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit toolchain-funcs flag-o-matic eutils
-
-MY_PN=acpica-unix
-MY_P=${MY_PN}-${PV}
-MY_TESTS_P=${MY_PN/ca/tests}-${PV}
-DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
-HOMEPAGE="https://www.acpica.org/downloads/"
-SRC_URI="http://www.acpica.org/sites/acpica/files/${MY_P}.tar.gz
- test? ( http://www.acpica.org/sites/acpica/files/${MY_TESTS_P}.tar.gz )"
-
-LICENSE="iASL"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="test"
-
-DEPEND="sys-devel/bison
- sys-devel/flex"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if use test && has test ${FEATURES}; then
- ewarn 'You have selected USE="test". This will install the test results'
- ewarn "into /usr/share/${PF}/, compressed as a tarball."
- ewarn 'The tests themselves will only rarely die, but the test results'
- ewarn 'are interesting for arch testing. The tests may take quite some'
- ewarn 'time to complete.'
- fi
-}
-
-src_prepare() {
- #epatch "${FILESDIR}/${PN}-20110922-as-needed.patch"
- epatch "${FILESDIR}/${PN}-20120816-locale.patch"
- # Upstream has changed the buildsystem a lot, not sure if these are still
- # needed
- #epatch "${FILESDIR}/${PN}-20120816-parallelmake-001.patch"
- #epatch "${FILESDIR}/${PN}-20110922-parallelmake-002.patch"
- #epatch "${FILESDIR}/${PN}-20110922-parallelmake-003.patch"
-
- find "${S}" -type f -name 'Makefile*' -print0 | \
- xargs -0 -I '{}' \
- sed -r -e 's:-\<Werror\>::g' -i '{}' \
- || die
-
- export BITS=64
-}
-
-src_configure() {
- :
-}
-
-src_compile() {
- cd acpica/generate/unix
- emake BITS=${BITS}
-}
-
-src_test() {
- aslts_test
- #aapits_test
- #The aapits test currently fails, missing include probably.
-}
-
-src_install() {
- cd acpica/generate/unix
- emake install DESTDIR="${D}" BITS=${BITS}
- default_src_install
- #local bin
- #for bin in $(<"${T}"/binlist) ; do
- # dobin "${T}"/${bin}
- #done
- dodoc "${S}"/changes.txt
- newdoc "${S}"/source/compiler/readme.txt compiler-readme.txt
- newdoc "${S}"/generate/unix/readme.txt unix-readme.txt
- newdoc "${S}"/generate/lint/readme.txt lint-readme.txt
- newdoc "${S}"/source/compiler/new_table.txt compiler-new_table.txt
-
- if use test && has test ${FEATURES}; then
- tb="${T}"/testresults.tar.bz2
- export ASLTSDIR="$(<"${T}"/asltdir)"
- ebegin "Creating Test Tarball"
- tar -cjf "${tb}" -C "${ASLTSDIR}"/tmp/RESULTS . || die "tar failed"
- eend $?
- dodir /usr/share/${PF}
- insinto /usr/share/${PF}
- doins ${tb} || die "doins testresults.tar.bz2 failed"
- fi
-
-}
-
-aslts_test() {
- export ASL="${S}"/generate/unix/bin${BITS}/iasl \
- acpiexec="${S}"/generate/unix/bin${BITS}/acpiexec \
- ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
- export PATH="${PATH}:${ASLTSDIR}/bin"
- echo "$ASLTSDIR" >"${T}"/asltdir
- cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f')
- make install || die "make install aslts test failed"
- chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
-
- #The below Do commands runs the tests twice and then dies if the results aren't
- #Identical.
- Do 1 || die "failed Do 1"
- Do 2 || die "failed Do 2"
-}
-
-aapits_test() {
- mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
- cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f')
- chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
- make || die "make in aapits failed"
- cd asl || die "cd asl failed"
- make || die "make in asl failed"
- cd ../bin
- ./aapitsrun || die "aapitsrun failed"
-}
diff --git a/sys-power/iasl/iasl-20140828.ebuild b/sys-power/iasl/iasl-20180810.ebuild
index d3b1c1eb1a09..b96e7473a7a7 100644
--- a/sys-power/iasl/iasl-20140828.ebuild
+++ b/sys-power/iasl/iasl-20180810.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit toolchain-funcs flag-o-matic eutils
+inherit toolchain-funcs flag-o-matic
MY_PN=acpica-unix
-MY_P=${MY_PN}-${PV}
-MY_TESTS_P=${MY_PN/ca/tests}-${PV}
+MY_P="${MY_PN}-${PV}"
+MY_TESTS_P="${MY_PN/ca/tests}-${PV}"
DESCRIPTION="Intel ACPI Source Language (ASL) compiler"
HOMEPAGE="https://www.acpica.org/downloads/"
SRC_URI="http://www.acpica.org/sites/acpica/files/${MY_P}.tar.gz
@@ -15,14 +15,14 @@ SRC_URI="http://www.acpica.org/sites/acpica/files/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="test"
DEPEND="sys-devel/bison
sys-devel/flex"
RDEPEND=""
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
pkg_setup() {
if use test && has test ${FEATURES}; then
@@ -34,9 +34,13 @@ pkg_setup() {
fi
}
+PATCHES=(
+ "${FILESDIR}/${PN}-20140828-locale.patch"
+ "${FILESDIR}/${PN}-20140214-nostrip.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PN}-20140828-locale.patch" \
- "${FILESDIR}/${PN}-20140214-nostrip.patch"
+ default
find "${S}" -type f -name 'Makefile*' -print0 | \
xargs -0 -I '{}' \
@@ -56,20 +60,20 @@ src_configure() {
}
src_compile() {
- cd acpica/generate/unix
+ cd generate/unix || die
emake BITS=${BITS}
}
src_test() {
aslts_test
- #aapits_test
#The aapits test currently fails, missing include probably.
+ #aapits_test
}
src_install() {
- cd acpica/generate/unix
+ cd generate/unix || die
emake install DESTDIR="${D}" BITS=${BITS}
- default_src_install
+ default
#local bin
#for bin in $(<"${T}"/binlist) ; do
# dobin "${T}"/${bin}
@@ -99,7 +103,7 @@ aslts_test() {
ASLTSDIR="${WORKDIR}/${MY_TESTS_P}"/tests/aslts
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
- cd "${ASLTSDIR}"
+ cd "${ASLTSDIR}" || die
edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -118,6 +122,6 @@ aapits_test() {
make || die "make in aapits failed"
cd asl || die "cd asl failed"
make || die "make in asl failed"
- cd ../bin
+ cd ../bin || die
./aapitsrun || die "aapitsrun failed"
}
diff --git a/sys-power/upower/Manifest b/sys-power/upower/Manifest
index 09f4ff3aa925..8451c2cde842 100644
--- a/sys-power/upower/Manifest
+++ b/sys-power/upower/Manifest
@@ -1,5 +1,7 @@
DIST upower-0.99.5.tar.xz 432344 BLAKE2B 048471cee61e57ee673e2ba2e2f826ef1770291ca5b7a02adcce11acd78f96a3aa443b5f66abc595ce6578ca59a15a940b0c4924b443babc798fa54f4f629564 SHA512 2fb06bea69455f538146576665e36c5b91eb18b119fa77e29d383fcb2a86ea58650b82e258f157d03c40147ecb12ea545997199580f0e24847ac6ea04d46e5ea
DIST upower-0.99.7.tar.xz 447832 BLAKE2B 3342f38552a5eb6abffc6b15803db0e8a24e6a3345fe1007f3a5fa66dd06ddebacf2352a751f7a3adf7ee0fe28797d7a1c5b3ec27cd190aabed17e2c7070a438 SHA512 a1ad200e715284eae815580bba3faad480f7f13401f6ff1a2e7446172796a2413990ce2b553de713ddc530849b2dff1f0ddc12fbd2fd9b55510bbb644d2340a4
+DIST upower-0.99.8.tar.xz 448664 BLAKE2B e101e7d1b2aede77c1ed2da1fd23b87a95ccac8d901bd8d1f8bebcd5de7052a66f1840cf578a48453538e166aae56ef4bc6d3a2b85f7ba148ecac5cc0a486809 SHA512 dfd2960cae382195dfc7a703a02af298d9de55bc626cde2a1f97e7983842191ba9d99eb2044190214e792539e7d6c9d8e00b5aed17e5e86b04544e9ab90278b1
EBUILD upower-0.99.5.ebuild 1978 BLAKE2B 9c989aba064d6208a66d283acac361e5d64965b76838f13709e3d4fad815e9d7170393965b0438cd0a8d7da1813da4d3016d0f2544f380cb90a96c375d16fe4c SHA512 e3d30dd8aa51bf408510d2809f984e74940c4ebb1658b66ff75ca5e25cc3459589a64ea7faf263fd39012304f5a0793d6a75df79f75fb013e0fd1610c74dbf7c
EBUILD upower-0.99.7.ebuild 1986 BLAKE2B e527fbadac423b52703d289dad520cf20f3ee6edec82161195f13c319393de65a6d29879fd1f1cdc2999f7e678676b077979a2db24fae6ac1fc71b03e9a35daf SHA512 515f932021a9b31b6439fb385b08d394915ba1cb4cdf4e83d1c077e62dfb8b84453c3c8e8cf0bc68b78cc5562fdacb01bbea15fdd61a9184d4c84ba1a1a3f83a
+EBUILD upower-0.99.8.ebuild 2175 BLAKE2B 9453243627a001836ccba5fe418934d0fc9a93ae5c43df63f907a7e15e9c089046bafe63edce40f33e310d70168a66a0f4a13f1f58846507141ae66e33a84e06 SHA512 525c97415e4bce4dee6fd487d89ffca9f3c8a7be8c08edae7595231e85a5bfeedee97c6cab31806291aac8ef8ec3ba7310e7866fed3e1989836a69f2643e576b
MISC metadata.xml 228 BLAKE2B 6b6559027915d8578c02e363cc855e812c338acf7716fe4108a8b85c09152a086cb578e7361f4613a44e8b550d7e205ff43aea39dd9488951fa18c6e15042278 SHA512 4f5e63f918a0f8790db49c5b12173c673f86935f00796a04acfed573f618379b73b05b1869941e11f881fe69d4958f5287ce815fd710eadb6ac9f2680894caae
diff --git a/sys-power/upower/upower-0.99.8.ebuild b/sys-power/upower/upower-0.99.8.ebuild
new file mode 100644
index 000000000000..009a7c7b43b4
--- /dev/null
+++ b/sys-power/upower/upower-0.99.8.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit systemd xdg-utils
+
+DESCRIPTION="D-Bus abstraction for enumerating power devices, querying history and statistics"
+HOMEPAGE="https://upower.freedesktop.org/"
+
+# No tarball released, use the same commit as Fedora
+#SRC_URI="https://${PN}.freedesktop.org/releases/${P}.tar.xz"
+COMMIT="9125ab7ee96fdc4ecc68cfefb50c1cab"
+SRC_URI="https://gitlab.freedesktop.org/upower/upower/uploads/${COMMIT}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # based on SONAME of libupower-glib.so
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 sparc ~x86 ~x86-fbsd"
+
+# gtk-doc files are not available as prebuilt in the tarball
+IUSE="doc +introspection ios kernel_FreeBSD kernel_linux selinux"
+
+COMMON_DEPS="
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.34:2
+ sys-apps/dbus:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ kernel_linux? (
+ virtual/libusb:1
+ virtual/libgudev:=
+ virtual/udev
+ ios? (
+ >=app-pda/libimobiledevice-1:=
+ >=app-pda/libplist-1:=
+ )
+ )
+"
+RDEPEND="
+ ${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-devicekit )
+"
+DEPEND="${COMMON_DEPS}
+ doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ dev-util/intltool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+QA_MULTILIB_PATHS="usr/lib/${PN}/.*"
+
+DOCS=( AUTHORS HACKING NEWS README )
+
+src_prepare() {
+ default
+ sed -i -e '/DISABLE_DEPRECATED/d' configure || die
+}
+
+src_configure() {
+ local backend
+
+ if use kernel_linux ; then
+ backend=linux
+ elif use kernel_FreeBSD ; then
+ backend=freebsd
+ else
+ backend=dummy
+ fi
+
+ local myeconfargs=(
+ --disable-static
+ --disable-tests
+ --enable-man-pages
+ --libexecdir="${EPREFIX%/}"/usr/lib/${PN}
+ --localstatedir="${EPREFIX%/}"/var
+ --with-backend=${backend}
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ --with-systemdutildir="$(systemd_get_utildir)"
+ $(use_enable doc gtk-doc)
+ $(use_enable introspection)
+ $(use_with ios idevice)
+ )
+ xdg_environment_reset
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ keepdir /var/lib/upower #383091
+}