summaryrefslogtreecommitdiff
path: root/sys-libs/tevent
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /sys-libs/tevent
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'sys-libs/tevent')
-rw-r--r--sys-libs/tevent/Manifest2
-rw-r--r--sys-libs/tevent/tevent-0.10.2.ebuild28
2 files changed, 17 insertions, 13 deletions
diff --git a/sys-libs/tevent/Manifest b/sys-libs/tevent/Manifest
index 2236e87b78e8..7608a5136b59 100644
--- a/sys-libs/tevent/Manifest
+++ b/sys-libs/tevent/Manifest
@@ -1,3 +1,3 @@
DIST tevent-0.10.2.tar.gz 800731 BLAKE2B 5ea6b83378b04dbe1666432db0dbd4c0df2e6b0bf5ebcc8ec4ec9bdeb834efec75c87b2019dc78c691aba6c4f6467394101febd6010f106046a1fb8848e27405 SHA512 1da8f28898f35daab515892b880d1de601062cc3e2b2570cd62e6913df17b0195a05acb7b484c628cddc0eb8b0cde893105ede3feb32bc5764e7d25684f332ba
-EBUILD tevent-0.10.2.ebuild 1636 BLAKE2B a2fd55e5d6d0053a6f8cf81487c6331fdc7aab75e6c91e34c185e3133644ead0d5c8b69cbb957a6372992a62d2073253e077e9e4613cffe96bf9698648bd33a7 SHA512 099e13ab6b456e151321f8ecf7facd6a4e9aaee8af2fff6731d94d235a83d43ee83f91d5ffc4fd6c865c849bf27310ae97de272bb97d08b67aced855b7c2f5f6
+EBUILD tevent-0.10.2.ebuild 1623 BLAKE2B f5713478edcdd744e058dba6d1d002c246704af6cec5f53dd4e7571f74f6760a7a55ed5faf3ee11eb95ee4611cfe60041c8cec84af5989247c63554229e30aaf SHA512 3bfb71f7f8cb4deec0c4cb651c81e8dc27d695d4ded443bdc5447bb16b38951122102978df6fbc4d7a0d3d33df2b41471861976c63bef2d8ba24399ea950c55c
MISC metadata.xml 345 BLAKE2B 2b19478c92e6a2e49d4421494986bf139e3e130ee9486f8ee2a208ac91db84662fee1b5ced560b29c926e6ab1c07752a4d6679582f220c50713c3b1dc2aa2e6b SHA512 35515a1369eeb1e4949415f8571fc54e7546ac83a59b506e04dc795f0a9b4cb06d7c8e1785577c20ca398fd87543f1742d9d4267fc09320503835bad1fc36cf5
diff --git a/sys-libs/tevent/tevent-0.10.2.ebuild b/sys-libs/tevent/tevent-0.10.2.ebuild
index 2f7b2c211659..bad3eaf202f9 100644
--- a/sys-libs/tevent/tevent-0.10.2.ebuild
+++ b/sys-libs/tevent/tevent-0.10.2.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
-
inherit waf-utils multilib-minimal python-single-r1
DESCRIPTION="Samba tevent library"
HOMEPAGE="https://tevent.samba.org/"
-SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+SRC_URI="https://samba.org/ftp/tevent/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
- >=sys-libs/talloc-2.3.1[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
- python? ( ${PYTHON_DEPS} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
+ python? (
+ ${PYTHON_DEPS}
+ sys-libs/talloc[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig
elibc_glibc? (
net-libs/libtirpc[${MULTILIB_USEDEP}]
|| (
@@ -29,15 +35,13 @@ DEPEND="${RDEPEND}
<sys-libs/glibc-2.26[rpc(+)]
)
)
- ${PYTHON_DEPS}
"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
WAF_BINARY="${S}/buildtools/bin/waf"
-RESTRICT="test"
-
pkg_setup() {
python-single-r1_pkg_setup
}