summaryrefslogtreecommitdiff
path: root/sys-libs/tevent/tevent-0.10.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tevent/tevent-0.10.2.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.10.2.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/sys-libs/tevent/tevent-0.10.2.ebuild b/sys-libs/tevent/tevent-0.10.2.ebuild
index 2f7b2c211659..bad3eaf202f9 100644
--- a/sys-libs/tevent/tevent-0.10.2.ebuild
+++ b/sys-libs/tevent/tevent-0.10.2.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
PYTHON_COMPAT=( python3_{6..9} )
PYTHON_REQ_USE="threads(+)"
-
inherit waf-utils multilib-minimal python-single-r1
DESCRIPTION="Samba tevent library"
HOMEPAGE="https://tevent.samba.org/"
-SRC_URI="https://www.samba.org/ftp/tevent/${P}.tar.gz"
+SRC_URI="https://samba.org/ftp/tevent/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x86-linux"
IUSE="elibc_glibc python"
-RDEPEND="!elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
- >=sys-libs/talloc-2.3.1[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
- python? ( ${PYTHON_DEPS} )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test"
+RDEPEND="
+ !elibc_FreeBSD? ( dev-libs/libbsd[${MULTILIB_USEDEP}] )
+ >=sys-libs/talloc-2.3.1[${MULTILIB_USEDEP}]
+ python? (
+ ${PYTHON_DEPS}
+ sys-libs/talloc[python,${PYTHON_SINGLE_USEDEP}]
+ )
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig
elibc_glibc? (
net-libs/libtirpc[${MULTILIB_USEDEP}]
|| (
@@ -29,15 +35,13 @@ DEPEND="${RDEPEND}
<sys-libs/glibc-2.26[rpc(+)]
)
)
- ${PYTHON_DEPS}
"
-# build system does not work with python3
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
WAF_BINARY="${S}/buildtools/bin/waf"
-RESTRICT="test"
-
pkg_setup() {
python-single-r1_pkg_setup
}