summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'sys-libs/libcxx/libcxx-11.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.9999.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
index bb151379aedf..01acafa1f815 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
@@ -5,8 +5,7 @@ EAPI=7
CMAKE_ECLASS=cmake
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -35,9 +34,6 @@ BDEPEND="
DOCS=( CREDITS.TXT )
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
python_check_deps() {
has_version "dev-python/lit[${PYTHON_USEDEP}]"
}
@@ -59,10 +55,7 @@ src_prepare() {
# out-of-tree build.
eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
+ llvm.org_src_prepare
}
test_compiler() {
@@ -133,13 +126,11 @@ multilib_src_configure() {
if use test; then
local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
- local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
[[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags);--param=cxx_under_test=${clang_path}"
)
fi
cmake_src_configure