summaryrefslogtreecommitdiff
path: root/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'sys-libs/libcxx/libcxx-11.0.0.9999.ebuild')
-rw-r--r--sys-libs/libcxx/libcxx-11.0.0.9999.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
index c8f3b48d30c5..bb151379aedf 100644
--- a/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-11.0.0.9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+CMAKE_ECLASS=cmake
+PYTHON_COMPAT=( python3_{6..9} )
inherit cmake-multilib llvm llvm.org multiprocessing python-any-r1 \
toolchain-funcs
@@ -34,12 +35,6 @@ BDEPEND="
DOCS=( CREDITS.TXT )
-PATCHES=(
- # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
- # out-of-tree build.
- "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
-)
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
@@ -59,6 +54,17 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
+ # out-of-tree build.
+ eapply "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
+
+ # cmake eclasses suck by forcing ${S} here
+ CMAKE_USE_DIR=${S} \
+ S=${WORKDIR} \
+ cmake_src_prepare
+}
+
test_compiler() {
$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
<<<'int main() { return 0; }' &>/dev/null
@@ -136,12 +142,12 @@ multilib_src_configure() {
-DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_test() {
local -x LIT_PRESERVES_TMP=1
- cmake-utils_src_make check-cxx
+ cmake_build check-cxx
}
# Usage: deps
@@ -187,7 +193,7 @@ gen_shared_ldscript() {
}
multilib_src_install() {
- cmake-utils_src_install
+ cmake_src_install
gen_shared_ldscript
use static-libs && gen_static_ldscript
}