summaryrefslogtreecommitdiff
path: root/sys-cluster/rocm-k8s-device-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 08:17:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 08:17:33 +0100
commitc2968b21192246c8fa4e99d5a2944658096f868e (patch)
tree7484ee755cf801622a77a7212739fffde9dff5a0 /sys-cluster/rocm-k8s-device-plugin
parented40f2eafae80bcb56715a81c92b1f9c29364bad (diff)
gentoo auto-resync : 10:08:2022 - 08:17:33
Diffstat (limited to 'sys-cluster/rocm-k8s-device-plugin')
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/Manifest3
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/metadata.xml8
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild34
3 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/rocm-k8s-device-plugin/Manifest b/sys-cluster/rocm-k8s-device-plugin/Manifest
new file mode 100644
index 000000000000..a0ea87d44b7a
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST rocm-k8s-device-plugin-0.3.0.tar.gz 5188051 BLAKE2B cff5a5eefea521fc398a3b9199375f8a4ed875688fc06bc6a097cdef017d1ef102eea096a8e37aa2d962afc2fc0a8153c26e36b226a31a1913ae2de97d632650 SHA512 d5c9c590aeb5fb744917662c9bc8a88a95c7b4478c614808c86ecb6caaf4f20c81a0013e6352d701c29c9c10810231ab142859ee95923e31d9267206209e4948
+EBUILD rocm-k8s-device-plugin-0.3.0.ebuild 840 BLAKE2B 5892b27256156d6ac2fe102faebd708302c7706c1579921043583d241e9f4544c70855b4c08089708665f1a9c85bd82476a7eb4fc4915c8da23e58b2c81e1200 SHA512 305495b731682cfdacabe188914190c271a98d001f53c09dde724fdd2de354f17265f5a8a459a4e3530cb28de3ca99a276c8a676efe689cd2afc648a26154832
+MISC metadata.xml 249 BLAKE2B 08603bf9d754b59bae12620988552abc7f76b87a1390d02038789eba034c22412a3593d10f443794a5171ff3905c2b5c822368b2eb9f53a528097b7b6c80ffe9 SHA512 338d72efbd040697be98aad4229b81c9694eb27ecbc39f3a18332f4cc766a46b4a0a92f32612203259bf58f5838d0aff7f0b1abec7766f6cd2394c73f7f0b251
diff --git a/sys-cluster/rocm-k8s-device-plugin/metadata.xml b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
new file mode 100644
index 000000000000..d6426fa96bbe
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# update these on every bump
+VERSION=v1.18.1-8-gabd271e
+TAG="amd-gpu-helm-${PV}"
+
+DESCRIPTION="AMD GPU device plugin for kubernetes"
+HOMEPAGE="https://github.com/RadeonOpenCompute/k8s-device-plugin"
+SRC_URI="https://github.com/RadeonOpenCompute/k8s-device-plugin/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-apps/hwloc
+ x11-libs/libdrm[video_cards_amdgpu]"
+RDEPEND="${DEPEND}
+ sys-cluster/kubelet"
+
+S="${WORKDIR}/k8s-device-plugin-${TAG}"
+
+src_compile() {
+ GOBIN="${S}/bin" ego install -ldflags="-X main.gitDescribe=${VERSION}" \
+ ./cmd/k8s-device-plugin
+}
+
+src_install() {
+ exeinto /var/lib/kubelet/device-plugins
+ doexe bin/k8s-device-plugin
+ einstalldocs
+}