summaryrefslogtreecommitdiff
path: root/sys-cluster
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 08:17:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 08:17:33 +0100
commitc2968b21192246c8fa4e99d5a2944658096f868e (patch)
tree7484ee755cf801622a77a7212739fffde9dff5a0 /sys-cluster
parented40f2eafae80bcb56715a81c92b1f9c29364bad (diff)
gentoo auto-resync : 10:08:2022 - 08:17:33
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/Manifest.gzbin11389 -> 11573 bytes
-rw-r--r--sys-cluster/crmsh/Manifest1
-rw-r--r--sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild46
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/Manifest3
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/metadata.xml8
-rw-r--r--sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild34
6 files changed, 92 insertions, 0 deletions
diff --git a/sys-cluster/Manifest.gz b/sys-cluster/Manifest.gz
index eae17bc1c5d0..28208f86903b 100644
--- a/sys-cluster/Manifest.gz
+++ b/sys-cluster/Manifest.gz
Binary files differ
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
index b9a8762b0f7e..6d97855febe9 100644
--- a/sys-cluster/crmsh/Manifest
+++ b/sys-cluster/crmsh/Manifest
@@ -1,4 +1,5 @@
DIST crmsh-4.2.1.tar.gz 1058921 BLAKE2B 84d1f8685e792d9f453b2d185ccda4e8c2c9566becd85ed8308c014bd18e1479f601f3e89e4a1c3464c0d5bb797d7ddf9ddff479cd8c4c0d2998fd528f8ecbd2 SHA512 df0945f1b977993a0aca89af7c9030bc798aac4397a9d448d47bf68331e8aec83fa6155f2897f3c84573bcdb20fa384a1489b4f1d69fd1a831ece2fdb2b5b321
EBUILD crmsh-4.2.1-r1.ebuild 915 BLAKE2B 491f31b3add8b294a447c8ef3c883f965f2b8a5d3ee1acf843a6f56d82695cc762c3d4181ebf52d277c388c43fcda9191aeacca22285a9da6361a1d5d706a735 SHA512 e420ce9d65ec0554fbbc59ea7facb5a6675e60fafb027fd144a07fb008775d01781c4c8a06133d47331408164f3d797cb435a76e99c31a9d809ebdd0d7e599cd
EBUILD crmsh-4.2.1-r2.ebuild 878 BLAKE2B d9e4af1e084534f334e7cd730098c3ed187b469e5ade0598158d0baf49244760512c62146ade4aad15184fbca52398ea4f75ddb73ba6b1a066b83d415d76a173 SHA512 23a0945babed96f0a2123d65d23be03f4763b8eacbe067280758c888a5e2b5f036384878cffe6e4b20aaab5b1b5a3e270e0e43d1acea0f5b3b0d06286a5004e8
+EBUILD crmsh-4.2.1-r3.ebuild 940 BLAKE2B 3c9db7e828e31850cef8390bf81f212b14747885c35fef9534132ffdf09b3f91ffd4c59f1c3ae472d83956e8ec25a00185e6480e63bd266f69c866594dfb9631 SHA512 36fbffa21b284c44bbd1c9d8fc019dc1803167301e3aa7e15d662c3d006d8e0c895d42c7cf00070aba0ea7fb317bfc2f26bdc4a27f5ec96ffdda32719823f635
MISC metadata.xml 344 BLAKE2B 3dd1aba1bed81c9993d1d9527e5695c4538c32014dc4da3303c602031182421f50629296c69f2f821455d29a0beb01a94b86541421d31462d37b05bbd57b41f0 SHA512 8fddf2b64d5dbdc79ccc206e36e33c2aee2c17ffc1c6012c80431d3d487734538c6efc3e3b6803407535783b1afa91901b929220874f8d20ce2616ad6cdb967d
diff --git a/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild b/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild
new file mode 100644
index 000000000000..88ea25ce1490
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.2.1-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-r3
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/parallax[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_optimize
+}
diff --git a/sys-cluster/rocm-k8s-device-plugin/Manifest b/sys-cluster/rocm-k8s-device-plugin/Manifest
new file mode 100644
index 000000000000..a0ea87d44b7a
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST rocm-k8s-device-plugin-0.3.0.tar.gz 5188051 BLAKE2B cff5a5eefea521fc398a3b9199375f8a4ed875688fc06bc6a097cdef017d1ef102eea096a8e37aa2d962afc2fc0a8153c26e36b226a31a1913ae2de97d632650 SHA512 d5c9c590aeb5fb744917662c9bc8a88a95c7b4478c614808c86ecb6caaf4f20c81a0013e6352d701c29c9c10810231ab142859ee95923e31d9267206209e4948
+EBUILD rocm-k8s-device-plugin-0.3.0.ebuild 840 BLAKE2B 5892b27256156d6ac2fe102faebd708302c7706c1579921043583d241e9f4544c70855b4c08089708665f1a9c85bd82476a7eb4fc4915c8da23e58b2c81e1200 SHA512 305495b731682cfdacabe188914190c271a98d001f53c09dde724fdd2de354f17265f5a8a459a4e3530cb28de3ca99a276c8a676efe689cd2afc648a26154832
+MISC metadata.xml 249 BLAKE2B 08603bf9d754b59bae12620988552abc7f76b87a1390d02038789eba034c22412a3593d10f443794a5171ff3905c2b5c822368b2eb9f53a528097b7b6c80ffe9 SHA512 338d72efbd040697be98aad4229b81c9694eb27ecbc39f3a18332f4cc766a46b4a0a92f32612203259bf58f5838d0aff7f0b1abec7766f6cd2394c73f7f0b251
diff --git a/sys-cluster/rocm-k8s-device-plugin/metadata.xml b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
new file mode 100644
index 000000000000..d6426fa96bbe
--- /dev/null
+++ b/sys-cluster/rocm-k8s-device-plugin/rocm-k8s-device-plugin-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# update these on every bump
+VERSION=v1.18.1-8-gabd271e
+TAG="amd-gpu-helm-${PV}"
+
+DESCRIPTION="AMD GPU device plugin for kubernetes"
+HOMEPAGE="https://github.com/RadeonOpenCompute/k8s-device-plugin"
+SRC_URI="https://github.com/RadeonOpenCompute/k8s-device-plugin/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-apps/hwloc
+ x11-libs/libdrm[video_cards_amdgpu]"
+RDEPEND="${DEPEND}
+ sys-cluster/kubelet"
+
+S="${WORKDIR}/k8s-device-plugin-${TAG}"
+
+src_compile() {
+ GOBIN="${S}/bin" ego install -ldflags="-X main.gitDescribe=${VERSION}" \
+ ./cmd/k8s-device-plugin
+}
+
+src_install() {
+ exeinto /var/lib/kubelet/device-plugins
+ doexe bin/k8s-device-plugin
+ einstalldocs
+}