summaryrefslogtreecommitdiff
path: root/sys-auth/pambase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /sys-auth/pambase
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'sys-auth/pambase')
-rw-r--r--sys-auth/pambase/Manifest3
-rw-r--r--sys-auth/pambase/pambase-20201103.ebuild13
-rw-r--r--sys-auth/pambase/pambase-999999999.ebuild105
3 files changed, 116 insertions, 5 deletions
diff --git a/sys-auth/pambase/Manifest b/sys-auth/pambase/Manifest
index 659e7e3827f0..fc1697848354 100644
--- a/sys-auth/pambase/Manifest
+++ b/sys-auth/pambase/Manifest
@@ -1,3 +1,4 @@
DIST pambase-20201103.tar.gz 3295 BLAKE2B 7e104b5342842a21e10dce6e5c5a2d330ec06146b4791b888518463d915eebefbd694a809ff676b32c9c43945087935dc5c3496ae93ac17b7e4fd4e2e2974d1a SHA512 b94e47780f45c5e897b5fd073ce2184a901d241d51516ac5007658b1ae423d0f34c37a09a9e1d055962aa7158675ea7740dfe6466fad5e4a1b50b66a0812f51d
-EBUILD pambase-20201103.ebuild 2660 BLAKE2B 036c5ee1f9b4d50384dbff61dce8270440269f009811d306b24abe13159df6275f0029033637e808340ae0d25b47597ea3cbad68836270c9b0fa460fe1b568fe SHA512 3c1910c0f2c0a7a23bb154d69e04fd0774591df3d64a2acd5287556416b22ec699dc8726853e515d43cc92a93ddc8c08ec09af164735066a1b812802e73d5c56
+EBUILD pambase-20201103.ebuild 2772 BLAKE2B d953df87a7801ef83ee9f1efeb6a9fd9f9ca3c2713004b3fb6ad853903a36e21fd70f17dd9eefabc5483ff6141238514487ae491afa98908d2f4c121b9597d91 SHA512 c43f51170fdc005d2fda51e3ab1eeafcf9ce6a3bd84ddbb63aa608e9f5548b1bfb367c8084e9b08f6a621d77298682d3ba8192baad0b641183b4bdfb8db47436
+EBUILD pambase-999999999.ebuild 2772 BLAKE2B d953df87a7801ef83ee9f1efeb6a9fd9f9ca3c2713004b3fb6ad853903a36e21fd70f17dd9eefabc5483ff6141238514487ae491afa98908d2f4c121b9597d91 SHA512 c43f51170fdc005d2fda51e3ab1eeafcf9ce6a3bd84ddbb63aa608e9f5548b1bfb367c8084e9b08f6a621d77298682d3ba8192baad0b641183b4bdfb8db47436
MISC metadata.xml 3810 BLAKE2B f4485cfec915c9e239c9328e6df338ba787ab26c3bb4f84773aa29361f4e2c48b56afb787c176fb38e8dc1c923e07c5baa6aeb5dba2774fe61f20250baf36b7d SHA512 ea58b1a801e68eeb8b7325192f5f26b406879bb70a46383222ffb9f69c71e5f9803532f2cca510ec0bc5cc3a96ceb165ed11725341a51b123fe8d4a712f4c26a
diff --git a/sys-auth/pambase/pambase-20201103.ebuild b/sys-auth/pambase/pambase-20201103.ebuild
index 30aca642bcf0..085421e24509 100644
--- a/sys-auth/pambase/pambase-20201103.ebuild
+++ b/sys-auth/pambase/pambase-20201103.ebuild
@@ -9,11 +9,18 @@ inherit pam python-any-r1 readme.gentoo-r1
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
-SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/pambase.git"
+else
+ SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}-${P}"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="caps debug elogind gnome-keyring minimal mktemp +nullok pam_krb5 pam_ssh +passwdqc pwhistory pwquality securetty selinux +sha512 systemd"
RESTRICT="binchecks"
@@ -52,8 +59,6 @@ python_check_deps() {
has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
}
-S="${WORKDIR}/${PN}-${P}"
-
src_configure() {
${EPYTHON} ./${PN}.py \
$(usex caps '--caps' '') \
diff --git a/sys-auth/pambase/pambase-999999999.ebuild b/sys-auth/pambase/pambase-999999999.ebuild
new file mode 100644
index 000000000000..085421e24509
--- /dev/null
+++ b/sys-auth/pambase/pambase-999999999.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit pam python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="PAM base configuration files"
+HOMEPAGE="https://github.com/gentoo/pambase"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/pambase.git"
+else
+ SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="caps debug elogind gnome-keyring minimal mktemp +nullok pam_krb5 pam_ssh +passwdqc pwhistory pwquality securetty selinux +sha512 systemd"
+
+RESTRICT="binchecks"
+
+REQUIRED_USE="
+ ?? ( elogind systemd )
+ ?? ( passwdqc pwquality )
+ pwhistory? ( || ( passwdqc pwquality ) )
+"
+
+MIN_PAM_REQ=1.4.0
+
+RDEPEND="
+ >=sys-libs/pam-${MIN_PAM_REQ}
+ elogind? ( sys-auth/elogind[pam] )
+ gnome-keyring? ( gnome-base/gnome-keyring[pam] )
+ mktemp? ( sys-auth/pam_mktemp )
+ pam_krb5? (
+ >=sys-libs/pam-${MIN_PAM_REQ}
+ sys-auth/pam_krb5
+ )
+ caps? ( sys-libs/libcap[pam] )
+ pam_ssh? ( sys-auth/pam_ssh )
+ passwdqc? ( >=sys-auth/passwdqc-1.4.0-r1 )
+ pwquality? ( dev-libs/libpwquality[pam] )
+ selinux? ( sys-libs/pam[selinux] )
+ sha512? ( >=sys-libs/pam-${MIN_PAM_REQ} )
+ systemd? ( sys-apps/systemd[pam] )
+"
+
+BDEPEND="$(python_gen_any_dep '
+ dev-python/jinja[${PYTHON_USEDEP}]
+ ')"
+
+python_check_deps() {
+ has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
+}
+
+src_configure() {
+ ${EPYTHON} ./${PN}.py \
+ $(usex caps '--caps' '') \
+ $(usex debug '--debug' '') \
+ $(usex elogind '--elogind' '') \
+ $(usex gnome-keyring '--gnome-keyring' '') \
+ $(usex minimal '--minimal' '') \
+ $(usex mktemp '--mktemp' '') \
+ $(usex nullok '--nullok' '') \
+ $(usex pam_krb5 '--krb5' '') \
+ $(usex pam_ssh '--pam-ssh' '') \
+ $(usex passwdqc '--passwdqc' '') \
+ $(usex pwhistory '--pwhistory' '') \
+ $(usex pwquality '--pwquality' '') \
+ $(usex securetty '--securetty' '') \
+ $(usex selinux '--selinux' '') \
+ $(usex sha512 '--sha512' '') \
+ $(usex systemd '--systemd' '') \
+ || die
+}
+
+src_test() { :; }
+
+src_install() {
+ local DOC_CONTENTS
+
+ if use passwdqc; then
+ DOC_CONTENTS="To amend the existing password policy please see the man 5 passwdqc.conf
+ page and then edit the /etc/security/passwdqc.conf file"
+ fi
+
+ if use pwquality; then
+ DOC_CONTENTS="To amend the existing password policy please see the man 5 pwquality.conf
+ page and then edit the /etc/security/pwquality.conf file"
+ fi
+
+ { use passwdqc || use pwquality; } && readme.gentoo_create_doc
+
+ dopamd -r stack/.
+}
+
+pkg_postinst() {
+ { use passwdqc || use pwquality; } && readme.gentoo_print_elog
+}