summaryrefslogtreecommitdiff
path: root/sys-auth/pambase/pambase-20201103.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pambase/pambase-20201103.ebuild')
-rw-r--r--sys-auth/pambase/pambase-20201103.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-auth/pambase/pambase-20201103.ebuild b/sys-auth/pambase/pambase-20201103.ebuild
index 30aca642bcf0..085421e24509 100644
--- a/sys-auth/pambase/pambase-20201103.ebuild
+++ b/sys-auth/pambase/pambase-20201103.ebuild
@@ -9,11 +9,18 @@ inherit pam python-any-r1 readme.gentoo-r1
DESCRIPTION="PAM base configuration files"
HOMEPAGE="https://github.com/gentoo/pambase"
-SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/pambase.git"
+else
+ SRC_URI="https://github.com/gentoo/pambase/archive/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${PN}-${P}"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
IUSE="caps debug elogind gnome-keyring minimal mktemp +nullok pam_krb5 pam_ssh +passwdqc pwhistory pwquality securetty selinux +sha512 systemd"
RESTRICT="binchecks"
@@ -52,8 +59,6 @@ python_check_deps() {
has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
}
-S="${WORKDIR}/${PN}-${P}"
-
src_configure() {
${EPYTHON} ./${PN}.py \
$(usex caps '--caps' '') \