summaryrefslogtreecommitdiff
path: root/sci-physics/hepmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /sci-physics/hepmc
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'sci-physics/hepmc')
-rw-r--r--sci-physics/hepmc/Manifest2
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09-r1.ebuild29
2 files changed, 16 insertions, 15 deletions
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
index 586c75a0a368..7b019433a0ab 100644
--- a/sci-physics/hepmc/Manifest
+++ b/sci-physics/hepmc/Manifest
@@ -1,3 +1,3 @@
DIST HepMC-2.06.09.tar.gz 4612637 BLAKE2B 6bbf1a6a8410b6717ddff29fc3643247582f7a61a05fd9e52a0b09f78bf75de587c1c55525f6a1367b306a26a4687ce55b64908c049d91bdb2db3d40467af62b SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4
-EBUILD hepmc-2.06.09-r1.ebuild 2034 BLAKE2B de4821607cdadfc233c0fa028d962fd9a6a09b74ef3e3baba127c4c55d4d85b0c40f3e390dff9aabe3dd90e6542fce5335194cbc2a768239f6421e0e602a316c SHA512 0c83528e2872cacac7ea2e343a479fb383f6a64af6286737a09e2ed5d57e12cba1e0d579662e7a3a866f75790726b56e822131e9572d1c85fd4951fec823fc51
+EBUILD hepmc-2.06.09-r1.ebuild 1983 BLAKE2B 834ec2bedcb51e1193a5da3bece07ea4813861fd2b607b09eb61e828746ff95b6429845a3990a7bfd4b4c3ac6e20c1012f344e144dcb8a6534e52e545b7e03ce SHA512 1480b2fea426367d582335d111d3ae154f146ecd09ee4f36d745b0c66a7be2c21f9b3da4888c7aac494712a52298144e19df24c5bd7e4db8e01942ead939e419
MISC metadata.xml 1386 BLAKE2B aafa21d2da77f67da6bb8f88ea88e96365f3575a4435614a010c4f8b7241a2f4837623ced2f86f781fa8f0dba72048fb22c9ab72677d7ff128e5c3ba4767f95e SHA512 b0ef90b6404b04d1d393e9e8bb04ff08a51f72938362f4ae1e2806bfe29c99d50089f15ddacb59b94d6d554d0ec8842ba7b89777434e0bab08c51627ab8bd9ce
diff --git a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
index 46b3b6d47d9e..fd3d790263ae 100644
--- a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit cmake-utils
MYP=HepMC-${PV}
DESCRIPTION="Event Record for Monte Carlo Generators"
-HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepMC/"
+HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
LICENSE="GPL-2"
@@ -33,7 +33,7 @@ DOCS=( ChangeLog AUTHORS )
src_prepare() {
cmake-utils_src_prepare
- sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt
+ sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt || die
# CMake doc building broken
# gentoo doc directory
#sed -i \
@@ -56,8 +56,12 @@ src_prepare() {
{src,fio}/CMakeLists.txt || die
# remove targets if use flags not set
- use examples || sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt
- use test || sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt
+ if ! use examples; then
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+ fi
+ if ! use test; then
+ sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt || die
+ fi
if ! use static-libs; then
sed -i \
-e '/(HepMC\(fio\|\)S/d' \
@@ -68,13 +72,9 @@ src_prepare() {
src_configure() {
# use MeV over GeV and mm over cm
- local length_conf="MM"
- use cm && length_conf="CM"
- local momentum_conf="MEV"
- use gev && momentum_conf="GEV"
- mycmakeargs+=(
- -Dlength=${length_conf}
- -Dmomentum=${momentum_conf}
+ local mycmakeargs=(
+ -Dlength=$(usex cm CM MM)
+ -Dmomentum=$(usex gev GEV MEV)
)
cmake-utils_src_configure
}
@@ -89,6 +89,7 @@ src_compile() {
}
src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ use doc && dodoc doc/*.pdf
cmake-utils_src_install
- use doc && dodoc doc/*.pdf && dohtml -r doc/html/*
}