summaryrefslogtreecommitdiff
path: root/sci-physics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /sci-physics
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/Manifest.gzbin5863 -> 5869 bytes
-rw-r--r--sci-physics/hepmc/Manifest2
-rw-r--r--sci-physics/hepmc/hepmc-2.06.09-r1.ebuild29
-rw-r--r--sci-physics/root/Manifest2
-rw-r--r--sci-physics/root/metadata.xml1
5 files changed, 17 insertions, 17 deletions
diff --git a/sci-physics/Manifest.gz b/sci-physics/Manifest.gz
index 939bcd02c032..b65b31c814f2 100644
--- a/sci-physics/Manifest.gz
+++ b/sci-physics/Manifest.gz
Binary files differ
diff --git a/sci-physics/hepmc/Manifest b/sci-physics/hepmc/Manifest
index 586c75a0a368..7b019433a0ab 100644
--- a/sci-physics/hepmc/Manifest
+++ b/sci-physics/hepmc/Manifest
@@ -1,3 +1,3 @@
DIST HepMC-2.06.09.tar.gz 4612637 BLAKE2B 6bbf1a6a8410b6717ddff29fc3643247582f7a61a05fd9e52a0b09f78bf75de587c1c55525f6a1367b306a26a4687ce55b64908c049d91bdb2db3d40467af62b SHA512 1030f31ad9d19d8ae184145a693c4a3092131f485e2ed89598b7172992a825ad9aa46fb44a9199a00c4a6bd7e163daead9452e9bc4fe32cb3b97351cf22906c4
-EBUILD hepmc-2.06.09-r1.ebuild 2034 BLAKE2B de4821607cdadfc233c0fa028d962fd9a6a09b74ef3e3baba127c4c55d4d85b0c40f3e390dff9aabe3dd90e6542fce5335194cbc2a768239f6421e0e602a316c SHA512 0c83528e2872cacac7ea2e343a479fb383f6a64af6286737a09e2ed5d57e12cba1e0d579662e7a3a866f75790726b56e822131e9572d1c85fd4951fec823fc51
+EBUILD hepmc-2.06.09-r1.ebuild 1983 BLAKE2B 834ec2bedcb51e1193a5da3bece07ea4813861fd2b607b09eb61e828746ff95b6429845a3990a7bfd4b4c3ac6e20c1012f344e144dcb8a6534e52e545b7e03ce SHA512 1480b2fea426367d582335d111d3ae154f146ecd09ee4f36d745b0c66a7be2c21f9b3da4888c7aac494712a52298144e19df24c5bd7e4db8e01942ead939e419
MISC metadata.xml 1386 BLAKE2B aafa21d2da77f67da6bb8f88ea88e96365f3575a4435614a010c4f8b7241a2f4837623ced2f86f781fa8f0dba72048fb22c9ab72677d7ff128e5c3ba4767f95e SHA512 b0ef90b6404b04d1d393e9e8bb04ff08a51f72938362f4ae1e2806bfe29c99d50089f15ddacb59b94d6d554d0ec8842ba7b89777434e0bab08c51627ab8bd9ce
diff --git a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
index 46b3b6d47d9e..fd3d790263ae 100644
--- a/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
+++ b/sci-physics/hepmc/hepmc-2.06.09-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit cmake-utils
MYP=HepMC-${PV}
DESCRIPTION="Event Record for Monte Carlo Generators"
-HOMEPAGE="http://lcgapp.cern.ch/project/simu/HepMC/"
+HOMEPAGE="https://hepmc.web.cern.ch/hepmc/"
SRC_URI="http://lcgapp.cern.ch/project/simu/HepMC/download/${MYP}.tar.gz"
LICENSE="GPL-2"
@@ -33,7 +33,7 @@ DOCS=( ChangeLog AUTHORS )
src_prepare() {
cmake-utils_src_prepare
- sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt
+ sed -i -e '/add_subdirectory(doc)/d' CMakeLists.txt || die
# CMake doc building broken
# gentoo doc directory
#sed -i \
@@ -56,8 +56,12 @@ src_prepare() {
{src,fio}/CMakeLists.txt || die
# remove targets if use flags not set
- use examples || sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt
- use test || sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt
+ if ! use examples; then
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+ fi
+ if ! use test; then
+ sed -i -e '/add_subdirectory(test)/d' CMakeLists.txt || die
+ fi
if ! use static-libs; then
sed -i \
-e '/(HepMC\(fio\|\)S/d' \
@@ -68,13 +72,9 @@ src_prepare() {
src_configure() {
# use MeV over GeV and mm over cm
- local length_conf="MM"
- use cm && length_conf="CM"
- local momentum_conf="MEV"
- use gev && momentum_conf="GEV"
- mycmakeargs+=(
- -Dlength=${length_conf}
- -Dmomentum=${momentum_conf}
+ local mycmakeargs=(
+ -Dlength=$(usex cm CM MM)
+ -Dmomentum=$(usex gev GEV MEV)
)
cmake-utils_src_configure
}
@@ -89,6 +89,7 @@ src_compile() {
}
src_install() {
+ use doc && HTML_DOCS=( doc/html/. )
+ use doc && dodoc doc/*.pdf
cmake-utils_src_install
- use doc && dodoc doc/*.pdf && dohtml -r doc/html/*
}
diff --git a/sci-physics/root/Manifest b/sci-physics/root/Manifest
index 318f49da4cf6..191772a26568 100644
--- a/sci-physics/root/Manifest
+++ b/sci-physics/root/Manifest
@@ -14,4 +14,4 @@ DIST root_v6.14.04.source.tar.gz 162451369 BLAKE2B c7af9cf18736c900f71c35b7f9df9
EBUILD root-6.12.06-r7.ebuild 7895 BLAKE2B 1edf90da948b0c3165624648f2679b602569d52484e6c49100d7e8834ff91ce84ae342da932c76c19b1dedd1dffeb175770e2a8c3f2a24dfb0e14938cefbdaff SHA512 786cdcb479098dc18e07e03201d6c27da80aef873997f828eda430499d462b2532cc1219432095eb34fb721e10a903a760be336111537379488c57ebf3ae2558
EBUILD root-6.14.04-r3.ebuild 7918 BLAKE2B 40bc6ad41f77f2d844f4f75b09b05f44a311fe268545b4cccafae84169735926238321874d5fcc2e3a7ec18578cd194208f5153559ef3f2ae1188c90a1a9637e SHA512 aac213999b59f79112150ecb4785135dfe59948cf37cde2afddf3f3751574cb7457a9d124bd555cf5c119a426ceabc8f926452c5927294824616e6672220d71f
EBUILD root-9999.ebuild 8142 BLAKE2B 785d7040bfdb6664c613390e7b16e5d05259b9e46ab35a956a53b6534cdd92338513055b807dd12398e3f3910d946fa81c0dcde57aeb253b438c1b0ab6f361ea SHA512 52ee93459aca1826856d22c89982ef2281d855d89be88340d1d24d0aac47c43aefd23da024e0333b0a3d0a8e825fbb09302e17a69ea6b817cc03f2d52af718ef
-MISC metadata.xml 2977 BLAKE2B f0c2cd6f71ff44c2e3f767ec08ee7051c3501f6e57998dc0ad744f609862c0ac686d85fa65f85cf562edfbc51d4f62048a3beaa31e6c66aa965d8a182d438a42 SHA512 f9d4a99776394f7c273b7eb2c69060e5580bbc4f546b6f2001690c1dbcfc5f56e090c259beadc18d54aae4a0fcb3ba517143e6fad268caa8e60adac453f1b689
+MISC metadata.xml 2896 BLAKE2B e84b7e82aba212c161c6d6d00b78d365c689a131d6786b641529e32ecb69d55cdad6f0a44d6a4cac6d33643f0f721fe68891a5ce7c1f976268dbaf880a25b0ae SHA512 cd477aee55ae4147ec9e153e3c478e2d42538e364e2946837458b9d287252fb7d98e1dd79d06245e9c20c94b50d98e1729e663e2307ca2ae5b4200537f618da0
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index baf90a1a37bc..6d5558e76bbf 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -27,7 +27,6 @@
<flag name="fortran">Compile included Fortran programs</flag>
<flag name="gdml">Enable GDML writer and reader</flag>
<flag name="http">Enable http server support including but not limited to fastcgi support</flag>
- <flag name="jemalloc">Enable support for <pkg>dev-libs/jemalloc</pkg></flag>
<flag name="libcxx">Build ROOT against <pkg>sys-libs/libcxx</pkg></flag>
<flag name="memstat">Build memory statistics library, helps to detect memory leaks</flag>
<flag name="minuit">Build ROOT's internal versions of minuit (fortran) and minuit2 (C++)</flag>