summaryrefslogtreecommitdiff
path: root/sci-physics/espresso/espresso-4.1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 02:56:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 02:56:37 +0000
commit61966498b463d88a09132a9a22c68c0c37159e41 (patch)
tree25b9048d3a714990a1d984b2313aea0a9771b0e8 /sci-physics/espresso/espresso-4.1.3.ebuild
parent40a4dd47c275aca60d7381a93635d31b8d09451a (diff)
gentoo auto-resync : 30:01:2023 - 02:56:37
Diffstat (limited to 'sci-physics/espresso/espresso-4.1.3.ebuild')
-rw-r--r--sci-physics/espresso/espresso-4.1.3.ebuild122
1 files changed, 0 insertions, 122 deletions
diff --git a/sci-physics/espresso/espresso-4.1.3.ebuild b/sci-physics/espresso/espresso-4.1.3.ebuild
deleted file mode 100644
index 17f2fbd1addc..000000000000
--- a/sci-physics/espresso/espresso-4.1.3.ebuild
+++ /dev/null
@@ -1,122 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_9 )
-CMAKE_MAKEFILE_GENERATOR="emake"
-
-inherit cmake cuda python-single-r1 savedconfig
-
-DESCRIPTION="Extensible Simulation Package for Research on Soft matter"
-HOMEPAGE="http://espressomd.org"
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/${PN}md/${PN}.git"
- EGIT_BRANCH="python"
- inherit git-r3
-else
- SRC_URI="https://github.com/${PN}md/${PN}/releases/download/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="cuda doc examples +fftw +hdf5 test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- >=dev-python/cython-0.26.1[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- cuda? ( >=dev-util/nvidia-cuda-toolkit-4.2.9-r1 )
- fftw? ( sci-libs/fftw:3.0 )
- dev-libs/boost:=[mpi]
- hdf5? ( sci-libs/hdf5:=[mpi] )"
-
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen[dot]
- dev-texlive/texlive-latexextra
- virtual/latex-base )"
-
-DOCS=( AUTHORS NEWS README ChangeLog )
-
-S="${WORKDIR}/${PN}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-11.patch
-)
-
-src_prepare() {
- use cuda && cuda_src_prepare
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DWITH_CUDA=$(usex cuda)
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DWITH_TESTS=$(usex test)
- -DINSTALL_PYPRESSO=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_FFTW3=$(usex !fftw)
- -DWITH_HDF5=$(usex hdf5)
- -DCMAKE_DISABLE_FIND_PACKAGE_HDF5=$(usex !hdf5)
- -DCMAKE_SKIP_RPATH=YES
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_build doxygen
- [[ ${PV} = 9999 ]] && use doc && cmake_build ug dg tutorials
-}
-
-src_install() {
- local i docdir="${S}"
-
- cmake_src_install
-
- python_optimize
-
- insinto /usr/share/${PN}/
- doins "${BUILD_DIR}/myconfig-sample.hpp"
-
- save_config "${BUILD_DIR}/src/config/myconfig-final.hpp"
-
- if use doc; then
- [[ ${PV} = 9999 ]] && docdir="${BUILD_DIR}"
- newdoc "${docdir}"/doc/dg/dg.pdf developer_guide.pdf
- newdoc "${docdir}"/doc/ug/ug.pdf user_guide.pdf
- for i in "${docdir}/doc/tutorials/python"/*/[0-9]*.pdf; do
- newdoc "${i}" "tutorial_${i##*/}"
- done
- dodoc -r "${BUILD_DIR}/doc/doxygen/html"
- fi
-
- if use examples; then
- insinto "/usr/share/${PN}/examples/python"
- doins -r samples/${i}/.
- fi
-}
-
-pkg_postinst() {
- echo
- elog "Please read and cite:"
- elog "ESPResSo, Comput. Phys. Commun. 174(9) ,704, 2006."
- elog "https://dx.doi.org/10.1016/j.cpc.2005.10.005"
- echo
- elog "If you need more features, change"
- elog "/etc/portage/savedconfig/${CATEGORY}/${PF}"
- elog "and reemerge with USE=savedconfig"
- echo
- elog "For a full feature list see:"
- elog "/usr/share/${PN}/myconfig-sample.hpp"
- echo
-}