summaryrefslogtreecommitdiff
path: root/sci-mathematics/gap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /sci-mathematics/gap
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'sci-mathematics/gap')
-rw-r--r--sci-mathematics/gap/Manifest2
-rw-r--r--sci-mathematics/gap/gap-4.14.0_beta1.ebuild138
2 files changed, 140 insertions, 0 deletions
diff --git a/sci-mathematics/gap/Manifest b/sci-mathematics/gap/Manifest
index fc8ecc7e0985..72d1c035e64b 100644
--- a/sci-mathematics/gap/Manifest
+++ b/sci-mathematics/gap/Manifest
@@ -1,5 +1,7 @@
AUX gap-4.13.1-hash-fixes.patch 8703 BLAKE2B 84ef5cce4ef7d71229972f60886472591a3fb1c8afb132e803e82bdcbc2a8e46a10910d99d43a3b04c7120a7c44b7b8ab04ecae4bab62035ccc1327e76c0d46e SHA512 5921dbb29361aafc7aa6a14b752d7c1736a7a4b0db01c56a4a4aa8719277d8a6a6e14116f3edd9e6764fbb449e9579f334311837d0c726e97a00bbca97f2117a
DIST gap-4.13.1-core.tar.gz 38673913 BLAKE2B a63cbd2211430bfbf1bc9bb489a68a2ee7182858ccb326dfe5e6d3a7b8fb6a8c34b56a539c8b9cf3a22a1cc3a4ffe22d365b0e5229ba2c2b6d0ce6bacf0e645b SHA512 e3b74558c05e5963ea87aa77baba0edc068634072ff97b8ea0880289e53213eed82b01784db2675263d6f47547bfef259b80353ed2843ce90a77a0252c551919
+DIST gap-4.14.0-beta1-core.tar.gz 38686095 BLAKE2B dec27a1d04cc9a75e3d896e8e08c07ff2f1e7e27cbb2a5a302a840fd9ed878abc91c8efa5b172118adf96949491badc809e86c43bbdca0bb6a78ce47b6ae53e5 SHA512 e56d768a2a84a3ba82cfcfb4c3d9f39f862410cf32f04c1a173376c7e2ca5beb55ab7a7519388ca5e3b2f8118d604033a0c405d1bfa26bb974a7ac8c02f574ea
EBUILD gap-4.13.1-r1.ebuild 4008 BLAKE2B a56bc5655cf450ab304fc653354c9914861269f9bec8acb933f9cb392bba5c626156745658a89e19329e2485df2bac7cffbfd03f8bbbbb4b563186dfc34c1251 SHA512 f1dcc671f350e4962ac7869650d01c037d5dc530731f84289dd323ce31068f16edc450d4375f413f83c668403c4b4ddb3d7d753ed8f983db44425195888ad24a
EBUILD gap-4.13.1.ebuild 3952 BLAKE2B 7799ab87b5facb7cbe4934c53108a85b96725add2e61dbe0cea6fa4f5d4ef013f3d2d496da86e0d2fda2b13f1e6601fd2755d5a0671306b7d80fe14c6d599389 SHA512 53a7f462e3f7c4601a96a95a199cddc0800b187100ada6a3046aa3f502bb65f881dfc524b07676817e83ab51923c90c16ae6b7fc74f6d06a57e18cdbb5d4b0b6
+EBUILD gap-4.14.0_beta1.ebuild 3940 BLAKE2B d5b2df6c00fdfdd97a10bba50640fad285031f58d0c6306f1acb4451407304b241ceae9caf156ef6c92ed6003237608deeeee17083d139feb0db439d098520f9 SHA512 7eb3d741c955e927e7b2bc5abda6df5d2e779fd82a3317c5a574e350e1bb30bbc73a9e4ed496f12aea854f07e086b67158f41d1b1e638ed814e8e626bacbfd4f
MISC metadata.xml 1582 BLAKE2B 9151244f139b0d675e327731c336c41d5d69c25856286c182944d57255fbb6d7b1f023195b3a01c829ff6f3ea1d5e6eb6edbcc796a30120deacde82b90b5f39c SHA512 f4490e9b13cee6604f14df39ea048d7578e080a8faa97b0bb22191a7dce56904416870ed64c289f91526087009f7488e8baed4e531c78f50a5b917e9e1684ce2
diff --git a/sci-mathematics/gap/gap-4.14.0_beta1.ebuild b/sci-mathematics/gap/gap-4.14.0_beta1.ebuild
new file mode 100644
index 000000000000..2675a4683173
--- /dev/null
+++ b/sci-mathematics/gap/gap-4.14.0_beta1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit estack
+
+DESCRIPTION="System for computational discrete algebra. Core functionality."
+HOMEPAGE="https://www.gap-system.org/"
+SRC_URI="https://github.com/gap-system/gap/releases/download/v${PV/_/-}/${P/_/-}-core.tar.gz"
+
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0/9" # soname
+KEYWORDS=""
+IUSE="cpu_flags_x86_popcnt debug memcheck minimal readline test valgrind"
+REQUIRED_USE="?? ( memcheck valgrind )"
+
+RESTRICT="!test? ( test )"
+
+# The minimum set of packages needed for basic GAP operation. You can
+# actually start gap without these by passing "--bare" to it on the CLI,
+# but don't expect anything to work.
+REQUIRED_PKGS="
+ dev-gap/gapdoc
+ dev-gap/primgrp
+ dev-gap/smallgrp
+ dev-gap/transgrp"
+
+# The packages aren't really required, but GAP tries to load them
+# automatically, and will complain to the user if they fail to load.
+# The list of automatically-loaded packages is a user preference, called
+# AutoloadPackages, and the upstream default can be found in
+# lib/package.gi within the GAP source tree. Passing "-A" to GAP on the
+# CLI (or setting that user preference) will suppress the autoload
+# behavior and allow GAP to start without these, which is why we allow
+# the user to skip them with USE=minimal if he knows what he is doing.
+AUTOLOADED_PKGS="
+ dev-gap/autpgrp
+ dev-gap/alnuth
+ dev-gap/crisp
+ dev-gap/ctbllib
+ dev-gap/factint
+ dev-gap/fga
+ dev-gap/irredsol
+ dev-gap/laguna
+ dev-gap/polenta
+ dev-gap/polycyclic
+ dev-gap/resclasses
+ dev-gap/sophus
+ dev-gap/tomlib"
+
+# The test suite will fail without the "required" subset.
+BDEPEND="test? ( ${REQUIRED_PKGS} )"
+
+DEPEND="dev-libs/gmp:=
+ sys-libs/zlib
+ valgrind? ( dev-debug/valgrind )
+ readline? ( sys-libs/readline:= )"
+
+RDEPEND="${DEPEND}"
+
+# If you _really_ want to install GAP without the set of required
+# packages, use package.provided.
+PDEPEND="${REQUIRED_PKGS} !minimal? ( ${AUTOLOADED_PKGS} )"
+
+pkg_setup() {
+ if use valgrind; then
+ elog "If you enable the use of valgrind during building"
+ elog "be sure that you have enabled the proper flags"
+ elog "in gcc to support it:"
+ elog "https://wiki.gentoo.org/wiki/Debugging#Valgrind"
+ fi
+}
+
+src_prepare() {
+ # Remove these to be extra sure we don't use bundled libraries.
+ rm -r extern || die
+ rm -r hpcgap/extern || die
+
+ # The Makefile just tells you to run ./configure, which then
+ # produces a GNUmakefile.
+ rm Makefile || die
+
+ default
+}
+
+src_configure() {
+ # We unset $ABI because GAP uses it internally for something else.
+ # --without-gmp and --without-zlib both trigger an AC_MSG_ERROR
+ local myeconfargs=(
+ ABI=""
+ --with-gmp
+ --with-zlib
+ $(use_enable cpu_flags_x86_popcnt popcnt)
+ $(use_enable memcheck memory-checking)
+ $(use_enable valgrind)
+ $(use_with readline)
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Without this, the default is a quiet build.
+ emake V=1
+}
+
+src_test() {
+ # We need to specify additional root paths because otherwise the
+ # recently-built GAP doesn't know where to look for the "required"
+ # packages (which must already be installed). The two paths we
+ # append to $S are where those packages wind up.
+ local gaproots="${S}/;"
+ gaproots+="${EPREFIX}/usr/$(get_libdir)/gap/;"
+ gaproots+="${EPREFIX}/usr/share/gap/"
+
+ # GAPARGS is a Makefile variable that exists for this purpose. We
+ # use "-A" to hide the warnings about missing autoloaded-but-not-
+ # required packages. The tee/pipefail works around a glitch in
+ # dev-gap/browse that can clobber your terminal.
+ eshopts_push -o pipefail
+ emake GAPARGS="-A -l '${gaproots}'" check | tee test-suite.log \
+ || die "test suite failed, see test-suite.log"
+ eshopts_pop
+}
+
+src_install() {
+ default
+
+ # Manually install Makefile.gappkg
+ insinto usr/share/gap/etc
+ doins etc/Makefile.gappkg
+
+ # la files removal
+ find "${ED}" -type f -name '*.la' -delete || die
+}