summaryrefslogtreecommitdiff
path: root/sci-mathematics/eprover
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sci-mathematics/eprover
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sci-mathematics/eprover')
-rw-r--r--sci-mathematics/eprover/Manifest3
-rw-r--r--sci-mathematics/eprover/eprover-3.0_pre008.ebuild62
-rw-r--r--sci-mathematics/eprover/metadata.xml31
3 files changed, 96 insertions, 0 deletions
diff --git a/sci-mathematics/eprover/Manifest b/sci-mathematics/eprover/Manifest
new file mode 100644
index 000000000000..d41834b6662a
--- /dev/null
+++ b/sci-mathematics/eprover/Manifest
@@ -0,0 +1,3 @@
+DIST eprover-3.0_pre008.tar.gz 1512310 BLAKE2B 88533bd05b823155639df49d631f4fb339019f624ea6cb1c3c7c46f1db331183dac4285c70a7efa372cbf3f0e839ec41b7589b93e4599a6ed94f42734f361985 SHA512 81f1a1dfd77b685805c80f95b683489d8759acbb5b45ebaf123f1b0f7cb82f9e2d58731975e5286afa9a8bf9d2874cc5362edc0c0da92aea39830ac4b8b1c4ec
+EBUILD eprover-3.0_pre008.ebuild 1346 BLAKE2B 1a0ca2e7e9ffffe70d340f808310723251da6be5e7133865c330c8faaf936c29b9d888c65b141045d53b385e45fbbd629c515be33331c7e08fa1e79596f15d4d SHA512 b23f0cbe5df739887bc54448f9e082d9811781cbedefe2adb0f89d2db6cdf272242b76a0e97dc0e79946f9d2cd87d607e929db64dde22a5ad70f5af0f49dbe09
+MISC metadata.xml 1534 BLAKE2B f53ad8e4eeccf361718ecbe735f72fbb0645478dd5a3c7b1e6baab718c1a15e9852c11d0074181b48b2402065b090fe95ba65cdc6bed4e84ff6e59aa6174446b SHA512 08caa0f223c5aa25935cba3cf12e11af77e59fc364b26a1aab9d622500245cd7a650143b1fe14bc3dc377e40f6b3018048c567dff40557e70738618a205e9743
diff --git a/sci-mathematics/eprover/eprover-3.0_pre008.ebuild b/sci-mathematics/eprover/eprover-3.0_pre008.ebuild
new file mode 100644
index 000000000000..0a693b56b539
--- /dev/null
+++ b/sci-mathematics/eprover/eprover-3.0_pre008.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automated theorem prover for full first-order logic with equality"
+HOMEPAGE="https://www.eprover.org/
+ https://github.com/eprover/eprover/"
+SRC_URI="https://github.com/eprover/${PN}/archive/E-${PV/_/}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-E-${PV/_/}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ho"
+
+BDEPEND="sys-apps/help2man"
+
+src_prepare() {
+ default
+
+ sed -e "/^OPTFLAGS/s|= .*|= ${CFLAGS}|" \
+ -e "/^LD/s|= .*|= $(tc-getCC) ${LDFLAGS}|" \
+ -e "/^ AR/s|ar|$(tc-getAR)|" \
+ -e "/^ CC/s|gcc|$(tc-getCC)|" \
+ -i "${S}"/Makefile.vars || die
+}
+
+src_configure() {
+ local -a myconf=(
+ $(usex ho '--enable-ho' '')
+ --bindir=/usr/bin
+ --exec-prefix=/usr
+ --man-prefix=/usr/share/man/man1
+ )
+ sh ./configure ${myconf[@]} || die
+}
+
+src_compile() {
+ default
+
+ if use ho ; then
+ ln -s "${S}"/PROVER/${PN}-ho "${S}"/PROVER/${PN} || die
+ fi
+
+ emake man
+}
+
+src_install() {
+ # Picosat (CONTRIB package) is available as separate package.
+ rm -r "${S}"/CONTRIB || die
+
+ emake EXECPATH="${ED}"/usr/bin MANPATH="${ED}"/usr/share/man/man1 install
+ dodoc -r DOC EXAMPLE_PROBLEMS
+
+ if use ho ; then
+ dosym -r /usr/bin/${PN}-ho /usr/bin/${PN}
+ fi
+}
diff --git a/sci-mathematics/eprover/metadata.xml b/sci-mathematics/eprover/metadata.xml
new file mode 100644
index 000000000000..9a9970613884
--- /dev/null
+++ b/sci-mathematics/eprover/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ E is a theorem prover for full first-order logic with equality. It accepts
+ a problem specification, typically consisting of a number of first-order
+ clauses or formulas, and a conjecture, again either in clausal or full
+ first-order form. The system will then try to find a formal proof for the
+ conjecture, assuming the axioms. If a proof is found, the system can
+ provide a detailed list of proof steps that can be individually verified.
+ If the conjecture is existential (i.e. it is of the form "there exists an X
+ with property P"), more recent versions can also provide possible answers
+ (values for X). Development of E started as part of the E-SETHEO project at
+ TUM. The first public release was in in 1998, and the system has been
+ continuously improved ever since. I believe that E now is one of the most
+ powerful and friendly reasoning systems for first-order logic. The prover
+ has successfully participated in many competitions.
+ </longdescription>
+ <use>
+ <flag name="ho">enable support for higher-order logic</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/eprover/eprover/issues/</bugs-to>
+ <remote-id type="github">eprover/eprover</remote-id>
+ </upstream>
+</pkgmetadata>