summaryrefslogtreecommitdiff
path: root/sci-mathematics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sci-mathematics
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/Manifest.gzbin17212 -> 17381 bytes
-rw-r--r--sci-mathematics/eprover/Manifest3
-rw-r--r--sci-mathematics/eprover/eprover-3.0_pre008.ebuild62
-rw-r--r--sci-mathematics/eprover/metadata.xml31
-rw-r--r--sci-mathematics/wxmaxima/Manifest2
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild79
6 files changed, 177 insertions, 0 deletions
diff --git a/sci-mathematics/Manifest.gz b/sci-mathematics/Manifest.gz
index ccf641c870a4..74b2f95fb8a0 100644
--- a/sci-mathematics/Manifest.gz
+++ b/sci-mathematics/Manifest.gz
Binary files differ
diff --git a/sci-mathematics/eprover/Manifest b/sci-mathematics/eprover/Manifest
new file mode 100644
index 000000000000..d41834b6662a
--- /dev/null
+++ b/sci-mathematics/eprover/Manifest
@@ -0,0 +1,3 @@
+DIST eprover-3.0_pre008.tar.gz 1512310 BLAKE2B 88533bd05b823155639df49d631f4fb339019f624ea6cb1c3c7c46f1db331183dac4285c70a7efa372cbf3f0e839ec41b7589b93e4599a6ed94f42734f361985 SHA512 81f1a1dfd77b685805c80f95b683489d8759acbb5b45ebaf123f1b0f7cb82f9e2d58731975e5286afa9a8bf9d2874cc5362edc0c0da92aea39830ac4b8b1c4ec
+EBUILD eprover-3.0_pre008.ebuild 1346 BLAKE2B 1a0ca2e7e9ffffe70d340f808310723251da6be5e7133865c330c8faaf936c29b9d888c65b141045d53b385e45fbbd629c515be33331c7e08fa1e79596f15d4d SHA512 b23f0cbe5df739887bc54448f9e082d9811781cbedefe2adb0f89d2db6cdf272242b76a0e97dc0e79946f9d2cd87d607e929db64dde22a5ad70f5af0f49dbe09
+MISC metadata.xml 1534 BLAKE2B f53ad8e4eeccf361718ecbe735f72fbb0645478dd5a3c7b1e6baab718c1a15e9852c11d0074181b48b2402065b090fe95ba65cdc6bed4e84ff6e59aa6174446b SHA512 08caa0f223c5aa25935cba3cf12e11af77e59fc364b26a1aab9d622500245cd7a650143b1fe14bc3dc377e40f6b3018048c567dff40557e70738618a205e9743
diff --git a/sci-mathematics/eprover/eprover-3.0_pre008.ebuild b/sci-mathematics/eprover/eprover-3.0_pre008.ebuild
new file mode 100644
index 000000000000..0a693b56b539
--- /dev/null
+++ b/sci-mathematics/eprover/eprover-3.0_pre008.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Automated theorem prover for full first-order logic with equality"
+HOMEPAGE="https://www.eprover.org/
+ https://github.com/eprover/eprover/"
+SRC_URI="https://github.com/eprover/${PN}/archive/E-${PV/_/}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-E-${PV/_/}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ho"
+
+BDEPEND="sys-apps/help2man"
+
+src_prepare() {
+ default
+
+ sed -e "/^OPTFLAGS/s|= .*|= ${CFLAGS}|" \
+ -e "/^LD/s|= .*|= $(tc-getCC) ${LDFLAGS}|" \
+ -e "/^ AR/s|ar|$(tc-getAR)|" \
+ -e "/^ CC/s|gcc|$(tc-getCC)|" \
+ -i "${S}"/Makefile.vars || die
+}
+
+src_configure() {
+ local -a myconf=(
+ $(usex ho '--enable-ho' '')
+ --bindir=/usr/bin
+ --exec-prefix=/usr
+ --man-prefix=/usr/share/man/man1
+ )
+ sh ./configure ${myconf[@]} || die
+}
+
+src_compile() {
+ default
+
+ if use ho ; then
+ ln -s "${S}"/PROVER/${PN}-ho "${S}"/PROVER/${PN} || die
+ fi
+
+ emake man
+}
+
+src_install() {
+ # Picosat (CONTRIB package) is available as separate package.
+ rm -r "${S}"/CONTRIB || die
+
+ emake EXECPATH="${ED}"/usr/bin MANPATH="${ED}"/usr/share/man/man1 install
+ dodoc -r DOC EXAMPLE_PROBLEMS
+
+ if use ho ; then
+ dosym -r /usr/bin/${PN}-ho /usr/bin/${PN}
+ fi
+}
diff --git a/sci-mathematics/eprover/metadata.xml b/sci-mathematics/eprover/metadata.xml
new file mode 100644
index 000000000000..9a9970613884
--- /dev/null
+++ b/sci-mathematics/eprover/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription>
+ E is a theorem prover for full first-order logic with equality. It accepts
+ a problem specification, typically consisting of a number of first-order
+ clauses or formulas, and a conjecture, again either in clausal or full
+ first-order form. The system will then try to find a formal proof for the
+ conjecture, assuming the axioms. If a proof is found, the system can
+ provide a detailed list of proof steps that can be individually verified.
+ If the conjecture is existential (i.e. it is of the form "there exists an X
+ with property P"), more recent versions can also provide possible answers
+ (values for X). Development of E started as part of the E-SETHEO project at
+ TUM. The first public release was in in 1998, and the system has been
+ continuously improved ever since. I believe that E now is one of the most
+ powerful and friendly reasoning systems for first-order logic. The prover
+ has successfully participated in many competitions.
+ </longdescription>
+ <use>
+ <flag name="ho">enable support for higher-order logic</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/eprover/eprover/issues/</bugs-to>
+ <remote-id type="github">eprover/eprover</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index edb911098c81..1e7f0e7b1b25 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,7 +1,9 @@
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-22.05.0.tar.gz 21493488 BLAKE2B 0b1f4bd65e88e4f39d5d54f164373ca67a76bd2a18a1556cd4b86cdb5a62ca3f0c783c6e1725ec1006f6174163f08b7b934dcfa3fd8a8a7aa34e61588e1b0cb1 SHA512 e78ce86d3265b8c5d1d9b110075bdc8e3ff180a0a017142f852b022a1984e7e9bf0a4b7d2fb829f8c87b09899ef57a6e8ee203ec7edac52e7d05f0a05d2c9fe8
DIST wxmaxima-22.09.0.tar.gz 21883782 BLAKE2B 370ea04f5101516fda494c08e21c1550556ff69e61e0458814aeb0922c66ae1b4a1be1e0b4d386f631b0479300fec04481f7f9e4be4214689b9bc0b9bd41f0f1 SHA512 778d3f221315f40f09918baaf26a4213dae3154ea19479c5ebf9254ed6c8036ca68f61472fce1d63e72d6c23787a635237c5f85ebc2975254893e6bec112ac3b
+DIST wxmaxima-22.12.0.tar.gz 23673254 BLAKE2B b00536c6b6243555f4c00016202d68f9764a2e1ec4c910ee52d7e0b498a5695c3f4746809e594179cda75ec40caeca1a01e21a11c211c329ec2685a8e6217e4e SHA512 842a4c891d757d17307a9bed17f5ffffde9f55e72b749e2356817a1598760b6a16fb9ce8e21f4706530bbe2360400de01b9269872d895944924d8e3eebfc31dc
EBUILD wxmaxima-20.12.2.ebuild 1428 BLAKE2B 30e26a147fe84b328902bedb1ee7df68a6c27d203b9b6e900096d931091ce51cce41d22e45fe779bb4144949b1ebcf259fbd085cc4e2f992e495405c5176410d SHA512 823b28ad77dfa70536103b64735ec68cdefe38abeec760b15acb6904f7f8f97d6ace10eec836f0536ff576f7711b2d135a989072087ae67d133506a301920882
EBUILD wxmaxima-22.05.0.ebuild 1893 BLAKE2B e83faab0df73eb403b223b6698b1fb1d8f806f40b485023f5a7b31477f2aa6949585ae677afa59a5ffc127528213e6b0ecafc88168b7d0e9e2fb916179e11c93 SHA512 acff61ffbadf7d193630ecdc2bdcbab2a483757f4d67a944e28e78793c43b26d0e85d0214f24e1de8fc7e463ac2d53ff8efa87e591fc4961d3878470d5846ed0
EBUILD wxmaxima-22.09.0.ebuild 1901 BLAKE2B 4eec649f59d4b941a3968023b6f4d31c257a15cdc43f96a3ca873a850afdb5a8992928816bf48bccde50a6216b4a93b01e37c8e6ad84708b33e32f4d44dbb6f7 SHA512 7ae6fbc815e3b8758e57c50877f66e04db096e6f245b44cea4b4bba5fb549bc77ee3a220870188965ddde6e94c1540cc6cb8eb8e50cc5a581f6e06e04e8bbaa5
+EBUILD wxmaxima-22.12.0.ebuild 1901 BLAKE2B 7c6834bf45bd13bc889fd06a0b115f79b3d71f913f3a982af15eee7130900d152058c817e4908112d52d0f6a9dcb1eabc2a99987ea9e5306b8205fa68cf780e2 SHA512 651f5d701a5d346c744fd15d2094545b61615a3837d53e1b124be0507b4f5c29ad80bf98a1c1691645ec0caea851093cf7250ad9d9a94fc54bd722f15df874ec
MISC metadata.xml 736 BLAKE2B fb5db64266afc69d42ab7ca857e9022d20e5306d04403859c847caf8d36953820ad9920212f164a74c1e2a807b111c0cffbbdfd4b098049e3bf689a9958b0b6d SHA512 318a52fafba636ef7439d52b936a3aa144e810077e381d367a8d1cc12529e085a3b84f873591ee9f9b613a5f71285a1f1f5b3ceedbd619e79c717a375e3c5e95
diff --git a/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild
new file mode 100644
index 000000000000..552ce4da0c45
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-22.12.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake plocale wxwidgets xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}[webkit]"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ plocale_find_changes locales/wxMaxima '' '.po'
+ plocale_for_each_disabled_locale rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}